"‘ TELEDYNE LECROY

Everywhereyoulook

Operator's Manual
WaveRunner 8000
Oscilloscopes



"‘ TELEDYNE LECROY

Everywhereyoulook

WaveRunner 8000 Oscilloscopes Instruction Manual

© 2017 Teledyne LeCroy, Inc. All rights reserved.

Unauthorized duplication of Teledyne LeCroy, Inc. documentation materials other than for internal sales and
distribution purposes is strictly prohibited. However, clients are encouraged to duplicate and distribute Teledyne
LeCroy, Inc. documentation for their own internal educational purposes.

WaveRunner and Teledyne LeCroy, Inc. are trademarks of Teledyne LeCroy, Inc., Inc. Other product or brand
names are trademarks or requested trademarks of their respective holders. Information in this publication
supersedes all earlier versions. Specifications are subject to change without notice.

926881 Rev C
May 2017



Contents

S O Y 1
SYMIONS 1
P AUt ONS 1
Operating ENVIrONmM et _ 2
CO0NING - 2
ClaNING . 2
PO BT 3
OSCIlOSCOPE OV W L 5
Front of OSCIlOSCOPE .. ... e 5
Side of OSCIIOSCOPE ... .. 6
Back Of OSCIllOSCOPE . ... 7
B oMt P ANl L 8
SIgNAl I I ACES ..o 11
0SCIIOSCOPE SOt U .o 13
POWerING ON/ O 13
SOftWare ACTIVA I ON L 13
Connecting to Other DeviCes/SYSteMS .. e 14
LanguUage SeleCtiON L 16
USING MAUL 17
T OUCK SO N e 17
ONE T OUCH HeID e 24
WOrKING WIth TraCes ..o 31
ZOOMUNG - oo 35
PN/ SCrEEN CaD UIE . 39
ACQUISTI ON 41
AAUTO S U o 41
VIEWING S atUS L 42
VIt Cal 42
Digital (Mixed SIgNal) 48
TIME DS 51
TGO 59
OIS PlAY 75
MU G DISPIaY .. 75
Q-Scape Multi-Tabbed Display . ... 76
DISPIaY SOt U L 77
PerSIStENCE DISPlaY .. .. 81




WaveRunner 8000 Oscilloscopes Instruction Manual

Math and MeaSUIE ... 83
CU SO S il 83
AU 86
TN 109
M N O Y il 126

ANAlYSIS TOO S ... 129
N A S C AN il 129
PaSS/Fall TeSHING - 135

Saving Data (File FUNCHIONS) ... . e 139
SV il 139
AUTO SV il 144
RECAIl 145
LabNOtEDOOK 147
RO GO AT OF e 152
SN 153
P It 154
Email & RePOrt SetNGS .o 155
USING the File BrOW ST . 156

U eS o l 159
ULIITIES DIAIOT - .. oo 159
S AU il 159
RemMOte CONTIOl 160
AUXIANY UL DU < e 162
DAt TN e 163
Ot ONS e 164
DISK Ut S L 165
PreferenCes SEtINGS ... 166
Cali o atiON 167
A CQUISIE I ON e 169
GOl OT 170
MISCEIIANEOUS ... .. L 177

M ENANCE . 173
Touch Screen Calibration .. ... 173
Restart/Reboot INStrUM Nt .. 173
Firmware Update .. 174
TeChNICAl SUP PO e 175
Returning a ProdUct fOr ServiCe ... 176




CartifiCAtiONS <o 177

EMC COMPlIANCE ..o 177
Safety ComMPlIANCE . ... 178
Environmental CompPlianCe ... 179
LSO Certif I CatiON 179
N BT ANy il 180
IntellectUal PrOPeItY 180
WiINAOWS LICENSE AQreemMIENT .. 180
INAEX 181




WaveRunner 8000 Oscilloscopes Instruction Manual

Welcome

Thank you for purchasing a Teledyne LeCroy WaveRunner oscilloscope. We're certain you'll be pleased
with the detailed features unique to our instruments.

Take a moment to verify that all items on the packing list or invoice copy have been shipped to you.
Contact your nearest Teledyne LeCroy customer service center or national distributor if anything is
missing or damaged. We can only be responsible for replacement if you contact us immediately.

We truly hope you enjoy using Teledyne LeCroy's fine products.

Sincerely,

A-/%:L

David C. Graef

Vice President and General Manager, Oscilloscopes
Teledyne LeCroy




Safety

Safety

To maintain the instrument in a correct and safe condition, observe generally accepted safety procedures
in addition to the precautions specified in this section. The overall safety of any system incorporating
this product is the responsibility of the assembler of the system.

Symbols

These symbols appear on the instrument or in documentation to alert you to important safety concerns:

A Caution of potential damage to instrument or Warning of potential bodily injury. Do not proceed until
the information is fully understood and conditions are met.

A Caution, high voltage; risk of electric shock or burn.
AZA Caution, contains parts/assemblies susceptible to damage by Electrostatic Discharge (ESD).

/—Jﬂ Frame or chassis terminal (ground connection).

Alternating current.

(D Standby power (front of instrument).

Precautions

A Caution: Comply with the following to avoid personal injury or damage to your equipment.

Use indoors only within the operational environment listed. Do not use in wet or explosive atmospheres.

Maintain ground. This product is grounded through the power cord grounding conductor. To avoid electric
shock, connect only to a grounded mating outlet.

Connect and disconnect properly. Do not connect/disconnect probes, test leads, or cables while they are
connected to a live voltage source.

Observe all terminal ratings. Do not apply a voltage to any input that exceeds the maximum rating of that
input. Refer to the body of the instrument for maximum input ratings.

Use only power cord shipped with this instrument and certified for the country of use.

Keep product surfaces clean and dry. See Cleaning.

Do not remove the covers or inside parts. Refer all maintenance to qualified service personnel.
Execise care when lifting. Use the built-in carrying handle.

Do not operate with suspected failures. Do not use the product if any part is damaged. Obviously
incorrect measurement behaviors (such as failure to calibrate) might indicate hazardous live electrical
quantities. Cease operation immediately and secure the instrument from inadvertent use.
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Operating Environment
Temperature: 5to 40° C.

Humidity: Maximum relative humidity 90 % for temperatures up to 31° C, decreasing linearly to 50%
relative humidity at 40° C.

Altitude: Up to 3,000 m at or below 30° C.

Cooling

The instrument relies on forced air cooling with internal fans and vents. Take care to avoid restricting the
airflow to any part. In a benchtop configuration, leave a minimum of 15 cm (6 inches) around the sides
between the instrument and the nearest object. The feet provide adequate bottom clearance. Follow
rackmount instructions for proper rack spacing.

A Caution: Do not block the cooling vents.

The instrument also has internal fan control circuitry that regulates the fan speed based on the ambient
temperature. This is performed automatically after start-up.

Cleaning

Clean only the exterior of the instrument using a soft cloth moistened with water or an isopropy! alcohol
solution. Do not use harsh chemicals or abrasive elements. Under no circumstances submerge the
instrument or allow moisture to penetrate it. Dry the instrument thoroughly before connecting a live
voltage source.

Caution: Unplug the power cord from the AC inlet before cleaning to avoid electric shock. Do not
attempt to clean internal parts. Refer all maintenance to qualified service personnel.




Safety

Power

AC Power

The instrument operates from a single-phase, 100-240 Vrms (£ 10%) AC power source at 50/60 Hz (+ 5%)
ora 100-120 Vrms (£ 10%) AC power source at 400 Hz (+ 5%). Manual voltage selection is not required
because the instrument automatically adapts to the line voltage.

Power Consumption

Maximum power consumption with all accessories installed (e.g., active probes, USB peripherals, digital
leadset) is 375 W (375 VA) for non-"M" models and 500 W (500 VA) for "M" models. Power consumption in
Standby mode is 15 W.

Ground

The AC inlet ground is connected directly to the frame of the instrument. For adequate protection again
electric shock, connect to a mating outlet with a safety ground contact.

Caution; Use only the power cord provided with your instrument. Interrupting the protective
conductor (inside or outside the case), or disconnecting the safety ground terminal, creates a
hazardous situation. Intentional interruption is prohibited.
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Oscilloscope Overview

Oscilloscope Overview

Front of Oscilloscope
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Touch screen display
Front panel

Built-in stylus holder
Power button
Channelinputs (C1-C4)

Ext input
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Aux output
USB 2.0 port
Mixed-Signal Interface

Ground and Calibration output
terminals

Tilting feet
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Side of Oscilloscope

. USB 2.0 ports (2)

. Ethernet port for connecting to

LAN or remote control

. DisplayPort ports (2) for

connecting external monitor

. USB 3.1 ports (4)
. DVI port for external monitor

. Audio In/Out (mic, speaker, and

line-in) for connecting external
audio devices

. USBTMC port for remote

control
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Back of Oscilloscope

Built-in carrying handle
Ref Out and Ref In for external reference clock

AC power inlet

o o wor

Kensington lock
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Front Panel

Trigger

Horizontal Vertical

b

Cursors Adjust

meets the trigger conditions.

my
- B
g
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Front panel controls duplicate functionality available through the
touch screen and are described here only briefly.

Knobs on the front panel function one way if turned and another if
pushed like a button. The first label describes the knob's “turn”
action, the second label its “push”action. Actions performed from

the front panel always apply to the active trace.

Many buttons light to show the active traces and functions.

Trigger Controls

The front panel Level knob changes the trigger threshold level
(V). The number is shown on the Trigger descriptor box. Pushing
the knob sets the trigger level to the 50% point of the input signal.

The READY indicator is lit when the trigger isarmed. TRIG'D is lit
momentarily when a trigger occurs.

Setup opens the Trigger Setup dialog. Press it again to close the
dialog.

Auto sets Auto mode, which triggers the oscilloscope after a set
time, even if the trigger conditions are not met.

Normal sets Normal mode, which triggers the oscilloscope each
time a signal is present that meets the trigger conditions.

Single sets Single trigger mode. The first press readies the
oscilloscope to trigger. The second press arms and triggers the
oscilloscope once (single-shot acquisition) when the input signal

Stop prevents the scope from triggering on a signal. If you boot up the instrument with the trigger in Stop
mode, a "No trace available" message is shown. Press the Auto button to display a trace.

Horizontal Controls

Turn the Delay knob to change the Trigger Delay value (S). Push the knob to reset Delay to zero.

If the trace source is an input channel, turn the Horizontal Adjust knob to set the Time/division (S) of the
oscilloscope acquisition system. The value is shown on the Timebase descriptor box. When using this
control, the oscilloscope allocates memory as needed to maintain the highest sample rate possible for the
timebase setting. If the trace source is a zoom, memory or math function, turn the knob to change the
horizontal scale of the trace, effectively "zooming" in or out. The value is shown on the corresponding
descriptor box. Push the knob to change the setting in fine increments; push it again toreturnto 1, 2, 5, 10-

step increments.
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Vertical Controls
Offset knob adjusts the zero level of the trace (this makes it appear to move up or down relative to the
center axis of the grid). The value appears on the trace descriptor box. Push it to reset Offset to zero.

Gain knob sets Vertical Gain (\V/div). The value appears on the trace descriptor box. Push it once to adjust
V/divin fine increments; push it again to adjust in 1, 2, 5, 10-step increments.

The Channel buttons (1-4) turn on a channel that is off, or activate a channel that is already on. When the
channelis active, pushing its channel button turns it off. A lit button shows the active channel.

Dig button enables digital input on -MS models.

Math, Zoom, and Mem Buttons

The front panel Zoom button creates a quick zoom of each open channel trace. The resulting zoom traces
are 1/10 of the channel timebase and centered on the display. Touch the zoom trace descriptor box to
display the zoom controls and adjust this. Touch the Zoom button again to turn off the zooms.

The Math and Mem(ory) buttons open the corresponding setup dialogs.

Cursor Controls

Cursors identify specific voltage and time values on the waveform. The white cursor markers help make
these points more visible, as well as provide a simple way to reposition them. A readout of the values
appears on the trace descriptor box.

There are five preset cursor types, each with a unique appearance on the display. These are described in
more detail in the Cursors section.

Press the front panel Type button to apply or remove cursors. Continue pressing to cycle through all cursor
types until the desired type is found ("no cursors" will appear in the cycle).

Turn the Cursor knob to reposition the selected cursor line. Push it to select a different cursor line to
adjust.

Adjust & Intensity

The front panel Adjust knob changes the value in active (highlighted) data entry fields that do not have
dedicated knobs. Pushing Adjust toggles between coarse (large increment) or fine (small increment)
adjustments when the knob is turned.

The Intensity button sets the Adjust knob to control the trace intensity. When more data is available than
can actually be displayed, the Intensity button helps to visualize significant events by applying an algorithm
that dims less frequently occurring samples. This feature can also be accessed from the Display Setup
dialog.
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Miscellaneous Controls

These miscellaneous controls also appear along the top and bottom rows of the front panel.

Auto Setup performs an Auto Setup. After the first press, you will be prompted for a confirmation. Press
the button again or use the touch screen to confirm.

Default Setup resets the oscilloscope to the factory default configuration. After the first press, you will be
prompted for a confirmation. Press the button again or use the touch screen to confirm.

Print captures the entire screen and outputs it according to your Print settings.

Touch Screen toggles on/off touch screen functionality.

Clear Sweeps resets the acquisition counter and any cumulative measurements.
Decode opens the Serial Decode dialog if you have serial data decoder options installed.
WaveScan opens the WaveScan dialog.

Spectrum opens the Spectrum Analyzer dialog if you have that option installed.

History opens the History Mode dialog.

10



Oscilloscope Overview

Signal Interfaces

The instrument offers a variety of interfaces for using probes or other devices to input analog or digital
signals. See the product page at teledynelecroy.com for a list of compatible devices.

Analog Inputs

A series of connectors arranged on the front of the instrument are used to input analog signals on
channels 1-4. EXT can be used to input an external trigger pulse or sample clock signal.

WaveRunner 8000 channel connectors use the ProBus interface. The ProBus interface contains a 6-pin
power and communication connection and a BNC signal connection to the probe. It includes sense rings
for detecting passive probes and accepts a BNC cable connected directly to it. ProBus offers 50 Q and 1

MQ input impedance and control for a wide range of probes.

The channel interfaces power probes and completely integrate the probe with the channel. Upon
connection, the probe type is recognized and some setup information, such as input coupling and
attenuation, is performed automatically. This information is displayed on the Probe Dialog, behind the
Channel (Cx) dialog. System (probe plus instrument) gain settings are automatically calculated and
displayed based on the probe attenuation.

Probes

The oscilloscope is compatible with the included passive probes and most Teledyne LeCroy ProBus active
probes that are rated for the instrument’s bandwidth. Probe specifications and documentation are
available at teledynelecroy.com/probes.

Passive Probes

The passive probes supplied are matched to the input impedance of the instrument but may need further
compensation. If using other passive probes, be sure to perform a low frequency calibration using the Cal
signal available from the front panel before using them to measure signal. Follow the directions in the
probe instruction manual to compensate the frequency response of the probes.

Active Probes

Most active probes match probe to oscilloscope response automatically using probe response data stored
in an on-board EEPROM. This ensures the best possible combined probe plus oscilloscope channel
frequency response without the need to perform any de-embedding procedure.

Be aware that many active probes require a minimum oscilloscope firmware version to be fully
operational. See the probe documentation.

11
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Digital Leadset

The digital leadset provided with -MS model
oscilloscopes enables input of up-to-16 lines of
digital data. Lines can be organized into four
logical groups and renamed appropriately.

The digital leadset features two digital banks with
separate Threshold controls, making it possible to
simultaneously view data from different logic
families.

Z
!
Connecting/Disconnecting the Leadset

The digital leadset connects to the Mixed Signal interface on the front of the instrument.

To connect the leadset to the instrument, push the connector into the Mixed Signal interface below the
front panel until you hear a click.

Toremove the leadset, press and hold the buttons on each side of the connector, then pull out to release.

Grounding Leads

Each flying lead has a signal and a ground connection. A variety of ground extenders and flying ground
leads are available for different probing needs.

To achieve optimal signal integrity, connect the ground at the tip of the flying lead for each input used in
your measurements. Use either the provided ground extenders or ground flying leads to make the ground
connection.

12



Oscilloscope Set Up

Oscilloscope Set Up
Powering On/Off

d) Press the Power button to turn on the instrument. The X-Stream application loads automatically
when you use the Power button.

Caution: Do not change the instrument’'s Windows® Power Options setting from the default Never
to System Standby or System Hibernate. Doing so can cause the system to fail.

A Caution: Do not power on or calibrate with a signal attached.

The safest way to power down the oscilloscope is to use the File > Shutdown menu option, which will
always execute a proper shut down process and preserve settings. Quickly pressing the power button
should also execute a proper shut down, but holding the Power button will execute a *hard” shut down (as
on a computer), which we do not recommend doing because it does not allow the Windows operating
system to close properly, and setup data may be lost. Never power off by pulling the power cord from the
socket or powering off a connected power strip or battery without first shutting down properly.

The Power button does not disconnect the instrument from the AC power supply. The only way to fully
power down the instrument is to unplug the AC power cord.

We recommend unplugging the instrument if it will remain unused for a long period of time.

Software Activation

The operating software (firmware and standard applications) is active upon delivery. At power-up, the
instrument loads the software automatically.

Firmware
Free firmware updates are available periodically from the Teledyne LeCroy website at:

teledynelecroy.com/support/softwaredownload

Registered users can receive an email notification when a new update is released. Follow the instructions
on the website to download and install the software.

Purchased Options

If you decide to purchase an option, you will receive a license key via email that activates the optional
features. See Options for instructions on activating optional software packages.

13


http://teledynelecroy.com/support/softwaredownload

WaveRunner 8000 Oscilloscopes Instruction Manual

Connecting to Other Devices/Systems

Make all desired cable connections. After start up, configure the connections using the menu options
listed below. More detailed instructions are provided later in this manual.

LAN

The instrument accepts DHCP network addressing. Connect a cable from the Ethernet port on the side
panel to a network access device. Go to Utilities > Utilities Setup > Remote to find the IP address.

To assign a static IP address, choose Net Connections from the Remote dialog. Use the standard
Windows networking dialogs to configure the device address.

Choose File > File Sharing and open the Email & Report Settings dialog to configure email settings.

USB Peripherals

Connect the device to a USB port on the front or of the instrument. These connections are "plug-and-play”
and do not require any additional configuration.

Printer

WaveRunner 8000 series oscilloscopes support USB printers compatible with the instrument's Windows
OS. Goto File > Print Setup and select Printer to configure printer settings. Select Properties to open the
Windows Print dialog.

External Monitor

You may operate the instrument using the built-in touch screen or attach an external monitor for extended
desktop operation. The WaveRunner 8000 supports WQXGA monitors with 2560x1600 resolution.

Note: The oscilloscope display utilizes Fujitsu touch-screen drivers. Because of conflicts, external
monitors with Fujitsu drivers can not be used to control the system, only as displays.

Connect the monitor cable to the DisplayPort connector on the side of the instrument (you can use an
adaptor if the monitor cable has a different interface). Monitors with DVI-D interfaces are also supported.
Goto Display > Display Setup > Open Monitor Control Panel to configure the display. Be sure to select the
instrument as the primary monitor.

To use the Extend Grids feature, configure the second monitor to extend, not duplicate, the oscilloscope
display. If the external monitor is touch screen enabled, the MAUI user interface can be controlled
through touch on the external monitor.

14



Oscilloscope Set Up

Remote Control

Go to Utilities > Utilities Setup > Remote to configure remote control. Connect the devices using the cable
type required by your selection. TCP/IP over Ethernet is generally supported, as is USB over the USBTMC
connection. GPIB is also supported with the correct hardware option installed.

Sample Clock

To input an external sample clock signal, connect a BNC cable from the EXT input to the other device. Go
to Timebase > Horizontal Setup > Clock Source to configure the clock.

Reference Clock

To either input or output a reference clock signal, connect a BNC cable from the Ref In or Ref Out
connector to the other instrument. Go to Timebase > Horizontal Setup > Clock Source to configure the
clock.

Auxilliary Output

To output signal from the instrument to another device, connect a BNC cable from Aux Out to the other
device. Go to Utilities > Utilities Setup > Aux Output to configure the output.

15
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Language Selection

To change the language that appears on the touch screen:

1.
2.

Goto Utilities > Preference Setup > Preferences and make a Language selection.

Follow the prompt to restart the application.

To also change the language of the Windows operating system dialogs:

1.

2
3
4.
5
6

~

g

Choose File > Minimize to hide X-Stream and show the Windows Desktop.

. From the Windows task bar, choose Start > Control Panel > Clock, Language and Region.

. Under Region and Language select Change Display Language.

Touch the Install/Uninstall Languages button.

. Select Install Language and Browse Computer or Network.

. Touch the Browse button, navigate to D:\Lang Packs\ and select the language you want to install.

The available languages are: German, Spanish, French, Italian, and Japanese. Follow the installer
prompts.

Reboot after changing the language.

Note: Other language packs are available from Microsoft's website.

16



Using MAUI

Using MAUI

MAUI, the Most Advanced User Interface, is Teledyne LeCroy's unique oscilloscope user interface. MAUI is
designed for touch—allimportant controls for vertical, horizontal, and trigger are only one touch away.

Touch Screen

The touch screenis the principal viewing and control center. The entire display area is active: use your
finger or a stylus to touch, drag, swipe, or draw a selection box.

Many controls that display information also work as “buttons” to access other functions. If you have a
mouse installed, you can click anywhere you can touch to activate a control; in fact, you can alternate
between clicking and touching, whichever is convenient for you.

The touch screen is divided into the following major control groups:
e Menu bar
e Gridarea

« Descriptor boxes

« Dialogs
« Message Bar

Menu Bar

The top of the window contains a complete menu of functions. Making a selection here changes the
dialogs displayed at the bottom of the screen.

While many common operations can also be performed from the front panel or launched via the
descriptor boxes, the menu bar is the best way to access dialogs for Save/Recall (File) functions, Display
functions, Status, LabNotebook, Pass/Fail setup, and Utilities/Preferences setup.

You will see a Q-Scape m control added to the menu bar when the Q-Scape option is
installed. This allows you to choose different tabbed display configurations. See Display.

L |_j [n]

If an action can be “undone”, a small Undo &8l button appears at the far right of the menu bar. Click this
to restore the oscilloscope to the state prior to the action.

17
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Grid Area

The grid area displays the waveform traces. Every grid is 8 Vertical divisions representing 256 Vertical
levels and 10 Horizontal divisions each representing acquisition time. The value represented by Vertical
and Horizontal divisions depends on the Vertical and Horizontal scale of the traces that appear on the grid.

Multi-Grid Display

The grid area can be divided into multiple grids showing different types and numbers of traces (in Auto
Grid mode, it will divide automatically as needed). Regardless of the number and orientation of grids, every
grid always represents the same number of Vertical levels. Therefore, absolute Vertical measurement
precision is maintained.

(] File = § Vertical 4 Timebase | [ Trigger & Display = # Cursors | E Measure & Math | Anal N Utilities = @ Support Zoom ”:'—j

100 #

F1 hist{C2] Timebase 0.00 sfTrigger 1 1218
1.00 V/div | A\ Incompatible 1.00 Vidiv | 500 ms/div Stop 0.00v
520 mV Source 5.00 ms/di | 2.50 MS 500 kS/s Edge Positive

Math Zoom Histogram

Segments

single dual
1<) i< hist(C2)

graph web edit s for trace F1
i

Arer %}ﬂ = g | %E Reset
L L}
Measure Next Zoom

Different types of traces opening in a multi-grid display.

Summary

Q-Scape Tabs

Oninstruments with the Q-Scape option installed, Tabs 1-4 appear along the top of the grid area. Each tab
s a distinct multi-grid display. See Display for more information about using Q-Scape.

18



Using MAUI

Grid Indicators

These indicators appear around or on the grid to mark important points on the display. They are matched
to the color of the trace to which they apply. When multiple traces appear on the same grid, indicators
refer to the foreground trace—the one that appears on top of the others.

L] | or change the Vertical/Horizontal scale. Originally shown in absolute values, the labels change to show delta
from 0 (center) when the number of significant digits grows too large. The number of labels that appear on
each grid depends on the total number of grids open. To remove them, go to Display > Display Setup and
deselect Axis Labels.

- Axis labels mark the times/units represented by a grid division. They update dynamically as you pan the trace

Trigger Time, a small triangle along the bottom (horizontal) edge of the grid, shows the time of the trigger.
Unless Horizontal Delay is set, this indicator is at the zero (center) point of the grid. Delay time is shown at the
top right of the Timebase descriptor box.

Pre/Post-trigger Delay, a small arrow to the bottom left or right of the grid, indicates that a pre- or post-trigger
Delay has shifted the Trigger Position indicator to a pointin time not displayed on the grid. All Delay values
are shown on the Timebase Descriptor Box.

Trigger Level at the right edge of the grid tracks the trigger voltage level. If you change the trigger level when
in Stop trigger mode, or in Normal or Single mode without a valid trigger, a hollow triangle of the same color
appears at the new trigger level. The trigger level indicator is not shown if the triggering channel is not dis-
played.

Zero Volts Level is located at the left edge of the grid. One appears for each open trace on the grid, sharing
the number and color of the trace.

Cursor markers appear over the grid to indicate specific voltage and time values on the waveform. Drag-
and-drop cursor markers to quickly reposition them.

.

Grid Intensity

You can adjust the brightness of the grid lines by going to Display > Display Setup and entering a new Grid
Intensity percentage. The higher the number, the brighter and bolder the grid lines.

19
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Descriptor Boxes
Trace descriptor boxes appear just beneath the grid whenever a trace is turned on. They function to:

« Inform—descriptors summarize the current trace settings and its activity status.

« Navigate—touch the descriptor box once to activate the trace, a second time to open the trace
setup dialog.

« Arrange—drag-and-drop descriptor boxes to move traces among grids.

« Configure—

drag-and-drop descriptor boxes to change source or copy setups.

Besides trace descriptor boxes, there are also Timebase and Trigger descriptor boxes summarizing the
acquisition settings shared by all channels, which also open the corresponding setup dialogs.

Channel Descriptor Box

0.00 mY ofst

1.446 k#
=107 77 myf
-105.3

Ay 245 mv

Channeltrace descriptor boxes correspond to analog signal inputs. They show
(clockwise from top left): Channel Number, Pre-processing list, Coupling, Vertical Scale
(gain) setting, Vertical Offset setting, Sweeps Count (when averaging), Vertical Cursor
positions, and Number of Segments (when in Sequence mode).

Codes are used to indicate pre-processing that has been applied to the input. The short
formis used when several processes are in effect.

Pre-processing Symbols on Descriptor Boxes

Pre-Processing Type Long Form Short Form
Sin X Interpolation* SINX S
Averaging AVG A
Inversion INV |
Deskew DSQ DQ
Coupling DC50,DC1M, AC1M or GND D50,D1,A10rG
Bandwidth Limiting BWL B

20



Using MAUI

Other Trace Descriptor Boxes

Similar descriptor boxes appear for math (Fx), zoom (Zx), and memory (Mx) traces. These descriptor
boxes show any Horizontal scaling that differs from the signal timebase. Units will be automatically
adjusted for the type of trace.

F1  trend(P3}}£1 zoom(C1
50.0 ps/div 200 m\//div 200 mV//div

20.0 #div 5.00 ns/div 30.0 ns/div

0s

Trace Context Menu

Touch and hold ("right-click") on the trace descriptor box until a white circle appears to open the trace
context menu, a pop-up menu of actions to apply to the trace such as turn off, move to next grid or label.

Setup...
Off
MNext Grid

Math...

Measure...

Setlabel ..

Timebase and Trigger Descriptor Boxes
The Timebase descriptor box shows: (clockwise from top right) Horizontal Delay, Time/div, Sample Rate,
Number of Samples, and Sampling Mode (blank when in real-time mode).

Trigger descriptor box shows: (clockwise from top right) Trigger Source and Coupling, Trigger Level (V),
Slope/Polarity, Trigger Type, Trigger Mode.

Timebase 0 nsfTrigger (3158
50.0 ns/div Auto 0.0 my
10 G5/s Edge Positive

1250ns AX= 2500 ns
25 0ns 1AX= 4.000 MHz

Horizontal (time) cursor readout, including the time between cursors and the frequency, is shown beneath
the TimeBase and Trigger descriptor boxes. See the Cursors section for more information.

21
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Dialogs

Dialogs appear at the bottom of the display for entering setup data. The top dialog will be the main entry
point for the selected functionality. For convenience, related dialogs appear as a series of tabs behind the
main dialog. Touch the tab to open the dialog.

Main Dialog Tabs for Related Dialogs Right-Hand Subdialogs

1) 9iE<D

FFT(C1)

web edit

graph ctio ce

i .

s oy = ; - % He
Measure Label Next

TELEDYNE LECROY 11:14:01 AM

Right-Hand Subdialogs

At times, your selections will require more settings than can fit on one dialog, or the task commonly invites
further action, such as zooming a new trace. In that case, subdialogs will appear to the right of the dialog.
These subdialog settings always apply to the object that is being configured on the left-hand dialog.

Action Toolbar

Several setup dialogs contain a toolbar at the bottom of the dialog. These buttons enable you to perform
commonplace tasks—such as turning on a measurement—without having to leave the underlying dialog.
Toolbar actions always apply to the active trace.

Actions for trace C1

-+ — M — i

Measure Zoom Math Decode Store Find Stale | NextGrid

Measure opens the Measure pop-up to set measurement parameters on the active trace.
Zoom creates a zoom trace of the active trace.
Math opens the Math pop-up to apply math functions to the active trace and create a new math trace.

Decode opens the main Serial Decode dialog where you configure and apply serial data decoders and
triggers. This button is only active if you have serial data software options installed.

Store loads the active trace into the corresponding memory location (C1, F1 and Z1 to M1; C2, F2 and Z2
toM2, etc.).

Find Scale performs a vertical scaling that fits the waveform into the grid.

Next Grid moves the active trace to the next grid. If you have only one grid displayed, a new grid will be
created automatically, and the trace moved.

Label opens the Label pop-up to annotate the active trace.

22



Using MAUI

Histogram, Trend, and Track buttons appear at the bottom of the Parameter (Px) dialogs. They allow you
to create a Math function to plot the parameter while remaining on the measurement dialogs.

Actions for P1

el

Histogram

Message Bar

At the bottom of the oscilloscope display is a narrow message bar. The current date and time are
displayed at the far right. Status, error, or other messages are also shown at the far left, where "Teledyne
LeCroy" normally appears.

A Input has invalid points

You will see the word "Processing..." highlighted with red at the right of the message bar when the
oscilloscope is processing your last acquisition or calculating.

Processing ...

This will be especially evident when you change an acquisition setting that affects the ADC configuration
in Normal or Auto trigger mode, such as changing the Vertical Scale, Offset, or Bandwidth. Traces may
briefly disappear from the display while the oscilloscope is processing.
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OneTouch Help

Touch, drag, swipe, pinch, and flick can be used to create and change setups with one touch. Just as you
change the display by using the setup dialogs, you can change the setups by moving different display
objects. Use the setup dialogs to refine OneTouch actions to precise values.

Asyou drag & drop objects, valid targets are outlined with a white box. When you're moving over invalid
targets, you'll see the "Null" symbol ( @) under your finger tip or cursor.

Note: Many actions shown here—such as Activate, Position Cursors, Change Trigger, Move Trace,
Scroll, Pan left/right, and Drag to Create Zoom—can be done on all MAUI instruments, even those
without the OneTouch features. Some examples below may show features not available on your
oscilloscope.

Turn On

Toturn on a new channel, math, memory, or zoom trace, drag any descriptor box of the same type to the
Add New ("+") box. The next trace in the series will be added to the display at the default settings. It is now
the active trace.

@»

If there is no descriptor box of the desired type on the screen to drag, touch the Add New box and choose
the trace type from the pop-up menui.

To turn on the Measure table when it is closed, touch the Add New box and choose Measurement.

Meaguiamant

Activate

Touch a trace or its descriptor box to activate it and bring it to the foreground. When the descriptor box
appears highlighted in blue, front panel controls and touch screen gestures apply to that trace.

50.0 myf
0.0 mY ofs
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Copy Setups

To copy the setup of one trace to another of the same type (e.g., channel to channel, math to math),
drag-and-drop the source descriptor box onto the target descriptor box.

To copy the setup of a measurement (Px), drag-and-drop the source column onto the target column of
the Measure table. You can do the same for a qualifier (Qx) on the Pass/Fail readout table.

Change Source

To change the source of a trace, drag-and-drop the descriptor box of the desired source onto the target
descriptor box. You can also drop it on the Source field of the target setup dialog.

20.0 iy 50,0 my
E 000 mv 53 MHzdev

To change the source of a measurement, drag-and-drop the descriptor box of the desired source onto
the parameter (Px) column of the Measure table. You can do the same to a qualifier (Qx) on the Pass/Fail
readout table.
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Position Cursors

To change cursor measurement time/level, drag cursor markers to new positions on the grid. The cursor
readout will update immediately.

To place horizontal cursors on zooms or other calculated traces where the source Horizontal Scale has
forced cursors off the grid, drag the cursor readout from below the Timebase descriptor to the grid where
you wish to place the cursors. The cursors are set at either the 5 (center) or 2.5 and 7.5 divisions of the
grid. Cursors on the source traces adjust position accordingly.

g,
o it

Change Trigger

To change the trigger level, drag the Trigger Level indicator to a new position on the Y axis. The Trigger
descriptor box will show the new voltage Level.

To change the trigger source channel, drag-and-drop the desired channel (Cx) descriptor box onto the
Trigger descriptor box. The trigger will revert to the coupling and slope/polarity last set on that channel.

Trigger 129 L8
50 -180 mV Aut  -180.0 mV
L il Positive Runt Megative
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Store to Memory

To store a trace to internal memory, drag-and-drop its trace descriptor box onto the target memory (Mx)
descriptor box.

TR o e iJe o ckala
g0 my|  available.

] A0 | R
* 100 i\ idie 100 gy
25.0 m\ 200 naldiv

Move Trace

Tomove a trace to a different grid, drag-and-drop the trace descriptor box onto the target grid. If you are
in a multi-tabbed Q-Scape display mode, you can move traces between tabs this way.

Scroll

Toscroll long lists of values or readout tables, swipe the selection dialog or table in an up or down
direction.
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Pan Trace

To pan a trace, activate it to bring it to the forefront, then drag the waveform trace right/left or up/down. If
it is the source of any other trace, that trace willmove, as well. For channel traces, the Timebase
descriptor box will show the new Horizontal Delay value. For other traces, the zoom factor controls show
the new Horizontal Center.

0 Tip: If you are using the multi-zoom feature, all time-locked traces will pan together.

To pan at an accelerated rate, swipe the trace right/left or up/down.
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Zoom

To create a new zoom trace, touch then drag diagonally to draw a selection box around the portion of the
trace you want to zoom. Touch the Zx descriptor box to open the zoom factor controls and adjust the
zoom exactly.

To "zoom out" on any trace, pinch two fingers over the trace horizontally.

R

S

Note: Pinch gestures do not create a separate zoom (Zx) trace, they only adjust the Horizontal
Scale. When you pinch a channel (Cx) trace, the Timebase for all channels changes. If the trace is
the source of any other, all its dependent traces change, as well.
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Turn Off

Toturn off a trace, flick the trace descriptor box toward the bottom of the screen.

To turn off a measure parameter or Pass/Fail qualifier, flick the Px or Qx cell toward the bottom of the
screen. If it's the last active cell of the table, the table will close.
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Working With Traces

Traces are the visible representations of waveforms that appear on the display grid. They may show live
inputs (Cx, Digitalx), a math function applied to a waveform (Fx), a stored memory of a waveform (Mx), a
zoom of a waveform (Zx), or the processing results of special analysis software.

Traces are a touch screen object like any other and can be manipulated. They can be panned, moved,
labeled, zoomed, and captured in different visual formats for printing/reporting.

Each visible trace will have a descriptor box summarizing its principal configuration settings. See
OneTouch Help for more information about how you can use traces and trace descriptor boxes to modify
your configurations.

Active Trace

Although several traces may be open, only one trace is active and can be adjusted using front panel
controls and touch screen gestures. A highlighted descriptor box indicates which trace is active. All
actions apply to that trace until you activate another. Touch a trace descriptor box to make it the active
trace (and the foreground trace in that grid).

DC1M

200 m\idiv 200 m\idiv
10.0 mY ofst 10.0 m¥ ofst

Active trace descriptor (left), inactive trace descriptor (right).

Whenever you activate a trace, the dialog at the bottom of the screen automatically switches to the
appropriate setup dialog.

50.0 mvidiv
0.0 mY ofst

Active descriptor box matches active dialog tab.

Foreground Trace

Since multiple traces can be opened on the same grid, the trace shown on top of the othersis the
foreground trace. Grid indicators (matched to the input channel color) represent values for the foreground
trace.

Touch a trace or its descriptor box to bring it to the foreground. This also makes it the active trace.

Note that a foreground trace may not be the same as the active trace. A trace in a separate grid may
subsequently become the active trace, but the indicators on a given grid will still represent the foreground
trace in that group.
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Turning On/Off Traces

Analog Traces
From the front panel, press the Channel button (1-4) to turn on the trace; press again to turn it off.

To turn on the trace from the touch screen, touch the Add New box and select Channel, or drag another
Channel (Cx) descriptor box to the Add New box.

To turn off a channel trace from the touch screen, do any of the following:
« Flick the trace descriptor box toward the bottom of the screen.

« Touch-and-hold (right-click) on the descriptor box until a white circle appears, then from the context
menu select Off.

o Clearthe "On"box on the Channel Setup or Cx dialogs.

Note: The default is to display each trace in its own grid. Use the Display menu to change how
traces are displayed.

Digital Traces

From the front panel, turn on the trace by pressing the Dig button, then checking Group on the Digitalx
trace dialog.

Toturn on the trace from the touch screen, choose Vertical > Digitalx Setup then check Group on the
Digitalx dialog.

Clear the Group checkbox to turn off the trace, or flick the trace descriptor box toward the bottom of the
screen.

Other Traces

From the front panel, touch the Zoom button to create quick zooms of all open traces. Press the button
again to turn them off.

From the touch screen, touch the Add New box and select the trace type, or drag another descriptor box
of that type to the Add New box. Turn off the trace the same as you would a channel trace.

Adjusting Traces

To adjust Vertical Scale (gain or sensitivity) and Vertical Offset, just activate the trace and use the front
panel Vertical knobs. To make other adjustments—such as channel pre-processing or the math function
definition—touch the trace descriptor box twice to open the appropriate setup dialog.

Many entries can be made by selecting from the pop-up menu that appears when you
touch a control. When an entry field appears highlighted in blue after touching, it is active
and the value can be modified by turning the front panel knobs. Fields that don't have a
dedicated knob (as do Vertical Level and Horizontal Delay) can be modified using the
Adjust knob.
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If you have a keyboard installed, you can type entries in an active (highlighted) data entry field. Or, you can
touch again, then "type" the entry by touching keys on the virtual keypad or keyboard.

To use the virtual keypad, touch the soft keys exactly as you would a calculator. When you touch OK, the
calculated value is entered in the field.

Moving Traces

Use any of these methods to move traces from grid to grid. See OneTouch Help for ways to pan traces
within the same grid.

Drag-and-Drop
You can move a trace from one grid to another by dragging its descriptor box to the desired grid. Thisis a
convenient way to quickly re-arrange traces on the display.

If you are in Q-Scape display mode, you can drag the descriptor box to a grid on another tab, provided the
grid is visible while you are moving the trace. For example, you cannot drag descriptors across tabs in Q-
Scape Single mode, because the target grids aren't visible, but you can in Q-Scape Dual or Q-Scape
Mosaic modes. This is true even in extended display. For more information, see Display.

Next Grid Button

Touch twice on the descriptor box of the trace you want moved to open the setup dialog, then touch the
Next Grid action toolbar button at the bottom of the dialog. You can also touch and hold (right-click) the
trace descriptor box and choose Next Grid from the context menu.

Note: If only one grid is open, a second grid opens automatically when you select Next Grid.
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Labeling Traces

The Label function gives you the ability to add custom annotations to the trace display. Once placed,
labels can be moved to new positions or hidden while remaining associated with the trace.

T 20

[ A

Create Label

1. Select Label from the context menu, or touch the Label Action toolbar button on the trace setup
dialog.

Text of label

Add
Label

Remove

Text of label

Label position may either b
or by dragging the label

2. Onthe Trace Annotation pop-up, touch Add Label.
3. Enterthe Label Text.

4. Optionally, enter the Horizontal Pos. and Vertical Pos. (in same units as the trace) at which to
place the label. The default position is 0 ns horizontal. Use Trace Vertical Position places the label
immediately above the trace.

Reposition Label
Drag-and-drop labels to reposition them, or change the position settings on the Trace Annotation pop-up.

Edit/Remove Label

On the Trace Annotation pop-up, select the Label from the list. Change the settings as desired, or touch
Remove Label to delete it.

Clear View labels to hide all labels. They will remain in the list.
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Zooming

Zooms magnify a selected region of a trace by altering the Horizontal Scale relative to the source trace.
Zooms may be created in several ways, using either the front panel or the touch screen. You can adjust

zooms the same as any other trace using the front panel Vertical and Horizontal knobs or the touch screen
zoom factor controls.

The current settings for each zoom trace can be seen on the Zx dialogs, while the Zoom dialogis a
convenient panel for turning on/off zooms or changing the zoom source.

The MultiZoom feature creates time-locked zoom traces for only the waveforms that you choose to
include. The zooms are of the same X-axis section of each waveform. As you scroll through a waveform,
allincluded zooms scroll in unison. For more information, refer to MultiZoom.

Zoom Dialog

Zoom controls appear throughout the X-Stream software wherever it is likely you may wish to change the
display scale of a trace, sometimes as a main dialog, sometimes as a subdialog, such as when setting up:

« Mathtraceson Fxdialogs
« Memory traces on Mx dialogs

To display the zoom controls, choose Math > Zoom Setup from the menu bar, or touch a zoom descriptor
box.

The main Zoom dialog contains selection boxes for turning on/off and changing the source of a zoom.
There are also options to:

« Reset All, return all zooms to x1 magnification.

« Quick Zoom, create a corresponding zoom trace for each open channel trace, same as using the
front panel Zoom button.

« MultiZoom
MultiZoom

Details...

Details___

Details._..

MultiZoom

Setup...
P Details_..
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Zx Dialog

Behind the main Zoom dialog is a separate tab for each potential zoom trace (Z1-Zx). Each Zx dialog
reflects the center and scale for that zoom. Use it to adjust the zoom magnification.

MultiZoom

Measure

Trace Controls
Trace On shows/hides the zoom trace. It is selected by default when the zoom is created.

Source lets you change the source for this zoom to any channel, math, or memory trace while maintaining
all other settings.

Segment Controls
These controls are used in Sequence Sampling Mode.

Zoom Factor Controls

« Outand In buttons increase/decrease zoom magnification and consequently change the Horizontal
and Vertical Scale settings. Touch either button until you've achieved the desired level.

« Var.checkbox enables zooming in single increments.

« Horizontal Scale/div sets the time represented by each horizontal division of the grid. It is the
equivalent of Time/div in channel traces, only unlike that setting, it may differ for each zoom trace.

« Vertical Scale/div sets the voltage level represented by each vertical division of the grid; it's the
equivalent of V/divin channel traces.

« Horizontal/Vertical Center sets the time/voltage at the center of the grid. The horizontal center is
the same for all zoom traces.

« Reset Zoom returns the zoom to x1 magnification.
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Creating Zooms
Any type of trace can be "zoomed" by creating a new zoom trace (Zx) following the procedures here.

@ Note: On instruments with OneTouch, traces can be "zoomed" by pinching/unpinching two fingers
over the trace, but this method does not create a separate zoom trace. With channel traces,
pinching will alter the acquisition timebase and the scale of all traces. Create a separate zoom
trace if you do not wish to do this.

All zoom traces open in the next empty grid, with the zoomed portion of the source trace highlighted. If
there are no more available grids, zooms will open in the same grid as the source trace.

[

i

ohs

M

Zoomed area of original trace highlighted. Zoom in new grid below.

Quick Zoom
Use the front panel Zoom button to quickly create one zoom trace for each displayed channel trace.
Quick zooms are created at the same vertical scale as the source trace and 10:1 horizontal magnification.

To turn off the quick zooms, press the Zoom button again.

Manually Create Zoom

To manually create a zoom, touch-and-drag diagonally to draw a selection box
around any part of the source trace.

The zoom will resize the selected area to fit the full width of the grid. The degree
of vertical and horizontal magnification, therefore, depends on the size of the
rectangle that you draw.

Alternatively, you can drag any Zx descriptor box over the Add New box, or touch
the Add New box and choose Zoom from the pop-up menu. The next available
zoom trace opens with its Zx dialog displayed for you to modify scale as needed.

Finally, you can touch-and-hold (right-click) on the descriptor box of the trace you
wish to zoom until a white circle appears, then choose Math from the context
menu. Select the Zoom operator to create a zoom in the next open math function. This method creates a
new Fx trace, rather than a new Zx trace, but it can be rescaled in the same manner. It is a way to create
more zooms than you have Zx slots available on your instrument.
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Adjust Zoom Scale

The zoom's Horizontal units will differ from the signal timebase because the zoom is showing a calculated
scale, not a measured level. This allows you to adjust the zoom factor using the front panel knobs or the
zoom factor controls however you like without affecting the timebase (a characteristic shared with math
and memory traces).

Close Zoom

New zooms are turned on and visible by default. If the display becomes too crowded, you can close a
particular zoom and the zoom settings are saved in its Zx slot, ready to be turned on again when desired.

To close the zoom, touch-and-hold (right-click) on the zoom descriptor box until the white circle appears,
then from the context menu choose Off.

MultiZoom

MultiZoom creates time-locked zoom traces for only the waveforms that you choose to include. The
zooms are of the same X-axis section of each waveform. As you scroll through a waveform, all included
zooms scroll in unison.

Set Up MultiZoom

1. Choose Math > Zoom Setup... to open the Zoom dialog, then touch the MultiZoom tab or
MultiZoom Setup... button.

2. Onthe MultiZoom dialog, check On.

3. Select all the traces that are In the MultiZoom group.

MultiZoom

Scroll Waveforms

The Auto-Scroll controls appear at the right of the MultiZoom dialog. They work similarly to A/V controls to
allow you to continuously scroll all the selected zoom traces in time-locked steps from the beginning to the
end of the acquisition.

38



Using MAUI

Print/Screen Capture

The front panel Print button captures animage of the display and outputs it according to your Print
settings. It can be used to save a LabNotebook, create an image file of waveform traces, or send the
display to a networked printer, etc.

The Printer% icon at the right of the Print dialog will also execute your print setting.

Print may be used as a screen capture tool by going to File > Print Setup and selecting to print to File,
then choosing a graphical format and naming scheme with your Screen Image Preferences. Once
configured, just press the Print button or Printer icon, and optionally annotate the image.

You can also use the touch screen to generate a screen capture by choosing File > Save > Screen image
and touching Save Now at the right of the dialog. The file is saved using your latest Screen Image
Preferences settings.
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Acquisition

The acquisition settings include everything required to produce a visible trace on screen and an acquisition
record that may be saved for later processing and analysis:

« Vertical axis scale at which to show the input signal and probe characteristics that affect the signal,
such as attenuation and deskew time

« Horizontal axis scale at which to represent time, and acquisition sampling mode and sampling rate
« Acquisition trigger mechanism

Optional acquisition settings include bandwidth filters and pre-processing effects, vertical offset, and
horizontal trigger delay, all of which affect the appearance and position of the waveform trace.

To avoid aliasing and other waveform distortions, it is advisable (per Nyquist) to acquire at a sample rate at
least twice the bandwidth of the input signal. It can be shown that a sample rate 10 times the acquisition
bandwidth is preferable in order to over sample fast signal rise times consistent with the oscilloscope
bandwidth.

Those with higher speed acquisition systems may need to manually adjust Bandwidth, Time/div, Sample
Rate, and the number of Active Channels to achieve the optimal result. Most Teledyne LeCroy
oscilloscopes have a Fixed Sample Rate option, which uses whatever memory is required for the
acquisition time, until none remains.

Auto Setup

Auto Setup quickly configures the essential acquisition settings based on the first input signal it finds,
starting with Channel 1. If nothing is connected to Channel 1, it searches Channel 2 and so forth until it
finds a signal. Vertical Scale (\VV/div), Offset, Timebase (Time/div), and Trigger are set to an Edge trigger on
the first, non-zero-level amplitude, with the entire waveform visible for at least 10 cycles over 10 horizontal
divisions.

Torun Auto Setup:

1. Either press the front panel Auto Setup button or choose Auto Setup from the Vertical, Timebase,
or Trigger menus. All these options perform the same function.

2. Pressthe Auto Setup button again or use the touch screen display to confirm Auto Setup.

After running Auto Setup, you'll see the words "Auto Setup" next to an Undo button at the far right of the
menu bar. This allows you to restore the settings in place prior to the Auto Setup.

Note: You will undo all new measurements or math function definitions entered since the Auto
Setup when you Undo the Auto Setup. Perform this work when the instrument is not in the Auto
Setup mode if you wish for it to persist.
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Viewing Status

Allinstrument settings can be viewed through the various Status dialogs. These show all existing
acquisition, trigger, channel, math function, measurement and parameter configurations, as well as which
are currently active.

Access the Status dialogs by choosing the Status option from the Vertical, Timebase, Math, or Analysis
menus (e.g., Channel Status, Acquisition Status).

Trigger time C1..C4 F1...F4 5. F& 71,74 7578 XY M1...M4 Others

500 ns
100.000 ps

Vertical

Vertical, also called Channel, settings usually relate to voltage level and control input channel traces (C1-
Cx) along the Y axis.

Note: While Digital settings can be accessed through the Vertical menu on-MS model
instruments, they are handled quite differently. See Digital.

The amount of voltage displayed by one vertical division of the grid, or Vertical Scale (V/div), is most
quickly adjusted by using the front panel Vertical knob. The Cx descriptor box always shows the current
Vertical Scale setting.

Detailed configuration for each trace is done on the Cx dialogs. Once configured, channel traces can be
quickly turned on/off or modified using the Channel Setup dialog.

Channel Setup Dialog

Use the Channel Setup dialog to quickly make basic Vertical settings for all analog input channels. To
access the Channel Setup dialog, choose Vertical > Channel Setup from the menu bar.

Channel Setup

Scale  Offset Coupling Bandwidth Probe / Atten

c1 - 50.0 mv 0.0 mv DCIMO

Copy Channel c2 500mv 00mv DCIMQ
Setup

c3 - W 500mv, 0.0mv DCIMO

c4 W 50.0mv 0.0mv DCIMQ

To show/hide the channel trace, select/deselect the checkbox next the channel number.

To change the channel trace color, touch the color block next to the channel number, then choose the
new color from the pop-up menu.
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To change any other Vertical settings, touch the input field and enter the new value.

Oninstruments with OneTouch, drag-and-drop the source channel descriptor box onto the target channel
descriptor box to copy settings from one channel to another

You can also touch Copy Channel Setup, then select the channel to Copy From and all the channels to
Copy To.

Cx (Channel) Dialog

Full vertical setup is done on the Cx dialog. To access it, choose Vertical > Channel <#> Setup from the
menu bar, or touch the Channel descriptor box.

Math Decode Store Find Séale | Next Grid Label

The Cx dialog contains:
« Vertical settings for scale, offset, coupling, bandwidth, and probe attenuation
« Rescale settings
« Pre-processing settings for pre-acquisition processes such as noise filtering and interpolation.

If a Teledyne LeCroy probe is connected, its Probe dialog appears to the right of the Cx dialog.

Vertical Settings
The Trace On checkbox turns on/off the channel trace.

Vertical Scale sets the gain (sensitivity) in the selected Vertical units, Volts by default. Select Variable
Gain for fine adjustment or leave the checkbox clear for fixed 1, 2, 5, 10-step adjustments.

Offset adds a defined value of DC offset to the signal as acquired by the input channel. This may be helpful
in order to display a signal on the grid while maximizing the vertical height (or gain) of the signal. A negative
value of offset will "subtract" a DC voltage value from the acquired signal (and move the trace down on the
grid") whereas a positive value will do the opposite. Touch Zero Offset to return to zero.

A variety of Bandwidth filters are available. To limit bandwidth, select a filter from this field.

Coupling may be setto DC 50 Q, DCTM, ACTM or GROUND.

A Caution: The maximum input voltage depends on the input used. Limits are displayed on the body
of the instrument. Whenever the voltage exceeds this limit, the coupling mode automatically

switches to GROUND. You then have to manually reset the coupling to its previous state. While the
unit does provide this protection, damage can still occur if extreme voltages are applied.
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Probe Attenuation and Deskew

Probe Attenuation and Deskew values for third-party probes may be entered manually on the Cx dialog.
The instrument will detect it is a third-party probe and display these fields.

When a Teledyne LeCroy probe is connected to a channel input:
« Passive probe Attenuation is automatically set, and this field is disabled on the Cx dialog.

« Foractive voltage and current probes, a tab is added to the right of the Cx tab. The Attenuation field
becomes a button to access the Probe dialog. Enter Attenuation on the Probe dialog.

Pre-Processing Settings

Average performs continuous averaging or the repeated addition, with unequal weight, of successive
source waveforms. It is particularly useful for reducing noise on signals drifting very slowly in time or
amplitude. The most recently acquired waveform has more weight than all the previously acquired ones:
the continuous average is dominated by the statistical fluctuations of the most recently acquired
waveform. The weight of old waveforms in the continuous average gradually tends to zero (following an
exponential rule) at a rate that decreases as the weight increases.

Interpolate applies (Sinx)/x interpolation to the waveform. The selection of None applies Linear
interpolation, which inserts a straight line between sample points and is best used to reconstruct straight-
edged signals such as square waves. (Sinx)/x interpolation, on the other hand, is suitable for
reconstructing curved or irregular wave shapes, especially when the sample rate is 3 to 5 times the
system bandwidth. Choose an upsample factor of 2 or 45 points.

Note: 10 point Sinx/x interpolation can be set by sending the command via IEEE 488.2 remote
control or COM Automation.

Deskew adjusts the horizontal time offset by the amount entered in order to compensate for propagation
delays caused by different probes or cable lengths. The valid range is dependent on the current timebase
setting. The Deskew pre-processing setting and the Deskew math function perform the same action.

Noise Filter applies Enhanced Resolution (ERes) filtering to increase vertical resolution, allowing you to
distinguish closely spaced voltage levels. The tradeoff is reduced bandwidth. The functioning of the
instrument's ERes is similar to smoothing the signal with a simple, moving-average filter. It is best used on
single-shot acquisitions, acqusitions where the data record is slowly repetitive (and you cannot use
averaging), or to reduce noise when your signal is noticeably noisy but you do not need to perform noise
measurements. It also may be used when performing high-precision voltage measurements and zooming
with high vertical gain, for example. See Enhanced Resolution.

Invert inverts the trace.

Cable De-Embedding (available as an option) allows you to remove the effects of cables used in the test
setup. Select the checkbox, then enter the attenuation constants or cable characteristics (provided by the
cable manufacturer) on the Cable De-Embedding dialog that appears. See Cable De-Embedding.
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Probe Dialog

The Probe Dialog immediately to the right of the Cx dialog displays the probe attributes and (depending on
the probe type) allows you to AutoZero, DeGauss and make tip selection for probes from the touch screen.
Other settings may appear, as well, depending on the probe model.

A Caution; Remove probes from the circuit under test before initializing Auto Zero or DeGauss.

C1HVD3102

erential Probe

Attributes

DC 10MQ

Auto Zero Probe

Auto Zero corrects for DC offset drifts that naturally occur from thermal effects in the amplifier of active
probes. Teledyne LeCroy probes incorporate Auto Zero capability to remove the DC offset from the
probe's amplifier output to improve the measurement accuracy.

DeGauss Probe

The Degauss control is activated for some types of probes (e.g., current probes). Degaussing eliminates
residual magnetization from the probe core caused by external magnetic fields or by excessive input. It is
recommended to always Degauss probes prior to taking a measurement.

Tip Select

If using one of the modular WaveLink probes, specify the type of tip/lead you're using by touching the Tip
Select control and making the appropriate selection.

Note: It's crucial to make the tip selection on this field as it results in the amplifier and tip
combination having the response calibrated for at the factory. Failure to do so may result in
inaccurate measurements.

45



WaveRunner 8000 Oscilloscopes Instruction Manual

Cable De-Embedding Option

Losses in the cables used in the test setup can reduce the accuracy of your signal (for example, signal
amplitude and risetime), as well as introduce Inter-Symbol Interference. These cable effects can
dramatically alter measurements and potentially create mask test violations.

Cable De-Embedding, available as an option, allows you to quickly specify the characteristics of the cables
(typically found on the cable's data sheet) in your test setup and analyze your signal with the effects of the
cables removed. The compensated signal is a more accurate representation of what was actually
transmitted.

When Cable De-Embedded is installed and selected from the channel pre-processing settings, the Cable
De-Embedding dialog will appear for you to describe the cable being used on the channel.

Channel Setup C1 Cable De-Embedding

DefaultCable

1. Touch Vertical > Channel # Setup... from the menu bar.
2. Onthe Cxdialog, check Cable De-Embeddingto display the Cable De-Embedding tab.

3. Onthe Cable De-Embedding dialog, touch Cable Specified by and choose either:
Attenuation Constants. Enter the cable loss model constants (provided by the manufacturer) in
Cable A1 and Cable A2.
Or

Attenuation Table. Enter the first set of Frequency and Attenuation values. Touch Add to continue
adding rows as needed.

ncy Attenuation

1.000000 MHz 10 mdB

Add Change Delete

Toedit arow in the table, select the row, change values, then touch Change. To delete a row, select
the row and touch Delete.

4. Touch Delay Specified by and choose from Propagation Velocity, Nominal Delay, or Dielectric
Constant. Enter the value in the field of the same name.

5. Enter the Cable Length ininches.
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6. Click Apply to initiate the cable de-embedding for the signal on this channel so that the effects of
the cable are removed.

7. Tosave this cable configuration for future use, touch File Name [DefaultCable] and enter a name,
or touch Browse and select a file to overwrite. To reload previously saved configurations, browse to
the file, then touch Load.
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Digital (Mixed Signal)

The digital leadset (standard with -MS model oscilloscopes) inputs up-to-16 lines of digital data. Leads are
organized into two banks of eight leads each, and you assign each bank a standard Logic Family or a
custom Threshold to define the digital logic of the signal.

When a Mixed Signal input device is connected to the oscilloscope, digital input setup options are added to
the Vertical menu. There are four set up dialogs for each of four possible digital groups, which correspond
to buses: Digital1 to Digital4. You choose which lines make up each digital group, what they are named,
and how they appear on the display.

Digital Traces

When a digital group is enabled, digital Line traces (the Expanded view) show which lines are high, low, or
transitioning relative to the threshold. You can also view a digital Bus trace that collapses all the linesin a
group into their Hex values.

[ File | ¥ Vertical |+ Timebase I Trigger & Display | # Cursors | El Measure | & Math | | Analysis = X Utilities @ Support

B

Four digital lines displayed with a Vertical Position +4.0 (top of grid) and a Group Height 4.0 (divisions).

Activity Indicators

Activity indicators at the bottom of the Digitalx dialogs show which lines are High (up arrow), Low (down
arrow), or Transitioning (up an down arrows) relative to the Logic Threshold value. They provide a quick
view of which lines are active and of interest to display on screen.

High Low Transitioning
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Digitalx (Group) Set Up
Logic Setup € cLose
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To set up a digital input:
1. Connect the Mixed-Signal input device to the test device and the instrument.
2. From the menu bar, choose Vertical > Digital <#> Setup.

3. Onthe Digitalx set up dialog, check the boxes for all the lines that comprise the group. Touch the
Right and Left Arrow buttons to switch between digital banks as you make line selections.

Alternatively, touch All Lines ON to quickly turn on an entire digital bank.

Note: Each group can consist of anywhere from 1 to 16 of the leads from any digital bank
regardless of the Logic set on the bank. It does not matter if the some or all of the lines
have been included in other groups.

4. Check Trace Onto enable the display.

5. When you're finished on the Digitalx dialog, open Logic Setup and choose the Logic Family that
applies to each digital bank, or set custom Threshhold and Hysteresis values.

6. Goontosetup the digital display for the group.

Digitald Logic Setup
D7:D0

User D

T ] Threshold
200V 200V

Hyst Hyst
500 mV 500 mV
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Digital Display Set Up

Choose the type and position of the digital traces that appear on screen for each digital group.

1. Setup the digital group.

2. Choose a Display Mode:

« Expand (default) shows a time-correlated trace indicating high, low, and transitioning points
(relative to the Threshold) for every digital line in the group. The size and placement of the
lines depend on the number of lines, the Vertical Position and Line Height settings.

« Collapse collapses the lines in a group into their Hex values.

3. InVertical Position, enter the number of divisions (positive or negative) relative to the zero line of
the grid where the display begins.The top of the first trace appears at this position.

4. InLine Height, enter the total number of grid divisions each line should occupy.

The example above shows a group of four Expanded traces each occupying a Line Height of 1.0
division.
To close digital traces, uncheck the Trace On box on the Digitalx dialog.

Tip: Because a new grid opens to accommodate each enabled group, you may wish to enable
groups one or two at a time when they have many lines to maximize the total amount of screen
space available for each. Closing the set up dialogs will also increase available screen space.

Renaming Digital Lines
The labels used to name each line can be changed to make the user interface more intuitive.

1. Setupthe digital group.

2. Touchthe Line number field below the corresponding checkbox. If necessary, use the Left/Right
Arrow buttons to switch between banks.

3. Use the virtual keyboard to enter the new name, then press OK.

Any active line traces are renamed accordingly.

50



Acquisition

Timebase

Timebase, also known as Horizontal, settings control the trace along the X axis. The timebase is shared by
allchannels.

The time represented by each horizontal division of the grid, or Time/Division, is most easily adjusted
using the front panel Horizontal knob. Full Timebase set up, including sampling mode and clock source
selection, is done on the Timebase dialog, which can be accessed by either choosing Timebase >
Horizontal Setup from the menu bar or touching the Timebase descriptor box.

Timebase Set Up

Use the Timebase dialog to select the sampling mode, memory and number of active channels. You can
also use it instead of the Front Panel to modify the Time/Div and horizontal Delay. There are related
dialogs for Clock Source.

Set Fixed
Maximum Sample
Memory Rate

Sampling Mode
Choose from Real Time, Sequence, RIS, or Roll mode.

Timebase Mode

Time/Division is the time represented by one horizontal division of the grid. Touch the Up/Down Arrow
buttons on the Timebase dialog or turn the front panel Horizontal knob to adjust this value. The overall
length of the acquisition record is equal to 10 times the Time/Division setting.

Delay is the amount of time relative to the trigger event to display on the grid. Raising/lowering the Delay
value has the effect of shifting the trace to the right/left. This allows you to isolate and display a
time/event of interest that occurs before or after the trigger event.

« Pre-trigger Delay, entered as a negative value, displays the acquisition time prior to the trigger event,
which occurs at time 0 when in Real Time sampling mode. Pre-trigger Delay can be set up to the
instrument's maximum sample record length; how much actual time this represents depends on the
timebase. At maximum pre-trigger Delay, the trigger position is off the grid (indicated by the arrow at
the lower right corner), and everything you see represents 10 divisions of pre-trigger time.

« Post-trigger Delay, entered as a positive value, displays time following the trigger event. Post-trigger
Delay can cover a much greater lapse of acquisition time than pre-trigger Delay, up to the equivalent
of 10,000 divisions after the trigger event occurred (it is limited at slower time/div settings and in Roll
mode sampling). At maximum post-trigger Delay, the trigger point is off the grid far left of the time
displayed.

Set to Zero returns Delay to zero.
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Real Time Sampling Rate
These controls specify how the instrument samples when in Real Time mode.

Maximum Sample Points is the number of samples taken per acquisition when you choose to Set
Maximum Memory. It changes to show Sampling Rate, the number of samples taken per time division,
when using a Fixed Sampling Rate.

Set Maximum Memory, the default setting on MAUI oscilloscopes, automatically adjusts the sampling
rate to take the maximum number of samples possible given the amount of pre- or post-trigger Delay and
the Time/div, up to the maximum record length. This optimizes the sample rate for fast timebases whenin
Real Time mode.

Fixed Sampling Rate activates the Sampling Rate field for you to set your own rate. Lowering the rate
can extend the acquisition to accommodate slower timebases or longer delays.

Active Channels (Dual-Channel Acquisition)

The Active Channels settings allow you to combine the acquisition capabilities of the leftmost pair of
channels (C1 and C2) and the rightmost pair of channels (C3 and C4) to result in two channels with
maximum sample rate and memory.

In 4-channel mode, all channels remain active at the default sample rate ().
To combine channels, under Active Channels, choose 2 or Auto:

« 2-channel mode turns off waveform acquisition on Channels 1 and 4, although they can still be used
for trigger input. Channels 2 and 3 acquire at doubled sample rate and memory ().

« InAuto mode, the oscilloscope will allot the maximum memory and sample rate possible based on
the activity within each pair of channels. Aslong as only one channel in each of the C1-C2 and C3-C4
pairsis turned on, the maximum rate is used. Turning on both channels in either pair has the same
effect as selecting 4 Active Channels.

Example: In Auto mode, C1 can operate with either C3 or C4 at higher sample rate and memory
since they belong to different pairs, and likewise C2. However, C1 cannot operate with C2 without
dropping the sample rate, nor can C3 operate with C4.

Refer to Acquisition System in the product datasheet for maximum sample rates.

Sampling Modes

The Sampling Mode determines how the instrument samples the input signal and renders it for display.

Real Time Sampling Mode

Real Time sampling mode is a series of digitized voltage values sampled on the input signal at a uniform
rate. These samples are displayed as a series of measured data values associated with a single trigger
event. By default (with no Delay), the waveform is positioned so that the trigger event is time 0 on the grid.
The relationship between sample rate, memory, and time can be expressed as:

Capture Interval = 1/Sample Rate X Memory
Capture Interval/10 = Time Per Division
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Usually, on fast timebase settings, the maximum sample rate is used when in Real Time mode. For slower
timebase settings, the sample rate is decreased so that the maximum number of data samplesiis
maintained over time.

Roll Sampling Mode

Roll mode displays, in real time, incoming points in single-shot acquisitions that appear to "roll"
continuously across the screen from right to left until a trigger event is detected and the acquisition is
complete. The parameters or math functions set on each channel are updated every time the roll mode
buffer is updated as new data becomes available. This resets statistics on every step of Roll mode that is
valid because of new data.

Timebase must be set to 100 ms/div or slower to enable Roll mode selection. Rollmode samplesat <5
MS/s. Only Edge trigger is supported.

Note: If the processing time is greater than the acquire time, the data in memory is overwritten. In
this case, the instrument issues the warning, "Channel data is not continuous in ROLL mode!!"" and
rolling starts again.

RIS Sampling Mode

RIS (Random Interleaved Sampling) allows effective sampling rates higher than the maximum single-shot
sampling rate. It is available on timebases < 10 ns/div.

The maximum effective RIS sampling rate is achieved by making multiple single-shot acquisitions at
maximum real-time sample rate. The bins thus acquired are positioned approximately 5 ps (200 GS/s)
apart. The process of acquiring these bins and satisfying the time constraint is a random one. The relative
time between ADC sampling instants and the event trigger provides the necessary variation.

Because the instrument requires multiple triggers to complete an acquisition, RIS is best used on
repetitive waveforms with a stable trigger. The number depends on the sample rate: the higher the sample
rate, the more triggers are required. It then interleaves these segments (as shown in the following
illustration) to provide a waveform covering a time interval that is a multiple of the maximum single-shot
sampling rate. However, the real-time interval over which the instrument collects the waveform data is
much longer, and depends on the trigger rate and the amount of interleaving required.

Note: RIS is not available when the oscilloscope is operating in fixed sample rate Mode.

Sequence Sampling Mode

In Sequence Mode sampling, the completed waveform consists of a number of fixed-size segments. The
instrument uses the Timebase Sequence settings to determine the capture duration of each segment.
The desired number of segments, maximum segment length, and total available memory are used to
determine the actual number of samples or segments, and time or points.

Sequence Mode is ideal when capturing many fast pulses in quick succession or when capturing few
events separated by long time periods. The instrument can capture complicated sequences of events
over large time intervals in fine detail, while ignoring the uninteresting periods between the events.
Measurements can be made on selected segments using the full precision of the timebase.

53



WaveRunner 8000 Oscilloscopes Instruction Manual

Sequence Mode Set Up

The Sequence dialog appears only when Sequence Mode sampling is selected. Use it to define the
number of fixed-size segments to be acquired in single-shot mode.

TimeBase

100.0000 s

oo e 4

Show Sequence
Trigger Times...

viewed and

From the menu bar, choose Timebase > Horizontal Setup..., then Sequence Sampling Mode.

On the Sequence tab under Acquisition Settings, enter the Number of Segments to acquire.

@ Note: The number of segments displayed can be less than the total number acquired.

To stop acquisition in case no valid trigger event occurs within a certain timeframe, check the
Enable Timeout box and provide a Timeout value.

Note: While optional, Timeout ensures that the acquisition completes in a reasonable
amount of time and control is returned to the operator/controller without having to
manually stop the acquisition, making it especially useful for remote control applications.

Touch Display mode and select a sequence display mode from the pop-up menu:

Adjacent

Waterfall (cascaded)

Mosaic (tiled)

Overlay

Perspective

5. Touch one of the front panel Trigger buttons to begin acquisition.
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Tip: You can interrupt acquisition at any time by pressing the front panel Stop button. In this
case, the segments already acquired will be retained in memory.

View Sequence Segments

When in Sequence sampling mode, you can view individual segments easily using the front panel Zoom
button. A new zoom of the channel trace defaults to Segment 1.

You can view other segments by changing the First and total Num(ber) of segments to be shown on the
Zx dialog. Touch the Zx descriptor box to display the dialog.

Tip: By setting the Num value to 1, you can use the front panel Adjust knob to scroll through each
segment in order.

Channel descriptor boxes indicate the total number of segments acquired in sequence mode. Zoom
descriptor boxes show the first segment displayed and total number of segments displayed ([#] #). As with
all other zoom traces, the zoomed segments are highlighted on the source trace.

50.0 m\idiv 50.0 mVidiv

0.0 mV ofst 1.00 psidiv
10 Seg [4]16 Seq

Example: You have acquired 10 segments. You choose to display segments 4 to 6—or, a total of 3
segments beginning with segment 4. The Cx descriptor box reads 10. The Zx descriptor box reads
[4]3, meaning you are displaying a total of 3 segments, starting with segment 4.

Besides using the Zoom feature, you can also create a Math (Fx) trace to display individual segments.
1. From the menu bar, choose Math > Math Setup...
2. Touch a Function (Fx) tab to display its corresponding dialog.
3. Onthe dialog, touch Operator1 and select the Segment button from the pop-up menu.
4. Touch the Select subdialog tab.
5. Touch First Selected and choose the first segment to display.
6. Touch Number of Selected and enter the total number of segments to display.
To view time stamps for each segment:
1. From the Sequence dialog, choose Show Sequence Trigger Times.
Or
From the menu bar, choose Timebase > Acquisition Status, then open Trigger time .

2. Under Show Status For, choose Time.
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Clock Source Settings

An external reference clock, applied via the REF In input, is used to synchronize the instrument's internal
timebase to an external frequency source. This allows multiple instruments to lock their timebases to a
common source.

An external sampling clock, applied via the EXT input, replaces the internal timebase as the sampling
clock. This means that the external sampling clock controls when the digitizers sample the input
waveforms.

Since the external sampling clock uses the EXT input, an external trigger cannot be used when the
external sampling clock is in use.

Internal External

Clock Frequencies

The signal types, frequency ranges, and levels accepted for an external reference clock or sampling clock
are model dependent. See the product specifications at teledynelecroy.com.

Reference Clock
The default setting is to use the instrument's Internal 10 MHz clock. To use an external reference clock:

1. Connect a clock source to the Ref In 10 MHz input using a BNC cable.
2. GotoTimebase > Horizontal Setup and choose Real-Time Sampling Mode.
3. Onthe Clock Source tab under Reference Clock choose External.
Sample Clock
The default setting is to use the instrument's Internal clock. To use an external sample clock:
1. Connect a clock source to the EXT input using a BNC cable.
2. GotoTimebase > Horizontal Setup and choose Real-time Sampling Mode.
3. Onthe Clock Source tab under Sample Clock choose from 0V, ECL, or TTL pulse types.
4

. Choose an External Coupling that matches the clock source input impedance.

56


http://teledynelecroy.com/

Acquisition

History Mode

History Mode allows you to review any acquisition saved in the history buffer, which automatically stores
allacquisition records until full. Not only can individual acquisitions be restored to the grid, you can "scroll’
backward and forward through the history at varying speeds to capture individual details or changes in the
waveforms over time.

Eachrecord is indexed and time-stamped, and you can choose to view the absolute time of acquisition or
the time relative to when you entered History Mode. In the latter case, the last acquisition is time zero, and
all others are stamped with a negative time. The maximum number of records stored depends on your
acquisition settings and the total available memory.

Press the front panel History Mode button, or choose Timebase > History Mode to access this feature.

Entering History Mode automatically stops new acquisitions. To leave History Mode, press the History
Mode button again, or restart acquisition by pressing one of the front panel Trigger Mode buttons.

Note: History Mode does not work with Sequence Mode acquisitions, pre-processor Interpolation
set on the input channel, or channel interleaving.
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Replay Acquisition History

This is a good way to begin using History Mode. Watching a "'movie" of the history allows you to see
waveform changes that are invisible during real-time acquisition.

Select View History to enable the display, then use the Navigation buttons or the slider bar at the bottom
of the dialog to "scroll" the history of acquisitions.

« The top row buttons scroll: Fast Backward, Slow Backward, Slow Forward, Fast Forward.

« The bottom row buttons step: Back to Start, Back One, Go to Index (row #), Forward One, Forward to
End.

Press Pause when you see something of interest, then use the History table to find the exact Index.

Select Single Acquisition
1. Select View History to enable the display, and View Table to show the index of records.
2. Optionally, select to show Relative Times on the table.

3. View individual acquisitions by selecting the row from the table or entering its Index number on the
dialog.

58



Acquisition

Trigger

Triggers define the event around which digitized information is displayed on the grid.

Different Trigger Types are used to select different events in the trigger source waveforms: edge voltages,
pulse widths, high/low states, etc. These may be a single channel event or a complex pattern of events
across several channels. On instruments with Mixed Signal capabilities, many triggers can be set on either
analog channels, including the External Trigger input, or digital lines.

In addition to the type, the Trigger Mode determines how the instrument behaves as it encounters trigger
events: take a single acquisition and stop, holding on to the display of the last acquisition, or continuously
take and display acquisitions.

In both cases, when the previous acquisition has completed processing, the oscilloscope is again ready to
acquire and the READY indicator is lit. If, while READY, the trigger circuit detects a signal that matches the
trigger conditions, the oscilloscope triggers on the next matching event, and the TRIG'D indicator is it.

Unless modified by a pre- or post-trigger Delay, the trigger event appears at time 0 at the horizontal center
of the grid, and a period of time equal to five divisions of the timebase is shown to the left and right of it.
Delay shifts the trigger position on screen, displaying a different portion of the pre- or post-trigger
waveform.

An additional condition of Holdoff by time or events is available for Edge and Pattern triggers, including
those that appear within MultiStage triggers. Holdoff arms the trigger on the first matching event, inserts
the holdoff count, then triggers on a subsequent event. Often, especially with repetitive signals, the initial
arming event appears to the left of the trigger in "negative" acquisition time.

Trigger Modes

The Trigger Mode determines how often the instrument acquires. It is equivalent to how analog
oscilloscopes "sweep," or refresh, the display. Trigger Mode can be set from the Trigger menu or from the
front panel Trigger control group.

In Single mode, when you choose Trigger > Single or press the front panel Single button, the oscilloscope
readies, arms, and triggers provided all trigger conditions (including Holdoff) are met. It then stops and
continues to display the last acquisition until a new one is taken. The oscilloscope remains armed unless
manually stopped or triggered, and if a valid trigger does not occur, invoking Single a second time will force
a trigger and display the acquisition.

In Normal mode, operation is the same as in Single, except that the trigger automatically re-arms after the
previous acquisition is complete, and data is continuously refreshed on the touch screen.

Auto operates the same as Normal mode, except that a trigger is forced if the trigger event has not
occurred within a preset timeout period.

Stop ceases acquisition processing until you select one of the other three modes. The arming and Holdoff
counters are cleared, even if there has not yet been a trigger since the previous acquisition.
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Trigger Types

The Trigger Type sets the triggering conditions. Special MultiStage types allow one set of conditions for
arming and another (same or different) set for triggering.

If a type is part of a subgroup (e.g., Smart), first choose the subgroup to display all the trigger options.

Basic Types
Edge triggers upon a achieving a certain voltage level in the positive or negative slope of the waveform.

Width triggers upon finding a positive- or negative-going pulse width when measured at the specified
voltage level.

Pattern triggers upon a user-defined pattern of concurrent high and low voltage levels on selected inputs.
In Mixed-Signal oscilloscopes, it may be a digital logic pattern relative to voltage levels on analog channels,
orjust a digital logic pattern omitting any analog inputs. Likewise, if your oscilloscope does not have Mixed-
Signal capability, the pattern can be set using analog channels alone.

TV triggers on a specified line and field in standard (PAL, SECAM, NTSC, HDTV) or custom composite
video signals.

Serial triggers on the occurrence of user-defined serial data events. This type will only appear if you have
installed protocol-specific serial data trigger and decode options.

Measurement is not technically a trigger, per se, but permits the instrument to stop and display acquisition
based on a post-processing measurement result, similar to a trigger.

MultiStage Types

MultiStage triggers establish dependencies between two or more distinct events, some that "qualify" or
arm, and others that trigger. The individual events are defined exactly as are the basic types (Edge, Width,
Pattern, etc.).

Cascaded establishes a succession of criteria in Stages A-D. The trigger occurs when stages B through
D—or whatever is the last defined event—are achieved. In Normal trigger mode, it automatically resets
after finding the last defined event. You may apply additional Holdoff by time or number of events between
each stage in the cascade.

QualFirst arms the oscilloscope on the A event, then triggers on all subsequent B events, saving each asa
Sequence Mode segment.

Note: This trigger is only enabled when using Sequence sampling mode.

Qualified arms on the A event, then triggers on the B event. In Normal trigger mode, it automatically resets
after the B event, and re-arms upon the next matching A event.

Note: This functionality is identical to Teledyne LeCroy's previous Qualify and State triggers, but
presented through a different user interface.
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Smart Triggers

Smart triggers allow you to apply Boolean logic conditions to the basic signal characteristics of level, slope,
and polarity to determine when to trigger.

Glitch triggers upon finding a pulse-width that is less than a specified time or within a specified time range.

Window triggers when a signal enters or exits a window defined by voltage thresholds.

Interval triggers upon finding a specific interval, the time (period) between two consecutive edges of the
same polarity: positive to positive or negative to negative. Use the interval trigger to capture intervals that
fall short of, or exceed, a specified range.

Dropout triggers when a signal loss is detected. The trigger is generated at the end of the timeout period
following the last trigger source transition. It is used primarily in Single acquisitions with pre-trigger Delay.

Runt triggers when a pulse crosses a first threshold, but fails to cross a second threshold before re-
crossing the first. Other defining conditions for this trigger are the edge (triggers on the slope opposite to
that selected) and runt width.

SlewRate triggers when the rising or falling edge of a pulse crosses an upper and a lower level. The pulse
edge must cross the thresholds faster or slower than a selected period of time.

Trigger Set Up

To access the Trigger setup dialog, press the front panel Trigger Setup button or touch the Trigger
descriptor box.

Different controls will appear depending on the Trigger Type selected (e.g., Slope for Edge triggers).
Complete the settings shown after making your selection.

The trigger condition is summarized in a preview window at the far right of the Trigger dialog. Refer to this
to confirm your selections are producing the trigger you want.

rigger TriggerScan

Source
For most triggers, the Source is the analog channel or digital line to inspect for the trigger conditions.

Tip: When triggering on analog channels, the source can be easily set by dragging the desired
source channel descriptor box onto the Trigger descriptor box. Note that the trigger coupling and
slope/polarity will revert to whatever was last set on that channel.

Pattern triggers may utilize multiple sources (such as a mix of analog and digital signals), and likewise
MultiStage triggers may use different sources for the arming and triggering events.
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Coupling
For analog triggers, specify the type of signal Coupling at the input.

« DC-Allthe signal's frequency components are coupled to the trigger circuit for high frequency bursts
or where the use of AC coupling would shift the effective trigger level.

« AC - The signalis capacitively coupled. DC levels are rejected, and frequencies below 50 Hz are
attenuated.

« LFREJ-The signalis coupled through a capacitive high-pass filter network, DC is rejected and signal
frequencies below 50 kHz are attenuated. For stable triggering on medium to high frequency signals.

« HFREJ-Signals are DC coupled to the trigger circuit, and a low-pass filter network attenuates
frequencies above 50 kHz (used for triggering on low frequencies).

Slope/Polarity

For some triggers, such as Edge, you will be asked to select the waveform Slope (rising vs. falling) on
which the triggering event may occur.

For others, such as Width, the equivalent selection will be Polarity (positive vs. negative).

Level

For analog triggers, enter the voltage Level at which the triggering condition must occur. Use the Find
Level button to set the level to the signal mean.

Trigger types that require multiple crossings to define the triggering condition—such as Window, SlewRate
and Runt— will have Upper Level and Lower Level fields.

For digital triggers, the level is determined by the Logic Family that is set on the digital group. This can also
be specified by a custom (User-Defined) crossing Threshold and Hysteresis band. Usually, there will be a
separate Logic dialog tab for these triggers.

Hysteresis

For Edge triggers, you may select to Optimize for HF. When this box is unchecked, the trigger circuit's
hysteresis is set quite high to eliminate any potential trigger instability from high-frequency noise riding on
a low-frequency input signal. Because HF signal amplitudes tend to be smaller, the Optimize for HF setting
reduces the hysteresis value to make the trigger more sensitive. The effect this will have on trigger
behavior depends on the signal's spectral and noise content rather than just fundamental frequency, soit's
overall effect is difficult to quantify.

Conditions (Smart Triggers)
Smart triggers all allow you to apply Boolean logic to refine the triggering condition beyond simply Level
and Slope/Polarity.

The values that satisfy the operators of Less Than, Less Than or Equal To, Greater Than, etc. can be set
by entering an Upper Value and/or Lower Value.
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In some cases, it is possible to set a range of values that satisfy the condition. The values may be In Range
that is bounded by the upper/lower values or Out Range.

The extent of the range can often also be specified by using a Nominal and Delta value, rather than an
absolute upper and lower value. In this case, the Nominal value sets the center of the range, and the Delta
determines how many units plus/minus the Nominal value are included in the range.

For Dropout triggers, the default is to Ignore Opposite Edge, setting the trigger to dropout of the Positive
or Negative edge within the given timeframe. Deselecting it has the effect of setting the trigger to dropout
on Both edges.

Patterns

A triggering pattern of low/high states across multiple inputs is used by the Pattern type and MultiStage
types that include Patterns as either the arming or triggering event. Patterns may be set on analog
channels, digital lines, or a combination or both when Mixed-Signal capabilities are available.

Digital Pattern

The Logic Bus method simplifies pattern set up by utilizing digital groups and logic you have already
defined on the Digital Setup dialogs. A digital pattern is set on a single bus (group) manually or by applying
a hexadecimal value, while the remaining lines are disabled ("Don't Care").

If you have not set up digital groups, you can set a digital pattern line by line using the Logic method. All
available lines remain active for selection.

1. Onthe Trigger dialog, select Pattern trigger type. Open the Digital Pattern dialog.

Trigger Digital Pattern evels xt TriggerScan

Setallto

2. Atthe farright of the dialog, choose either Logic Bus or Logic.

3. Optionally, deselect Filter Out Unstable Conditions. This default filter ignores short glitches in logic
state triggers that last less than 3.5 ns.

4. If using Logic Bus, touch Source and select the digital group. Any lines that are not in this group will
now be disabled.

5. Toapply a digital logic pattern, either:

« Enterthe hexadecimal value of the patternin Hex or Value. Lines will take a logical 1, 0, or X
("Don't Care") according to the pattern. Disabled lines will remain X.

« Touch the Dx button for each active line, and select whether it must be High or Low compared
to the logic threshold. Depending on your selection, a logical 1 (High) or O (Low) now appears
on the dialog. Leave X selected for any line you wish to exclude from the pattern. Use the Left
and Right Arrow buttons to display lines in other digital banks.
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E=|| Note: As an alternative to a pattern, you may set edge conditions on any line. Touch the Dx

button and choose the edge. Edge conditions always assume a logical OR in the overall
trigger criteria.

As you work, the checkboxes along the bottom of the dialog will change to show the pattern. You
can also use these checkboxes to make selections.

If you have not already set a logic threshold, open the Levels dialog and select a Logic Family for
each digital bank from which you've selected lines. To set a custom logic threshold, choose Logic
Family User Defined, then enter the Threshold voltage and Hysteresis.

Note: Digital lines inherit the Logic Setup made when defining digital groups. However, you
can change the logic threshold on the Levels dialog. The two settings are linked and always

reflect whatever was last selected. Logic thresholds can only be set per lead bank, not
individual line.

Analog Pattern

0 Tip: With the Mixed-Signal option, you can also use the Digital Pattern dialog to set an analog state

pattern. Touch Set All To... and select Don't Care. This will eliminate any meaningful digital pattern
and activate all the Boolean operators. Use the Left Arrow button to display the C1-EXT group of
inputs, and follow the procedure below to set the low/high pattern on each input.

. Onthe Trigger dialog, select the Pattern trigger type.

. Select the Boolean Operator (AND, NAND, OR, or NOR) that describes the relationship among

analog inputs (e.g., C1 must be High AND C2 must be Low).

For each input to be included in the trigger pattern, select what State it must be in (High, Low, or

Don't Care) compared to the threshold Level you will set. Leave "Don't Care" selected for any input
you wish to exclude.

For each input included in the trigger, enter the voltage threshold Level.

If you've included EXTERNAL as an input, open the Ext tab and enter the external trigger
Attenuation.
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MultiStage Triggers

MultiStage types arm on the A event, then trigger on a subsequent event. The options for the triggering
event depend on the type of arming event.

See Cascaded, QualFirst and Qualified.

Measurement Trigger

Measurement is not technically a trigger, but permits the instrument to stop and display acquisition based
on a post-processing measurement result, similar to a trigger. The available measurements depend on
your model instrument and the options installed, and each will offer a different method for specifying the
"trigger" conditions, based on the type of measurement. Generally, you will be able to specify a triggering
value or range of values, and for @level parameters, the voltage level at which the measurement is taken.

A measurement can be defined as a standalone trigger condition or as the final condition in a multistage
Cascaded trigger.

Trigger TriggerScan Freg@vi Condition

Measurement Frequency of each full cycle at specified slope and
Freq@level level.

Find level

TV Trigger

TV triggers on a specified line and field in standard (PAL, SECAM, NTSC, HDTV) or custom composite
video signals.

Trigger

=
TV Standard ﬁ

&

TV Trigger
on Negative Edge

I evel
Level

-140 mvV

1. Choose the Source signal input.

2. Choose the signal TV Standard. To use a custom signal, also enter the Frame Rate , # of Fields per
line, # of Lines, and Interlace ratio.

3. Choose the Line and Field upon which to trigger.
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Serial Trigger

The Serial trigger type will appear if you have installed serial data trigger and decode options. Select the
Serial type then the desired Protocol to open the serial trigger setup dialogs. For setup instructions, see
the software instruction manual at teledynelecroy.com/support/techlib under Manuals > Software
Options.

Note: Certain software serial triggers can only be input on certain channels; the set up dialog will
instruct you which channel to use. A 3.125 Gb/s Serial Trigger hardware option is available for
WaveRunner oscilloscopes. This option provides capability for 8b/10b symbol triggering. The
trigger hardware is factory installed and is permanently connected internally to C4. Complete
information on the operation of the hardware serial trigger can be obtained in the High Speed Serial
Triggers Instruction Manual.
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Qualified Trigger

A Qualified trigger arms on the A event, then triggers on the B event. In Normal trigger mode, it
automatically resets after the B event, and re-arms upon the next matching A event. Unlike a basic Edge or
Pattern trigger with Holdoff, the A and B events can occur in different signals, allowing you to use the state
of one signal to "qualify" the trigger on another.

On the Trigger dialog, select MultiStage > Qualified trigger type to display the controls.
On the Trigger dialog, select MultiStage trigger type and choose Qualified.

Trigger Qualified Event "A’ Edge e TriggerScan

Qualified Event 'A’ Edge Event ‘B Pattern
Tr

Any Time

Besides an Edge or Pattern, two special conditions may be selected as the arming event (A):
« State, an analog or digital High/Low state ocurring on a single input.
« PatState, a pattern of analog or digital High/Low states across multiple inputs.

When B is an Edge or Pattern, a time window may be added to the trigger conditions by using the When B
Occurs buttons:

« Any Time triggers if B occurs any time after being qualified by A.
« Less Thantriggersonly if B occurs before the time set once qualified.
« Greater Than triggers only if B occurs after the time set once qualified.
« Events triggers on the next B event after the specified N Events once qualified.
As with regular Holdoff, the counter may begin from the Acquisition Start or the Last Trigger Time.

Once you've selected the A and B events on the Qualified dialog, set up the conditions on the respective
"Event” dialogs exactly as you would a single-stage trigger.
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QualFirst Trigger

The QualFirst trigger, which is used in Sequence sampling mode, is set up exactly like the Qualified trigger.
The only difference is that the "B" event is captured as a series of sequence segments, rather than a single
acquisition.

Cascaded Trigger

A Cascaded trigger type establishes a succession of criteria in Stages A-D. The trigger occurs when
stages B through D—or whatever is the last defined event—are achieved. In Normal trigger mode, it
automatically resets after finding the last defined event. You may apply additional Holdoff by time or
number of events between each stage in the cascade.

On the Trigger dialog, select MultiStage trigger type and choose Cascaded.

Trigger [S=ELELEL Stage "A’ Windo ge Stage 'C’ Edge TriggerScan

Width

Trigger Cascaded Stage ‘A’ Window Stage ‘B’ Glitch Stage 'C’ Edge TriggerScan

None

You may apply additional Holdoff at each stage by time or number of events:
« Time and Events work exactly as they do in other Holdoff counts.

« Time & Reset sets a Holdoff time between cascaded events, but resets to the beginning of the
cascade if no valid trigger occurs before the reset time expires.

Once you've selected the A through D events on the Cascade dialog, set up the conditions on the
respective sub-dialogs exactly as you would a single-stage trigger.
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Trigger Holdoff

Holdoff is either a period of time or an event count that may be set as an additional condition for Edge and
Pattern triggers. Holdoff disables the trigger temporarily, even if the other conditions are met. Use Holdoff
to obtain a stable trigger for repetitive, composite waveforms. For example, if the number or duration of
sub-signals is known, you can disable them by setting an appropriate Holdoff value.

Note: Qualified operates using time or event conditions similar to Holdoff, but arm and trigger
differently.

Hold Off by Time

Thisis a period of time to wait after the arming event before triggering on the next event. The maximum
allowed time is 20 seconds; the Holdoff time would otherwise be limited only by the input signal, the
coupling, and the instrument's bandwidth.

When a Holdoff by time is counted from the start of the acquisition, the oscilloscope readies, arms on the
first event, holds for the specified time, then triggers on the next event. After one full acquisition has
completed, the oscilloscope again readies, arms, holds, and triggers for the following acquisition.

l Holdoff 5 l lHuIduﬂS l

Arm Trigger Arm Trigger
[
i | : !
i | | !
oy !
oy !
[ oy !
!

Ready Complete One Acquisition Process  Ready Complete One Acquisition

Positive Edge trigger with Holdoff by time counted from the start of acquisition.

When a Holdoff by time is counted from the last trigger time, the oscilloscope immediately re-arms on the
first event following the trigger and begins counting the Holdoff, rather than wait to complete the full
acquisition. The Holdoff count continues even during the very brief time between acquisitions while the
oscilloscope is processing. As soon as the Holdoff is satisfied and the oscilloscope is again ready, it triggers
on the next event. The re-arming and Holdoff may occur in one acquisition, and the trigger in the next.

l Holdoff l IHnIdufF 5 I | Holdoff 5 |

Arm Trigger  Arm Trigger Arm Trigger
I [ I_ - [
| | [ | : |
o | [ T
[ 1 ! [ |
i | ! i i |
[ | oy
o ! o

Yy T o F T
Ready Complete One Acquisition Process  Ready Complete One Acquisition Process  Ready

Positive Edge trigger with Holdoff by time counted from the last trigger time.
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Note: Because there is only one trigger per acquisition, the trigger event will always belongs to the
new acquisition. The processing time shown here is for purposes of illustration only.

Regardless of where in the acquisition record the trigger event was found (first edge or last), the display
will show time pre- and post-trigger based on your Time/Div and Delay settings.

Hold Off by Events
Eventsrefers to the number of times the trigger conditions have been met following the arming event.

For example, if the Holdoff is two edges counted from the start of the acquisition, the oscilloscope readies,
arms on the first edge, holds off for the next two, triggers on the fourth edge, then completes the
acquisition. Because there must always be a first arming edge, the Holdoff appears to be "Holdoff plus
one."

|Hulduﬁ2Edges I |Hulduﬁ2Edges |
Arm 1 2 Trigger Arm 1 2 Trigger
- -

: 1 : |
[
| [ !
[
[
T

Ready Complete One Acquisition Process  Ready Complete One Acquisition

Positive Edge trigger with Holdoff by events counted from start of acquisition.

As with Holdoff by time, when a Holdoff by events is counted from the last trigger time, the oscilloscope re-
arms immediately following the trigger and begins the Holdoff count. If the count is satisfied by the time
the oscilloscope is again ready, the trigger occurs on the next event at the start of the new acquisition.

l Holdoff 2 Edges | | Holdoff 2 Edges l | Holdoff 2 Edges |

Arm 1 2 Trigger Arm 1 2 Trigger Arm 1 2 Trigger
| [ 1~ =7
| | : | | f I
| | [ | I | [
| | [ ! I | [
| i I | | I |
| | I | | f I
oy ! o !

Y
Ready Complete One Acquisition Process  Ready Complete One Acquisition Process  Ready

Positive Edge trigger with Holdoff by events counted from last trigger time.
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Holdoff Set Up

To add Holdoff to an Edge or Pattern trigger, touch the Trigger descriptor box or press the front panel
Trigger Setup button, then open the Holdoff tab.

Trigger Holdoff Software Assisted Trigger
Holdoff by

None

uutln

Time Acquisition Start

50.0ns Trigger on

s positive edge
RN E with Holdoff by Time

Choose to Holdoff by Time (the clock) or Events.

« Ifusing Holdoff by Time, enter the Time in S to wait before triggering.

« If using Holdoff by Events, enter the number of Events to wait before triggering.
Choose to Start Holdoff Counter On:

« Current Acquisition Start time.

« Last Trigger Time from previous acquisition.
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Software Assisted Trigger

Software Assisted Trigger is used to find the trigger-level crossing point closest to the hardware trigger
point. It then adjusts the time offset of the waveform so that it is aligned with the specified trigger level
and slope.

In the following figure, the white trace is the waveform at the input to software-assisted trigger
processing. The red trace shows it after processing, aligned with the trigger point indicated by the red
marker below the grid.

Note: This feature can only be used with an Edge trigger type in Normal trigger mode.
1. From the menu, choose Triggers > Trigger Setup, then touch the Software Assisted Trigger tab.

Mode

Auto

top Normal

0 s

N

. Touch Enable.

w

Create a trigger window by entering a Hysteresis value. This value sets a boundary above and
below the main trigger level to exclude noise.

4. Choose Auto or Normal mode; this determines the trigger behavior when trigger crossings are not
found in the trigger source waveform.
« Auto mode allows all waveforms through the channel.

« Normal mode allows waveforms only with a trigger crossing within the horizontal gate region
through the channel.

5. Set Start and Stop time values on the Horizontal Gate part of the Software Assisted Trigger tab.
These values control where in the waveform the software-assisted trigger processing searches for
trigger crossings.
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TriggerScan

TriggerScan is a debugging tool that helps you quickly discover waveform anomalies by automating the
process of building triggers designed to find rare events in an acquisition. TriggerScan:

« Trains the system by looking at normal acquired waveforms. During the training, TriggerScan
analyzes the waveforms to determine what waveforms normally look like. Using this information, it
generates a list of smart triggers to isolate abnormal situations.

« Loads the trigger setups from the Trainer and cycles them. As triggers occur, they are overlaid on the
screen. All acquisition settings are preserved, and you can use other tools to find the root cause of
these anomalies such as WaveScan, Histograms, etc.

Training TriggerScan

The TriggerScan Trainer inspects the current acquisition and automatically builds a list of trigger setups
that could potentially be used to find events of interest.

Note: Run the Trainer if you want to change the trigger types or if you change the channel or
signal. You must acquire and display at least 3 cycles of a signal before running the Trainer.

1. Touch Trigger > Trigger Setup... from the menu bar, then open the TriggerScan tab.
2. Touch the Trainer button.

3. Onthe TriggerScan Trainer pop-up, choose the Source channel on which to train and trigger, and
select all the trigger types you want to set up.

4. Touch the Start Training button. When training is complete, a list of smart trigger setups is
displayed in the Trigger List.

Modifying Trigger List

Follow these steps to change the triggers created by TriggerScan. Once you have finalized the Trigger
List, you are ready to start scanning.

1. Choose Trigger > Trigger Setup... from the menu bar, then open the TriggerScan tab.

L

Edge 470 mV Po: - Load

Trainer
i Selected

Browse
Delete
Selec
Load Setup

Delete
All

2. Make any of the following modifications to the Trigger List:

« Add new trigger: touch the Trigger descriptor box and set up the new trigger as desired on the
Trigger dialog. Then, back on the TriggerScan dialog, touch the Add New button to append
the new trigger to the Trigger List.
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« Replace atrigger with one manually set up on the Trigger dialog: highlight the setup in the
Trigger List and touch the Update Selected button.

. Delete a trigger: highlight the setup in the Trigger List and touch the Delete Selected button.
All trigger setups can be deleted in one step by touching the Delete All button.

3. Optionally:
« Enter a Dwell Time the time instrument should wait before loading the next trigger.
« Checkthe Stop On Trigger checkbox. You can use this to isolate events as the triggers find

them.

Note: If you have Persistence enabled, all trigger events are recorded on the display.

Saving TriggerScan Setups

You can preserve the Trigger List by saving it to a setup file. The current Trigger List is not preserved after
exiting the application unless you manually save it.

1. Onthe TriggerScan dialog, touch Setup File Name and enter a file name, or touch the Browse
button and select a location and file name.

2. Touch the Save Setup... button.

Toreload a saved Trigger List, touch the Browse button, locating the file, then touch Load Setup....

Running TriggerScan
When the Trigger List is set, touch the Start Scan button on the Trigger Scan dialog. The instrument
automatically cycles through all the triggers in the list.

Torunonly a single trigger, select it from the Trigger List and touch Load Selected. The trigger settings
are copied to the Trigger dialog and will be used when you start acquisition.
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Display settings affect the number and style of grids that appear on screen and some of the visual
characteristics of traces, such as persistence.

Multi-Grid Display
WaveRunner 8000Zi series oscilloscopes feature multi-grid display, where each separate grid represents
the full number of 256 vertical levels.

Auto Grid Mode is enabled by default. This feature adds a grid each time a new trace is opened, up to 16
grids, until no more grids are available. There are display options to show all traces on a Single Grid, or to
manually divide the display into different numbers and orientations of grids. The Grid Mode icon shows
what the result of the selection will be.

B File ¥ Vertical ++ Timebase I Trigger s ( El Measure @ Math | Ana X Utilities = @ Support

SIS = FEET

-600 ps -400 us 0hs 400 ps 600 ps

udwmlww

-100ms 80 ms -60 ms -40 ms 20 ms ohs 20ms 40 ms 60 ms 80 ms 100 ms

[CAN Std __ JyTr D IDE_RTR DLC Data BitRate Status
s S 0x740 0071

0x17bcTocf 1 1

0x1a47df96 1 1

0x57d 0.0

F1 C1-C2)|F2  trend(P1 Fd hist(P6)|F5  zoom(C1 | ! Thase 0.0 msf Trigger (1508
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388 5.082 k# 1 |
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7
8 79fb 19c6 03 f7 3f 61

Multi-grid display.
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Q-Scape Multi-Tabbed Display

Available with the Q-Scape option, the Q-Scape Display Modes divide the screen into multi-tab displays,
each of which can be configured with a different multi-grid display mode. Many of the same functions you
can perform in Normal mode, such as moving traces by drag-and-drop, you can also perform in Q-Scape
modes.

The Display Mode setting determines whether the touch screen has a single display area ("Normal" mode)
or tabs each representing a separate display (the various "Q-Scape" modes). The Grid Mode setting
determines how grids are configured within the display area and what kind of traces they show (for
example, XY or VT). Normal Display Mode (a single display) is the default.

[ File ¥ Vertical =+ Timebase | | Trigger & Display | # Cursors | E Measure @ Math | Analys X Utilities = @ Support T vl Gesture H.r'-j
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Multi-tab display with different grid styles.
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Display Set Up

To access the Display dialog, choose Display > Display Setup.

Display

Grid Mode

d

Display Mode (Q-Scape only)
The Display mode determines the number and layout of display tabs. Choose Normal (default), a single
display with no tabs, or one of the three Q-Scape display modes:

« Q-Scape Single, a single set of four tabs stacked so that only one at a time is visible. Each tab can
have any style of grid mode, same or different.

IDE_RTR DLC Data
0.0 1 00

476 mV/
10.0 ms/div

« Q-Scape Dual, two sets of four stacked tabs. Equivalent tabs in each set share the same grid mode,
but can display different traces. You can simultaneously view one tab from each set, but they must
be different numbered tabs (e.g., Tab 1 from set one and Tab 3 from set two).

track(P3)
50,0 bitls
10.0 ms/div
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« Q-Scape Mosaic, a single set of four tabs arranged so that all are viewed simultaneously.

In Q-Scape modes, channel, math, memory, and zoom descriptors appear in the tab where the trace is
open, while Timebase and Trigger descriptors remain outside the tabs, since they are not associated with
any one trace.

Note: If you switch from Normal mode into any Q-Scape mode, all traces willmove to Tab 1, from
which you can drag-and-drop to redistribute them to other grids. In Q-Scape Single mode, you will
not be able to drag-and-drop traces across tabs, only to other Tab1 grids.

Torename Q-Scape tabs after they open:

1. Touch-and-hold (right-click) on the Tab <#> until Rename pops up.

2. Touch Rename.

3. Enterthe New Alias, then touch OK.

Extended Display

Note: The "Extend Grids..." option only appears when a second monitor is connected. Minimize the
oscilloscope window and use the standard Windows Display controls to make the instrument the
primary display. It should be extended, not duplicated.

To take advantage of an extended display in Q-Scape mode:
1. Onthe Display dialog, select Extend Grids Onto 2nd Monitor. The Select Grid pop-up opens.

2. Switch to the Extended Display submenu and choose a Grid style. Tab 1 and the external monitor
will share the same grid style.

Tip: Drag-and-drop descriptor boxes to place traces on the desired grids.To take full advantage of
Q-Scape on the larger display, choose File > Windowed on the instrument, then grab the window
title bar and drag it to the external monitor screen. Drag the Extended Display window to the
instrument screen.

78



Display

Grid Mode

Touch the Grid button, then select one of the grid modes. In Normal Display Mode, select one Grid Mode.
In Q-Scape Display Mode, select a Grid Mode for each tab. The selection icon shows the number and

arrangement of grids.

Grid Mode | Number | Orientation | Notes

Auto variable [ landscape Automatically adds or deletes grids as traces turned on/off, up to the maximum
(default) supported

Single 1 landscape All traces share one grid

Dual 2 landscape One top, one bottom

Tandem 2 portrait One left, one right

Triplex 3 landscape Stacked top to bottom

Triad 3 portrait Left, center, right

Quad 4 landscape Stacked top to bottom

Quattro 4 landscape One in each quarter of screen

Octal 8 landscape Two columns of four stacked top to bottom
Twelve 12 landscape Three columns of four stacked top to bottom
Sixteen 16 landscape Four columns of four stacked top to bottom
XY 1 portrait Single XY type grid

XYSingle 2 portrait One VT grid left, one XY grid right

XYDual 3 variable Two VT grids left, one XY grid right

Note: Additional grid modes may become available with the installation of software options.

Grid Intensity

To dim or brighten the background grid lines, touch Grid Intensity and enter a value from 0 to 100.

Grid on top superimposes the grid over the waveform.

Note: Some waveforms may be hidden from view with the grid on top.

Axis labels display the values represented by each division of the grid, based on your vertical scale and
timebase. Turned on by default, they may appear as absolute values or delta from center (0). Deselect the
checkbox to remove them from the display.
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Trace Intensity
Choose a line style for traces: solid Line or disconnected sample Points.
When more data is available than can actually be displayed, Trace Intensity helps to visualize significant

events by applying an algorithm that dims less frequently occurring samples. Touch Intensity and enter a
value from 0 to 100.

Intensity 40% (left) dims samples that occur < 40% of the time to highlight the more frequent samples,
vs. intensity 100% (right) which shows all samples the same.

XY Plots

XY plots display the phase shift between otherwise identical signals. They can be used to display either
voltage or frequency on both axes, each axis now corresponding to a different signal input, rather than a
different parameter. The shape of the resulting pattern reveals information about phase difference and
frequency ratio.

Note: The inputs can be any combination of channels, math functions, or memories, but both
sources must have the same X-axis scale.

Choose an XY grid mode and select the sources for Input X and Input Y.

Sequence Display Mode
Use these settings to select the Display Mode used when sampling in Sequence mode.
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Persistence Display

The Persistence feature retains waveform traces on the display for a set amount of time before allowing
them to gradually "decay," similar to the analog-style display of old, phosphor screen oscilloscopes.

The display is generated by repeated sampling of events over time and the accumulation of the sampled
data into "persistence maps". Statistical integrity is preserved because the duration (decay) is proportional
to the persistence population for each amplitude or time combination in the data.

The different persistence modes show the most frequent signal path in three-dimensional intensities of
the same color (Analog), or in a graded spectrum of colors (Color).

The Ptrace math functions compute a vector trace based on a persistence map that can be used for
further analysis. The Phistogram math function can be used to statistically represent the frequency of
samples within a vertical and/or horizontal slice of a persistence map.

Access the Persistence dialog from the Display dialog or by choosing Display > Persistence Setup.

All Locked

Per Trace

Apply Persistence
1. Check Persistence On.

2. Tosetupalltracestogether, touch All Locked. This constrains all input channels to the same
persistence settings.To set up traces individually, touch Per Trace.

3. Use the buttons to select a persistence mode:

Color Mode persistence works on the same principle as Analog
persistence, but instead uses the entire color spectrum to map signal
intensity: violet for minimum population, red for maximum population. In
this mode, all traces use all colors, which is helpful for comparing
amplitudes by seeking like colors among the traces.

In Analog Mode, as a persistence data map develops, different intensities
of the same color are assigned to the range between a minimum and a
maximum population. The maximum population automatically gets the
highest intensity, the minimum population gets the lowest intensity, and
intermediate populations get intensities in between these extremes. The
information in the lower populations (for example, down at the noise level) could be of greater
interest to you than the rest. The Analog persistence view highlights the distribution of data so that
you can examine it in detail.
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3d Mode persistence creates a topographical view of your waveform from a selection of shadings,
textures, and hues. The advantage of the topographical view is that areas of highest and lowest
intensity are shown as peaks and valleys, in addition to color or brightness. The shape of the peaks
(pointed or flat) can reveal further information about the frequency of occurrences in your
waveform. You choose the Quality of the 3D display:

Solid quality can be either color or monochrome. Saturation is set at 50%,
with hotter colors indicating highest intensity.

In the monochrome view of solid, the lightest areas indicate highest
intensity, corresponding to the red areas in the color view.

In shaded (projected light) quality, the shape of the pulses is emphasized.
This quality is monochrome only.

In wire frame quality, lines of equal intensity are used to construct the
persistence map. This display can be either color or Monochrome.

In 3d mode, X Axis Rotation and Y Axis Roation canrange 180° from -90° to +90°. In the examples
above, the X-axis is rotated 60° an the Y-axis 15°.

Tip: To quickly rotate the graph, grab a corner of the persistence map and drag it in the
desired direction.

4. Select the Saturation level as a percentage of the maximum population. All populations above the
saturation population are assigned the highest color intensity: that is, they are saturated. At the
same time, all populations below the saturation level are assigned the remaining intensities. Data
populations are dynamically updated as data from new acquisitions is accumulated. A saturation
level of T00% spreads the intensity variation across the entire distribution; at lower saturation levels
the intensity will saturate (become brighter) at the percentage value specified. Lowering this
percentage causes the pixels to be saturated at a lower population and makes visible those events
rarely seen at higher saturation levels.

5. InPersistence Time, enter the duration of time (in seconds) after which persistence data is erased
from the display.

6. Choose to superimpose the last waveform over the persistence display by selecting Show Last
Trace (not available in 3d mode).

7. Todisplay persistence traces as a continuous line (instead of a series of sample points), select Dot
Joined.

Remove Persistence

To turn off persistence and return to the regular trace style, clear Persistence On or select an individual
trace's None (left-most) persistence mode button.
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Math and Measure

Teledyne LeCroy offers arich set of standard, pre-programmed tools for the "quickest time to insight" into
the characteristics of acquired waveforms. Most instruments calculate measurements for all samples in
an acquisition, enabling you to rapidly and thoroughly calculate thousands or millions of parameter values
and apply a variety of mathematical functions to the input waveform trace.

Cursors

Cursors are markers (lines, cross-hairs, or arrows) that identify voltage and time values on the waveform.
Use cursors to make fast, accurate measurements of specific points in the waveform. There are five,
standard cursor types available.

Vertical (amplitude) cursor readouts appear the trace descriptor box; Horizontal (time) cursor readouts
appear below the Timbebase descriptor box.

Cursors can be placed on math functions whose X-axis has a dimension other than time, such asan FFT.
When there is at least one non-time-domain math trace open, the Standard Cursors dialog contains an X-
Axis control where you can choose the units measured by the horizontal cursors. The options will be
appropriate to the types of function traces open; for example, if there is an FFT trace, there is an option for
Hz. The cursor lines are placed on the traces that normally display X-axis values in the selected units.

B File 3 Verical = Timebase [ Trigger | & Display | # Cursors [l Measure @ Math | = Analysis X Utilties @ Support

200mV

100mv

-100 mV [

-150mV

200mV ;) ci
-100ns 100ns 200ns 4005 500ns

Trigoer (81 L8

50.0 mV/| | 100 ns/div Auto 0.0 mV

0.0 mV ofst; | 10 kS 10 GS/s Edge Positive
515 mV: | X1= 2013ns  AX= 96.€

8ns
-100.0 mV ! ! X2= 199.5ns 1/AX= 25202 MHz
Ay -151.5mV)} |

Horizontal Relative cursors.
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Cursor Types
Horizontal (Time) cursors intersect points on the horizontal axis.

« Horizontal Abs displays a single, dashed, vertical line. The readout shows the absolute value at the
cursor location.

« Horizontal Rel displays two, dashed, vertical lines. The readout may be in absolute values or a delta
of the two points, depending on the Show option selected.

Vertical (Amplitude) cursors intersect points on the vertical axis.

« Vertical Abs displays a dashed, horizontal line. The readout shows the absolute value at the cursor
location.

« Vertical Rel displays two dashed, horizontal lines. As with Horizontal Relative cursors, the readout
may show absolute values or a delta.

The Both Rel(ative) option places both Vertical and Horizontal Relative cursors together.
Apply and Position Cursors

Apply Cursors
Toturn on cursors, either:

« From the menu bar, choose Cursors and select the desired cursor type from the drop-down list.

« Onthe front panel, press the Cursor Type button repeatedly to cycle through all the cursor types.
Stop when the desired type is displayed.

Note: There must be a waveform on the grid for cursors to execute, although acquisition may be in
process or stopped when you turn them on.

To turn off cursors, choose Cursors > Off, or continue cycling the button until they disappear.

Position Cursors

The easiest way to reposition a cursor is to drag-and-drop the cursor marker to a new position. Indicators
outside the grid show to which trace the cursor belongs when you have multiple traces on one grid.

Alternatively, turn the front panel Cursors knob. If both vertical and horizontal cursors are turned on, push
the knob until the correct line is selected, then turn to move it. When there are multiple traces each with its
own cursors on the same grid, bring the desired trace to the foreground by touching the trace or its
descriptor box. The Cursors knob will only operate on the foreground trace.

If Horizontal cursors are applied to a source trace but do not appear on its dependent traces (e.g., a zoom)
because of differences in scale, drag-and-drop the cursor readout from below the Timebase descriptor
box onto the target trace or its descriptor box. This applies the same cursors at the 5 (single cursor) or 2.5
and 7.5 (relative cursors) division mark of the target trace and adjusts source cursors accordingly.
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Note: Horizontal Relative cursors are initially placed one on the negative side of the X-Axis (marked
by ) and one on the positive side (marked by [). If you move the negative cursor to the right of
the positive cursor, or vice versa, the delta is shown in negative increments.

Standard Cursors Dialog

These controls can be used instead of the front panel controls to set cursors or to refine the cursor
position. Access the dialog by choosing Cursors > Cursors Setup from the menu bar.

Cursors Ondisplays or hide cursor lines. When first checked, the last selected cursor type is displayed.
Cursor Type buttons select the type of cursor displayed on the grid.

The Show controls determine which values are shown in the readout, particularly when using relative
CUrsors:

« Absolute shows specific voltages for the two cursor locations.

« Delta shows the difference between the specific voltages at the cursor locations.

« Abs+Delta shows both the absolute and delta readouts.

« Slope (Horizontal Relative only) shows the slope of the waveform between the cursor locations.

The Position controls at the right-side of the Standard Cursors dialog display the current cursor location
and can be used to set a new location. The options available depend on the Cursor Type and Show
settings.

« X1 (negative) and X 2 (positive) sets time from the zero point.

« Y 1 (negative) andY 2 (positive) sets number of divisions from the zero level. May be a fraction of a
division.

« Tracklocks cursor lines so they move together, maintaining their same relative distance from each
other.

XY Cursors Dialog

If your Grid Mode selection includes an XY trace display, an XY Cursors dialog appears behind the
Standard Cursors dialog. Use it to exactly position and track the cursors on the XY trace, the same as you
use the settings on the Standard Cursors dialog for VT traces. The functionality is the same.
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Measure

Measurement parameters are tools that give you access to a wide range of waveform properties. Use
them to analyze many attributes of your waveform such as rise-time, rms voltage, and peak-to-peak
voltage. Measurements can also be graphed as a histrogram, track, or trend for statistical analysis.

The instrument offers a quick selection of standard horizontal and vertical measurements, or you can
create a custom set of parameters (My Measure) drawn from all available measurements.

Measure Table

Measurement readouts appear in a table below the grid. The value row shows the measurements taken
for each parameter on the last cycle of the last acquisition. Other rows show optional statistics.

Timebase 0 ns
200 ns/div Auto 0.0 mV
0.0 mV ofst | | 20 kS 10 GS/s Edge Positive

Measurement Status Indicators
Symbols in the status row of the Measure table indicate the following:

Symbol | Description

Problem with the signal or the setup. Touch cell to see explanation in message bar.

Valid value returned.

Unable to determine top and base; however, measurement may still be valid.

Underflow condition.

Overflow condition.

Simultaneous underflow and overflow condition.

Navigating with the Table

Close setup dialogs when the Measure table is displayed to maximize the touch screen area available for
viewing waveforms. The table itself can be used to quickly access setup dialogs. To open the Parameter
Setup (Px) dialog, touch the Px cell of the table. Touch the far left Measure column to open the Measure
dialog and modify the table contents. The table is static when using the standard measurements, as these
cannot be changed.

Quick Table Setup

Any parameter can be copied by dragging the cell onto the target cell of the table. Then, drag the desired
measurement source descriptor box onto the new parameter. Touch the cell to make any other
modifications on the Px dialog.
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Measure Dialog

The Measure Dialog gives quick access to measurement features. Besides turning on/off parameters, use
the Measure dialog to display Statistics, Histicons, or Help Markers for standard and user-defined
parameter sets. You can also Gate the standard parameter sets to limit the horizontal scope of the
measurement. All standard parameters will share the same gate. (Use the Px dialogs to gate user-defined
parameters.)

ampl(C1)
My
Measure M@x(C1)
Std
Vertical

delay(C1)

std
Horizontal 4 On  dt@MC1.C2) On  ovsh+C1) Sweeps

Select Measurements

1. Toopen the Measure dialog, touch the Add New box and select Measurement, or choose Measure
> Measure Setup from the menu bar.

2. Check Show Table to display the measurement readout on screen.

3. Checkthe selection box for each measurement you wish to display. Touch the Px button to define
anew measurement.

Standard Parameter Sets
Pre-configured standard parameter sets are available for quick display. Choose either:

« Std Vertical: mean, sdev, max., min., ampl, pkpk, top, base.
« Std Horizontal: freq, period, width, rise, fall, delay, duty, num points.

To define your own parameter set, choose My Measure. Open the Px dialogs to define new parameters.
Once parameters are configured, select the On checkbox next to each parameter to turn on the
measurement.

To quickly begin a new parameter set based on the standard vertical or horizontal sets, touch Quick
Setups and choose the set to copy. Refine the settings on the Px dialogs. Touch Clear All to remove all
measurement definitions.

A Caution: Definitions cannot be restored after clearing, you must repeat measurement set up.

Statistics

Checking Statistics On adds the measures mean, min., max., sdev, and num(ber of measurements
computed) to the table.

For any parameter that computes on an entire waveform (like amplitude, mean, minimum, maximum,
etc.) the num statistic represents the number of sweeps.
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For any parameter that computes on every event, the num statistic represents the number of events per
acquired waveform. If x waveforms were acquired, num is x times the number of cycles per waveform.

To reset the statistics counter, touch Clear Sweeps on the display or front panel.

Histicons

Histicons are miniature histograms of measurement parameters that appear on the measurement table.
These thumbnail histograms let you see at a glance the statistical distribution of each parameter. Select
the Histicons checkbox to turn on histicons.

0 Tip: You can quickly display a full histogram by touching the histicon you want to enlarge.

Help Markers

Help Markers clarify measurements by displaying lines, labels and hysteresis bands to mark the points
being measured on the trace. For "@Level" parameters, markers make it easier to see where your
waveform intersects the chosen level.

You can choose to use Simple markers, which are only the lines, or Detailed markers, which include the
measurement point labels.

You also have the option, by means of the Always On checkbox, to leave the markers displayed over
traces after you have closed the Measure dialogs or readout table. If you change the set of parameters
displayed, the markers will change, as well.

@ Note: Unlike regular cursors, which are white and can be moved, help markers are blue and only
augment the display; they cannot be moved, and they do not reset the measurement points. Some
optional analysis software packages include markers designed specially for that domain of
reference, which are documented in the option manual.

Detailed Help Markers on standard horizontal parameters.
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Parameter Set Up
Use the Px dialogs to define a new set of measurement parameters ("My Measure").

You may also define parameters using Math on Parameters or the Web Editor.

1.

10.

11.

From the menu bar, choose Measure > Measure Setup. On the Measure dialog, select Show Table

to display the readout on screen.

Tip: To quickly reopen the Measure Setup dialog, touch any cell of the Measure readout
table.

Choose Measure Mode My Measure.
Open the dialog Px of the parameter you wish to use.

Check On to enable the parameter and add it to the measurement readout table.

dt@v(C1,C2) e ' Find level

Actions for P4

el

Histogram

Select the Type Measure On Waveforms.

Touch Source1 and select the channel, math trace, memory trace, or other waveform to be
measured.

Touch the Measure field and select the measurement from the pop-up menu.

Enter the measurement Level and Type (percent or absolute) when it appears on the parameter

subdialogs (e.g., for @Level parameters).

For certain time-based measurements, choose to measure on the positive, negative, or both Slope

(s). For two-input parameters, such as Dtime@level, you can specify the slope for each input, as

well as the level and type.

Make any further selections on the subdialogs that appear after your Measure selection. These are

explained on the dialog and are necessary to fully define the selected measurement.
Optionally, turn on Help Markers, or use the parameter subdialogs to:
« Gate measurements (limit the horizontal scope of the measurement)

« Qualify measurements (accept only measurements that meet additional conditions)
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Gating Measurements

By using gates, you can narrow the span of the waveform on which to perform tests and measurements,
allowing you to focus on the area of greatest interest. For example, if you "gate" five rising edges of the
waveform, rise time calculations are performed only on the five pulses bounded by the gate posts.

The default starting positions of the gate posts are 0 divand 10 div, which coincide with the left and right
ends of the grid. Therefore, the gate initially encloses the entire waveform.

The quickest way to set a gate is to drag the gate posts from the far left and right of the grid to the desired
positions. You can refine this setting down to hundredths of a division by using the Gate Start and Stop
fields on the Gate subdialog.

Touch the Default button to return gates to the width of the trace.

Qualified Measurements

Some measurements can be constrained to a vertically or horizontally limited range of samples, or to
samples "gated" by the state of a second waveform. Both constraints can operate together. This
capability enables you to exclude unwanted characteristics from your measurements. It is much more
restrictive than a measure gate, which is used only to narrow the span of analysis along the horizontal axis.

Note: Since this feature operates on only a subset of the data, possible alerts or status indicators
concerning the measurement (such as "Data range too low") are not displayed.

If the measurement supports this feature, you will see the Accept subdialog next to the Px dialog for you to
define your constraints.

N-Cycle Jitter

-1.000 5

Find Range Find Level

Range Limited Parameters

1. From the menu bar, choose Measure > Measure Setup..., then touch the Px tab to open the
parameter setup dialog.

2. Onthe Accept subdialog, select Values In Range and enter the start and stop values, or touch the
Find Range button to quickly display the most recently measured range of values.
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Note: The correct units for the measurement (V, s, Hz, dB, etc.) are automatically

displayed. If you select a simple ratio parameter that yields a dimensionless number (such
as power factor) , units are omitted.

Waveform Gated Parameters

1.

From the menu bar, choose Measure > Measure Setup, then touch the Px tab to open the
parameter setup dialog.

On the Accept subdialog, select Values Based on Waveform State.

Touch When Wform and select the gating waveform. It can be any waveform active at the same
time as the measurement source waveform.

Touch State Is and select High or Low from the pop-up menu. Measurements will only be taken
when the gating waveform is in the selected state.

Touch Level Type and select Absolute (voltage) or Percent (of amplitude) from the pop-up menu.
Enter the crossing Level value at which you want measurements to begin.

You can also touch the Find Level button to automatically set the level at 50% of the gating
waveform.

Using Custom Scripts

On instruments installed with the Advanced Customization option (XDEV), custom scripts may be used to
define a measure parameter, math function, or math on parameters. Several scripting "languages" are

supported besides VBScript ( the instrument's "native tongue"), depending on the application. You can find
these options in the Custom submenu of the Measure/Math Selector. Scripts may be imported or written
in the instrument's Script Editor window and saved for future use. See Using P Script for a description of
the process.
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Math on Parameters

In addition to measuring waveforms, you can set up a parameter that performs mathematical operations
on other parameters. Math on parameters differs from math functions in that the input and the output are
still numerical values that display in the measurement readout table. Math functions, on the other hand,
input and output waveform traces that appear on the grid.

The setup for math on parameters is much like that for other parameters. Some parameters can be
qualified on the Accept subdialog using value ranges or gating waveforms, as can regular waveform
measurements. If you have the Advanced Customization (XDEV) option, there is functionality for applying
custom scripts to calculate the results.

Exclusions
« Multiplication and division of parameters that return logarithmic values

« Source parameters that are the result of other parameter math operations

Setting Up Math on Parameters
1. From the menu bar, choose Measure > Measure Setup....
. Choose Measure Mode My Measure and open a parameter setup (Px) dialog.

. Touch the Math on Parameters button.

2

3

4. Touch Math Operator and choose an operation from the Select Measurement menu.

5. Touch the Source fields and select the parameters that are the inputs to the measurement.
6

. Check Onto enable the new output parameter and add it to the measurement readout.

Using P Script (Custom Math on Parameters)

On instruments installed with the Advanced Customization option (XDEV), you can write your own
VBScript or JavaScript to apply a mathematical operation to one or two input parameters. Choose the
Math Operator P Script. Scripting can be done directly on the instrument in the Script Editor window, or
you can import an existing script.

Note: Param Script is a VBScript or JavaScript that performs a measurement on one or two
waveforms to output a parameter. P Script, which is Math on Parameters, is a VBScript or
JavaScript that inputs one or two parameter values and performs a math operation on them to
output another parameter.

B Math Operator
E.. i
b P E:I'it

pscript(P2,P3)
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1. Choose Measure > Measure Setup from the menu bar.

Touch the Math on Parameters button.
Touch Math Operator and choose P Script.

Enter the Source input parameter(s).

N oo~ W

Function Update() '

CutResult.Value = InResultl.Value * InResult2.Value
OutResult.VerticallUnits = "HZ"

End Function

Default atiye - OK Import Export
Status : OK
Code tatus - OK from File to File

Cancel Apply

Touch the Edit Code button to open the Script Editor window.

Touch the Px tab of the output parameter to display the parameter setup dialog.

On the Script Math subdialog, touch Script Language and choose either VBScript or JScript.

8. Enteryour code in the window, or Import from File an existing script. Click Apply and OK to finish.

0 Tip: Scripts created in this window can be exported to a new file for future use.
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Using Web Editor

Whereas with Math on Parameters you can apply a single math operation to a measurement parameter,
the Web Editor enables you to create processes that potentially chain many operations and inputs,
including custom math and measurements (with the XDEV option). These processes are integral to the
operation of the instrument; there is no need to export data to other programs.

Processes are "programmed" in the X-Stream application simply by dragging and dropping a series of
blocks representing different math functions or measurements and connecting them to form a flow
chart—a "processing web." The terminal parameters and functions represent the final output of this
process.

Create Processing Web
1. From the menu bar, choose Measure > Measure Setup.
2. Onthe Measure dialog, choose Measure Mode My Measure.

3. Openthe Px dialog and select Advanced Web Edit.

Measure

On
L 4

ummary Select me
web edit
Actions for P1 Help

.dn]ha.

Histogram

4. Touch the Show Processing Web button. You will see a "peg board" display with potential input
sources aligned along the left, and a terminal marked with the parameter number to the far right.

Web Editor Math Vieasure Source Filter
Add P Enable/

dd ne e Ld Measure
+ Math 1o th A i pear only in L. ; ’

M Math

+ Meas.

.
|
.
|
.

+ PMath A ew pa_ra{melel; math to
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9.

On the Source Filter subdialog, deselect any types (e.g., zooms) that you do not want to use in the
process. This simplifes the display and reduces the need to scroll.

On the Wed Editor dialog, choose the type of process to add to the flow. You can Add Math, Add
Measure, or Add Param Math (Math on Parameters).

From the pop-up, choose the operation or measurement that will occur at that node. A new block
appears on the display. Drag the block to a location in the flow.

Tip: Touch the location to place a green plus sign before adding the node. Then, the new
block will be created at this spot. Otherwise, blocks may cover one another until moved.

The process block will have a input "pin" on the left. If a waveform is required, the pinis blue; if a
number is required, the pin is purple. Touch and drag a matching colored pin from the sources on
the left of the screen to the block. Choose as many sources as there are input pins on the block.

Tip: You may need to use the scrollbar to see all the available sources. For convenience,
the Math and Measure dialogs behind the Web Editor dialog summarize what is currently
configured for those sources.

When you drop the pin, a line is drawn from the source to the process. If a source is incompatible
with a process, you will not be able to pinit.

Web Editor Mat
Ad

Previewed nodes appear only in
the Web Editor.

+ Meas. - inaweb Sparsing factor

+ PMath

If the process requires additional configuration, a subdialog appears next to the Web Editor dialog.
Use it to enter the values to apply to that processing node.
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10. Continue to add processes as needed, pinning the output of each block to the input of the next
block in the flow. The final process should be the same type as the terminal (in this example, a
measurement).

Note: The flow does not need to be strictly sequential, as many processes can accept
multiple inputs that may or may not have undergone other processes. The only
requirement is that the outputs are pinned to acceptable inputs. The color of the
input/output arrows indicates which connections are compatible.

11. Dragthe output pin from the final process block to the input pin on the terminal.

Preview Outputs
You can add preview "windows" to see the output of a process at any stage in the flow. These previews
apply only to the Web Editor.

Select the output pin of the processing block you wish to preview. It will turn bright green. Then, on the
Web Editor dialog choose Add Preview.

Delete Process/Connection
To delete any process from the web, select the block then touch Delete. All the connections to/from it are
automatically deleted.

Toremove a connection between process blocks, touch the line. A scissor icon appears above it. Confirm
whether or not to "cut” the connection.

Add Other Terminals to Processing Web

Other measurements or math functions can share the same processing web. For example, you may wish
to create a math function of the waveform that would result from a sub-processing node, while the final
output of the full process is a measurement parameter.

Toadd a terminal:
1. Open the Math or Measure dialog behind the Web Editor dialog.

2. Touch the Web Edit icon following the location (Px or Fx). The summary changes to Web Edit, and a
new terminal block appears on the Web Editor peg board.

3. Connect the output pin of the desired process to the input pin of the terminal. You can select
outputs that are already pinned to other blocks.
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Graphing Measurements
Measurements can be viewed in graphical formats to facilitate your analysis:

« Histograms display the distribution of measured values for a given parameter as a bar chart.

« Tracks provide a time-correlated view of a measurement parameter compared to other acquired
channels or calculated math traces. Acommon usage for track is to observe the modulation of a
signal, such as amplitude, frequency, or pulse width modulation.

« Trends provide a view of a measurement parameter over an extended period of time and over
multiple acquisitions.

Action buttons at the bottom of the the Parameter (Px) dialogs let you quickly draw these plots for the
respective measurement.

Actions for P4

dbe | = |

Histogram Trend

Although these graphs plot measurement values, they are generated on the display as math functions (Fx)
and can be set up through either the Measure or Math dialogs.

Histogramming

Histograms graphically divide data points into intervals, or bins. These bins are plotted on a bar chart such
that the bar height relates to the number of data points within each bin.

Histograms are usually created to visualize the distribution of waveform parameter
WIEZLDYM  values over one or more acquisitions. The Phistogram function creates a histogram of
SMEEN]  values falling within a vertical or horizontal 'slice" of a persistence map. Whatever the
BELSE  source, histograms are always created as a math function. The number of sweeps (k#)
used to calculate the histogram is shown on the histogram function descriptor box.

Because the shape of histogram distributions is particularly interesting, additional histogram
measurements (found in the Statistics sub-menu of the Measure Selector) are available for analyzing
these distributions. They are generally centered on one of several peak value bins.

Thumbnail versions of parameter histograms are called Histicons. They are available as a checkbox option
on the Measure dialog. Histicons appear on the Measure table, rather than as a new math trace.
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Plot Histogram

Conventional histograms are statistical tools that graph the occurrence of measured events in waveform
parameters such as amplitude, frequency, or pulse width. The histogram bar charts are divided into
intervals, or bins, where each bin contains a class of similar parameter values.

For a histogram of... Use...

Different interval widths presentin a long data stream Histogram of Horizontal Parameter Period@level
Cumulative jitter on a long record of a clock signal Histogram of Jitter Parameter TIE@level
Cycle-to-cycle jitter Histogram of Horizontal Parameter Dperiod@level

To plot a histogram of a measurement:

1.

Open the parameter setup (Px) dialog for the measurement you wish to histogram. A quick way to
do this is to touch the Measure table cell.

Touch the Histogram action button at the bottom of the Px dialog and choose the function (Fx) in
which to draw the histogram.

Touch the new hist descriptor box to display the Fx dialog, then open the Histogram subdialog.

Zoom Histogram

#V

1000 50.0 0mv

. EI Find Center Wi
1000 and Width 50.0 mV
0

Clear i )
Sweeps Linear

Enter the maximum #Values in one bin of the histogram. This determines the number of samples
that are represented by the bar at full height.

Touch #Bins and enter the number of bins that comprise the histogram. This determines how
many bars appear in the histogram.

To let the software determine the range of values represented by each bin/bar, check Enable Auto
Find, then touch the Find Center and Width button. To set your own range, enter Center and Width
values.

Choose a Vertical Scale method:

« Linear allows the histogram to build vertically as data accumulates. When the histogram
reaches the top of the display, it rescales the vertical axis to keep it on screen

« LinConstMax keeps the histogram at near full scale and rescales the vertical axis as data is
accumulated.
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Optimizing Histograms

Histograms are dynamically computed using the last N events in the parameter buffer (# Values), up to 2
billion. If the number of bins or values is modified, the histogram is redrawn using the last N events
required. If the source of the histogrammed parameter is a memory, storing new data to memory
effectively acts as an acquisition trigger/sweep and updates the parameter buffer and the histogram.

When the ideal range required to form a good distribution is not apparent, the instrument's range finding
function can be used to calculate an optimal range and redraw the histogram using it. The instrument
gives a running count of where values fall relative to the range, and if any fall above or below it, the range
finder can recalculate the histogram using those values while still in the buffer.

Determining peak value bins, or histogram peaks, is very useful because they indicate dominant values of
a signal. However, signal noise and the use of a high number of bins relative to the number of parameter
values acquired can yield a spiky histogram, making meaningful peaks hard to distinguish. An optimal bin
number is one where the change in bin value is insignificant, and the histogram distribution does not have
a jagged appearance. The instrument analyzes histogram data to identify peaks from background noise
and histogram definition artifacts such as small gaps, which are due to very narrow bins.

Histogram bins represent a sub-range of waveform parameter values, or events. The events represented
by a bin may have a value anywhere within its sub-range. However, measurements of the histogram itself
assume that all eventsin a bin have a single value. The instrument uses the center value of each bin's sub-
range in all its histogram measurements. The greater the number of bins used to subdivide a histogram’s
range, the less the potential deviation between actual event values and those values assumed in
histogram measurements. Nevertheless, using more bins may require a greater number of waveform
parameter measurements (from a greater number of sweeps) to populate the bins sufficiently for the
identification of a characteristic histogram distribution.

As with all measurements, the events used to calculate histograms correspond to the portion of the
waveform visible on the display, or bounded by the measure gates (the default gates are at the 0 and 10
div positions, enclosing the entire grid, or one full sweep).

In Sequence sampling mode, an acquisition for each segment occurs prior to parameter calculations, and
a sweep is equivalent to acquisitions for all segments. If a single segment is selected for viewing, the
histogram will be recalculated for only the displayed/gated events in that segment.

For non-segmented waveforms, an acquisition is identical to a sweep. Measurements that yield only one
value per acquisition (Amplitude, Area, Base, Cycles, Delay, Delta Delay, Dtime@level, Duration, First, Last,
Maximum, Mean, Median, Minimum, Nb Phase, Nb Power, Overshoot+, Overshoot-, Peak-Peak, Phase,
Points, RMS, Std Dev., etc.) may not produce the best histograms unless you allow sweeps to accumulate
over many acquisitions.
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Track and Trend

Both Track and Trend are tools that can be used to plot measurement data and observe variations with
respect to time. The table below summarizes their differences.

Track Trend

Represents Parameter value vs. time Parameter value vs. event

Cumulative Non-cumulative (resets after every acquis- | Cumulative over several acquisitions up
ition), unlimited number of events to one million events

Time correlates to other data | Yes No

Monitors Frequency domain Yes No, points are not evenly spaced in time

and therefore cannot be used for an FFT

Monitors parameters over No, resets after every acquisition Yes
multiple acquisitions

Preserves all measurement Yes (although maximum time period that No, data can be missed during time oscil-
data can be captured is limited by acquisition loscope takes to re-arm between acquis-
memory and sampling rate) itions

Plot Track

A Track is a plot composed of parameter measurements that is time synchronous with the source
waveform. The vertical units are those of the source parameter and the horizontal units are seconds. In
order to maintain time synchronism, the parameter values are posted at the sampling rate.

In general, Track is the tool to use if you want to capture a continuous stream of data spaced closely
together. Track values are redundant in that the same value is repeated every sample period until the
measurement changes.

1. Open the parameter setup (Px) dialog for the measurement you wish to track. A quick way to do
thisis to touch the Measure table cell.

2. Touchthe Tracktoolbar button at the bottom of the Px dialog and choose the function (F1-Fx) in
which to draw the plot. The track opens in a new grid along with its function descriptor box.

3. Touchthe new Track descriptor box to display the Fx dialog, then open the Track subdialog.

ck” function, giving :
waveform of equivalent Interpolate
h le to the

50U eform, but of a v
m urement on that A
waveform.

Find
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4. Onthe Track subdialog, use Find Scale to automatically find suitable values, or uncheck Auto Find

Scale and enter a custom Center and Height/div.

5. Choose a line Connect function of either Interpolate or Extend.

Plot Trend

A Trend is a plot composed of a series of parameter measurements in the order the measurements were
taken. The vertical units are those of the source parameter, the horizontal unit is measurement number.
The Trend contains a single value for each measurement. Think of Trend as a strip chart recorder for your
instrument.

Trends are especially useful for visualizing the history of a parameter over an extended period of time or
over multiple acquisitions. Trend can be used if your data is spaced widely apart and longer than the dead-
time between acquisitions.

1.

Open the parameter setup (Px) dialog for the measurement you wish to histogram. A quick way to
do thisis to touch the Measure table cell.

Touch the Trend button at the bottom of the Px dialog and choose the function (Fx) in which to
draw the plot. The Trend opensin a new grid along with its function descriptor box.

Touch the new Trend descriptor box to display the Fx dialog, then open the Trend subdialog.

Zoom Trend

Forms a list of measurement
values
Mode
Avera

1000

Choose a computation Mode of All (plots multiple points per acquisition) or Average (plots one point
per acquisition). Enter the number of measured Values to Trend.

Torescale the Trend, use Find Scale to automatically find suitable values, or uncheck Auto Find
Scale and enter custom Center and Height/div values.
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List of Standard Measurements
The measurements included standard with your instrument are listed below alphabetically.

Note: Additional measurements may be available depending on the software options installed.

Measurement Description

Measures the difference between upper and lower levels in two-level signals. Differs from pkpk
Amplitude in that noise, overshoot, undershoot, and ringing do not affect the measurement. Amplitude is
(ampl) calculated by using the formula Top — Base. On signals not having two major levels (such as tri-
angle or saw-tooth waves), the amplitude parameter returns the same value as peak-to-peak.
Area Integral of data. Computes area of the waveform relative to zero level. Values > zero contribute
positively to the area; values < zero, negatively.
Lower of two most probable states (higher is top). Measures lower level in two-level signals. Dif-
B fers from min in that noise, overshoot, undershoot, and ringing do not affect measurement. On
ase ; : i . )
signals not having two major levels (such as triangle or saw-tooth waves), the amplitude para-
meter returns the same value as minimum.
Bit Rate Bit rate of serial data stream.
Cycles Determines number of cycles of a periodic waveform lying between cursors. First cycle begins
(cycles) at first transition after the left cursor. Transition may be positive- or negative-going.
Time from trigger to transition: Measures time between trigger and first 50% crossing of spe-
Delay cifies signal. Delay can be used to measure the propagation delay between two signals by trig-
gering on one and determining delay of other.
Delta Delay Computes time between 50% level of two sources.
(ddelay)
Dperiod@level Adjacent cycle deviation (cycle-to-cycle jitter) of the period measurement for each cycle in a
(dper@lv) waveform. The reference level for this measurement can be specified.
Dtime@level Computes the time between transitions of the selected sources at the specified levels. Only pos-
(dt@lv) itive going transitions are counted.
Dtrig Time Time from last trigger to this trigger
(dtrig)
For single sweep waveforms, dur is 0; for sequence waveforms: time from first to last segment's
Duration trigger; for single segments of sequence waveforms: time from previous segment's to current
(dur) segment's trigger; for waveforms produced by a history function: time from first to last accu-
mulated waveform's trigger.
Duty Cycle Percent of period for which data are above or below the 50% level of the signal.
Duty@level Percent of period for which data are above or below a specified level.
(duty@lv)
Dwidth@level Difference (delta) between adjacent widths above or below a specified level.
Edge@level Number of positive edges in waveform that cross the specified threshold level.
(edge@lv)
Edge to Edge Delta time between some edge on the first source to some (other) edge on a second source.
Duration of pulse waveform's falling transition from 80% to 20% of the amplitude averaged for
Fall 80-20% all falling transitions between the measurement gates. On signals not having two major levels
(fall8020) (triangle or saw-tooth waves, for example), top and base can default to maximum and minimum,
giving less predictable results.
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Measurement Description

Duration of pulse waveform's falling transition from 90% to 10% of the amplitude averaged for

Fall time all falling transitions between the measurement gates. On signals not having two major levels
(fall) (triangle or saw-tooth waves, for example), top and base can default to maximum and minimum,
giving less predictable results.
Fall atlevel: Duration of pulse waveform's falling edges between user-specified transition
levels.
Thresh. |Remate | Lower | Upper | Default
Fall@level Limit | Ot
fa”@leve Lower | Low | 1% | 45% | 10%
(fall@lv) Upper | Hgh | 55% | 00% | 0%
Threshold arguments specify two vertical values on each edge used to compute fall time:
lower = lower thresh. x amp/100 + base
upper = upper thresh. x amp/100 + base
First Indicates value of horizontal axis at left cursor.
F Period of cyclic signal measured as time between every other pair of 50% crossings. Starting
requency ) o . . .
f with first transition after left measurement gate. The period is measured for each transition pair.
(freq) . . )
The reciprocal of each period measurement is calculated as the frequency.
Freq@level Period of cyclic signal measured as time between every other pair at the specified level. Start-
ing with first transition after left measurement gate. The period is measured for each transition
(freq@lv) . X . ;
pair. The reciprocal of each period measurementis calculated as the frequency.
FWHM Measures the width of the largest area histogram peak at half of the populationof the highest
peak.
FWxx Measures the width of the largest area histogram peak at xx% of the population of the highest
peak.
Half Period Half period of a waveform.
(hper)
Hist ampl Difference in value between the two most populated peaks in a histogram.
(hampl)
Hist base Value of the left-most of the two most populated histogram peaks.
Hist max pop Peak with maximum population in a histogram.

Hist maximum

Value of the highest (right-most) populated bin in a histogram.

Hist mean

Average or mean value of data in a histogram.

Hist median

Value of the X' axis of a histogram that divides the population into two equal halves.

Hist minimum

Value of the lowest (left-most) populated bin in a histogram.

Hist mode Position of the highest histogram peak.

Hist pop@x Population at bin for specified horizontal coordinate.

Histrange Calculates range (max-min) of a histogram.

Hist rms Root mean square of the values in a histogram.

Hist sdev Standard deviation of values in a histogram.

Hist top Value of the right-most of the two most populated histogram peaks.
Hist X@peak Value of the nth highest histogram peak. You supply the value of n.
Hold Time Time from the clock edge to the data edge.

Last Time from trigger to last (rightmost) cursor.
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Measurement Description

Level@X
(IvVi@x)

Gives the vertical value at the specified x position. If the x position is between two points, it
gives the interpolated value. When the Nearest point checkbox is selected, it gives the vertical
value of the nearest data point.

MATLAB param

Custom MATLAB function that produces a measurement.

Maximum Measures highest pointin waveform. Unlike top, does not assume waveform has two levels.

(max)

Mean Average of data for time domain waveform. Computed as centroid of distribution for a histogram
of the data values.

Median The average of base and top values.

Minimum Measures the lowest pointin a waveform. Unlike base, does not assume waveform has two

(min) levels.

N-cycle Jitter Peak-to-peak jitter between edges spaced n Ul apart.

NBPhase Provides measurement of the narrow band phase at a specific frequency of the waveform.

NBPower Provides measurement of the narrow band power at a specific frequency of the waveform.

None Disables parameter calculation

Num Points Number of points in the waveform between the measurement gates.

(npoints)
Amount of overshoot following a falling edge. This is represented as percentage of amplitude.

Overshoot- Overshoot- is calculated using the formula (base - min.)/ampl x 100. On signals not having two
maijor levels (triangle or saw-tooth waves, for example), may not give predictable results.
Amount of overshoot following a rising edge specified This is represented as a percentage of

Overshoot+ amplitude. Overshoot+ is calculated using the formula (max. - top)/ampl x 100. On signals not

having two major levels (triangle or saw-tooth waves, for example), may not give predictable
results.

Peak to Peak
(pkpk)

Difference between highest and lowest points in waveform. Unlike ampl, does not assume the
waveform has two levels. Peak to peak is calculated using the formula maximum — minimum.

Peaks Number of peaks in a histogram.
Percentile Horizontal data value that divides a histogram so the population to the left is xx% of the total.
(pctl)
The time between every other pair of 50% crossings. Starting with first transition after left meas-
Period urement gate, period is measured for each transition pair, with values averaged to give final res-
ult.
. The time between every other pair of at the level specified. Starting with first transition after left
Period@level . " o ;
measurement gate, period is measured for each transition pair, with values averaged to give
(per@lv)
final result.
Phase Phase difference between signal analyzed and signal used as reference. Both signals are

measured from the 50% point of their rising edges.

Rise 20-80%

Duration of pulse waveform's rising transition from 20% to 80% of the amplitude averaged for
all rising transitions between the measurement gates. On signals not having two major levels

(rise2080) (triangle or saw-tooth waves, for example), top and base can default to maximum and minimum,
giving less predictable results.
Duration of pulse waveform's rising transition from 10% to 90% of the amplitude averaged for
Rise Time all rising transitions between the measurement gates. On signals not having two major levels

(triangle or saw-tooth waves, for example), top and base can default to maximum and minimum,
giving less predictable results.
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Measurement Description

Duration of pulse waveform's rising edges between user-defined transition levels. Threshold
Rise@level arguments specify two vertical values on each edge used to compute rise time:
(rise@lv) lower = lower thresh. x amp/100 + base
upper = upper thresh. x amp/100 + base
Root Mean Square of data (between gates) calculated using the formula:
RMS
Where: vi denotes measured sample values, and N = number of data points within the periods
found up to maximum of 100 periods.
Setup Time from the data edge to the clock edge.
Time of Clock2 edge (nearest to Clock1) minus time of Clock1 edge. "Clock" refers to specified
Skew . )
edge and level of any two sources, data signals included.
Slew Rate Slew rate or local dV/dtin a transition zone
(slew)
Standard deviation of the data between the measure gates using the formula:
1 - 2
Std Dev T2 (Vi - mean )
(sdev) f=1
Where: vi denotes measured sample values, and N = number of data points within the periods
found up to maximum of 100 periods. This is equivalent to the rms for a zero-mean waveform.
Also referred to as AC RMS
Difference between the measured times of crossing a given slope and level and the ideal
expected time. For Slope you can choose positive, negative, or both. For output units you can
TIE@level choose time or unitinterval (Ul). A unitinterval equals one clock period. The Virtual Clock setup
(tie@lv) gives you a choice of Standard (1.544 MHz) or Custom reference clocks. You can also use a
mathematically derived Golden PLL to filter low frequency jitter. The cutoff frequency is user
selectable.
Time@level Time from trigger (t=0) to crossing at a specified level.
(time@Iv)
Higher of two most probable states (base is lower). Measures higher level in two-level signals.
To Differs from max in that noise, overshoot, undershoot, and ringing do not affect measurement.
P On signals not having two major levels (such as triangle or saw-tooth waves), the amplitude
parameter returns the same value as minimum.
Total Pop Total population of a histogram.
(totp)
Width of cyclic signal determined by examining 50% crossings in data input. If first transition
after left cursor is a rising edge, waveform is considered to consist of positive pulses and width
Width the time between adjacentrising and falling edges. Conversely, if falling edge, pulses are con-
sidered negative and width the time between adjacent falling and rising edges. For both cases,
widths of all waveform pulses are averaged for the final result.
Width@level Width measured at a user-specified level.
(wid@lv)
WidthN Time of cyclic signal determined by examining 50% crossings in data input. The widthN is
(widn) measured from falling edge to rising edge.
X@max Determines the horizontal axis location of the maximum value between the measure gate.
X@min Determines the horizontal axis location of the minimum value between the measure gate.
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Calculating Measurements
The instrument uses the following methods to calculate measurements.

Determining Top and Base Lines

Proper determination of the top and base reference lines is fundamental for ensuring correct parameter
calculations. The analysis begins by computing a histogram of the waveform data over the time interval
spanned by the left and right measurement gates. For example, the histogram of a waveform transitioning
in two states will contain two peaks (see figure). The analysis will attempt to identify the two clusters that
contain the largest data density. Then the most probable state (centroids) associated with these two
clusters will be computed to determine the top and base reference levels: the top line corresponds to the
top and the base line to the bottom centroid.

! !
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Determining Rise and Fall Times

Once top and base are estimated, rise and fall times are calculated. The appropriate threshold levels are
automatically determined by the instrument, using the amplitude (ampl) parameter.

Threshold levels for rise or fall time can also be selected using absolute or relative settings ( if @level
measurements are included with your model). When absolute settings are chosen, the rise or fall time is
measured as the time interval separating the two crossing points on a rising or falling edge. When relative
settings are chosen, the vertical interval spanned between the base and top lines is subdivided into a
percentile scale (base =0 %, top = 100 %) to determine the vertical position of the crossing points. The
time interval separating the points on the rising or falling edges is then estimated to yield the rise or fall
time. These results are averaged over the number of transition edges that occur within the observation
window.
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Rising Edge Duration

1 ¥ w1

-Hrz (Iry -TIr; )
i=1

Falling Edge Duration
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EZ(E -If)
il

X
Where Mris the number of rising edges found, Mf the number of falling edges found, Ir; the time when

X
rising edge / crosses the x% level, and T the time when falling edge i crosses the x% level.

Determining Time Parameters

Time parameter measurements such as width, period and delay are carried out with respect to the mesial
reference level, located halfway (50%) between the top and base reference lines or with respect to the
specified level for @level parameters.

Time-parameter estimation depends on the number of cycles included within the observation window. If
the number of cyclesis not an integer, parameter measurements such as rms or mean will be biased.
However, only the last value is actually displayed, the mean being available when statistics are enabled. To
avoid these bias effects, cyclic parameters can be chosen, including crms and cmean, that restrict the
calculation to an integer number of cycles.
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Determining Differential Time Measurements

The instrument enables accurate differential time measurements between two traces: for example,
propagation, setup and hold delays.

Parameters such as Skew require the transition polarity of the clock and data signals to be specified. A
hysteresis range may be specified to ignore any spurious transition that does not exceed the boundaries of
the hysteresis interval. In the figure below, Skew measures the time interval separating the falling edge of
Source from the rising edge of Source2.

Noisy spikes ignored due |
to Hysteresis band :
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Source 1 Clock = Negative Transition "{_
Source 2 Clock = Positive Transition _f~
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Math

Math traces (Fx) display the result of applying a mathematical operation to a source trace. The output of a
math function is always another trace, whereas the output of a measurement parameter is a tabular
readout of the measurement.

Math can be applied to any channel (Cx), zoom (Zx), or memory (Mx) trace. It can even be applied to
another math trace, allowing you to chain operations (for example, trace F1 can show the average of C1,
while trace F2 provides the integral of F1). Functions such as Trend can be applied to measurement
parameters (Px) to plot the history of the measurement.

In addition to the extensive math capabilities that are standard with every instrument, enhanced math
analysis tools customized for various industries and applications are offered through optional software
packages. To learn about math tools available in each optional package, see the product datasheets at
teledynelecroy.com.

If you have installed software options, the new capabilities are usually accessed through the Analysis
menu, rather than the Math menu, although special measure parameters and math functions will be
available when using Measure and Math dialogs.

Math Function Set Up

Use the Function dialog to set up math function traces. Math functions take as input one or more channel|,
zoom, memory or math traces and output a new function trace (Fx). Any additional settings required for
the operator will appear on a subdialog at the right of the screen.

Single functions perform one operation on one or two input sources.

Dual functions chain two operations to arrive at a single result. This saves you the effort of having to chain
two separate math functions. As with single functions, the number of sources required will vary based on
the operation. You may need only one source for Operator1, but two for Operator?2 (the result of the first
operation counts as one source).

Setting Up New Functions
1. From the menu bar choose Math > Math Setup, or press the front panel Math button.
2. Choose a location by touching one of the Fx tabs.

If you know which function location you'll be using, you can select Fx Setup right from the Math
menu.

Operatort
il FeT

1) [LiE]

3. Choose a single f(x) or dual g(f(x) operator function.
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You can also choose Web Edit, in which case this function is added as a terminal to the processing
web. See the instructions for Using Wed Edit to set up the function.

4. InOperator1, choose the math operation to perform.

Note: On instruments with the Advanced Customization (XDEV) option, the Operator can be
a custom script written in one of several scripting "languages." Choose from the Custom
submenu and import or write the script in the Script Editor. See Using PScript for a
description of the process.

5. The choice of operator drives the number of Source fields you will see displayed. Make a selection
in each field, or drag the source channel descriptor box to the field.

A Summary of the function you are building appears on the dialog. Refer to this to be sure your
sources are in the proper order to yield the function you want (e.g., C1-C2 vs. C2-C1).

6. If the operator you've selected has any other configurable settings, you'll see a subdialog of the
same name as the operator. Touch the tab to open the dialog and make any further settings. These
are explained on the dialog.

7. If you're creating a dual function, repeat the procedure for the second operator.

Graphing

The Graph button on the Function (Fx) dialogs allows you to simultaneously apply a measurement
parameter to the function trace and plot the results using histogram, track, or trend. See Histogramming
and Track and Trend.

0 Tip: The plots are the same as those created using the toolbar on the Parameter (Px) dialog.
As with other math functions, configurable settings will appear on subdialogs after the plot is selected.

Adjusting Memory or Math Traces

Unlike channel traces, the scale of memory (Mx) or math function (Fx) traces can be adjusted directly
without having to create a separate zoom trace. The same set of zoom factor controls used for zoom
traces appear on the Zoom subdialog, but in this context they only rescale the active math or memory
trace rather than create a new zoom. This applies to any trace that is created as a math function (Fx)
trace, including traces generated through analysis options and graphs.

You can, if you wish, create a separate zoom trace from a memory or function trace the same as you
would normally create a zoom (draw a selection box, Add New Zoom, etc.). In this case, you choose one of
the zoom locations (Zx) in which to draw the trace, but the source trace remains at the original scale.
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Math Dialog

Once a math function has been created and saved on the Function (Fx) dialog, use the main Math dialog
to quickly enable/disable it. You can also use this dialog to quickly turn on/off zoom traces.

zoom({C1)

either the button or the
finiti
I

zoom(C2)
zoom(C3)

zoom(C4) On zoom(C4)

To open the Math dialogs, touch the front panel Math button, or from the menu bar choose Math > Math
Setup. Select the On checkbox next to each function you wish to display.

To modify a function, touch the Fx button.
To erase all functions from their locations, touch Reset All.

To restart the counter on cumulative functions (like Average), touch Clear Sweeps.
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Average Function

Setting Up Averaging
To apply Continuous or Summed Averaging as a Math function:

1. Follow the usual steps to set up a math fuction, selecting Average from the Basic Math submenu.

2. Onthe Average subdialog, choose Summed or Continuous.

3. Touch Sweeps and provide a value. The valid range is 1 to 1,000,000 sweeps.

Tip: To quickly set up Continuous Averaging (only), access the channel setup dialog (Cx) and enter
the number of sweeps to average in Averaging. The valid range is 1to 1,000,000 sweeps.

Summed Averaging

Summed Averaging is the repeated addition, with equal weight, of successive source waveform records. If
a stable trigger is available, the resulting average has a random noise component lower than that of a
single-shot record. Whenever the maximum number of sweeps is reached, the averaging process stops. In
Summed averaging, you specify the number of acquisitions to be averaged. The averaged data is updated
atregularintervals.

An even larger number of records can be accumulated simply by changing the number in the dialog.
However, the other parameters must be left unchanged or a new averaging calculation will be started. You
can pause the averaging by changing the trigger mode from NORMAL/AUTO to STOP. The instrument
resumes averaging when you change the trigger mode back to NORMAL/AUTO.

You canreset the accumulated average by pushing the CLEAR SWEEPS button or by changing an
acquisition parameter such as input gain, offset, coupling, trigger condition, timebase, or bandwidth limit.
The number of current averaged waveforms of the function, or its zoom, is shown in the acquisition status
dialog. When summed averaging is performed, the display is updated at a reduced rate to increase the
averaging speed (points and events per second).

Continuous Averaging

Continuous Averaging, the default setting, is the repeated addition, with unequal weight, of successive
source waveforms. It is particularly useful for reducing noise on signals that drift very slowly in time or
amplitude. The most recently acquired waveform has more weight than all the previously acquired ones:
the continuous average is dominated by the statistical fluctuations of the most recently acquired
waveform. The weight of ‘old' waveforms in the continuous average tends to zero (following an
exponential rule) at a rate that decreases as the weight increases.

You determine the importance of new data vs. old data by assigning a weighting factor. Continuous
averaging allows you to make adjustments to a system under test and to see the results immediately. The
formula for both summed and continuous averaging is:

new average = (new data + weight * old average)/(weight + 1)
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However, by setting a Sweeps value, you establish a fixed weight that is assigned to the old average once
the number of sweeps is reached. For example, for a sweeps (weight) value of 4:

Sweep New Average =

1 (no old average yet) | (new data +0 * old average)/(0 + 1) = new data only

new data + 1*old average)/(1 + 1) = 1/2 new data +1/2 old average

new data + 2 * old average)/(2 + 1) = 1/3 new data + 2/3 old average

new data + 4 * old average)/(4 + 1) = 1/5 new data + 4/5 old average

new data + 4 * old average)/(4 + 1) = 1/5 new data + 4/5 old average

(
2 (
3 (
4 (new data + 3 * old average)/(3 + 1) = 1/4 new data + 3/4 old average
5 (
6 (
7 (

new data + 4 * old average)/(4 + 1) = 1/5 new data + 4/5 old average

In this way, for sweeps > 4 the importance of the old average begins to decrease exponentially.

Note: The number of sweeps used to compute the average is displayed at the bottom of the trace
descriptor box.

Copy Function

The Copy math function saves a copy of your present waveform in its unprocessed state to the first
available memory location. While processing may continue on the original waveform, the copy enables
faster throughput in some cases by preserving the original data. No calculations need to be undone on the
copy before additional math can be calculated. This benefit of faster throughput, however, comes at the
expense of memory usage.

Follow the ususal steps to set up a math function, selecting Copy from the Misc submenu.

On the Wform Copy subdialog, optionally Reset Count or Change BatchSize.
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ERes Function

ERes (Enhanced Resolution) filtering increases vertical resolution, allowing you to distinguish closely
spaced voltage levels. The instrument's ERes function is similar to smoothing the signal with a simple,
moving-average filter. However, it is more efficient concerning bandwidth and pass-band filtering.

Use ERes:

« On single-shot acquisitions, or where the data record is slowly repetitive (cases where you cannot use
averaging).

« Toreduce noise on noticeably noisy signals when you do not need to perform noise measurements.
« When performing high-precision voltage measurements (e.g., zooming with high vertical gain).
Setting Up ERes
To apply ERes as a Math function:

1. Follow the usual steps to set up a math function, selecting Eres from the Filter submenu.

2. Touch the Trace On checkbox.

3. Onthe Eres subdialog, then touch bits and make a selection from the pop-up menu.

Tip: To quickly set up ERes as a pre-processing function, access the channel setup dialog (Cx) and
select a Noise Filter (ERes) bit size.

How the Instrument Enhances Resolution

The instrument's enhanced resolution feature improves vertical resolution by a fixed amount for each
filter. This real increase in resolution occurs whether or not the signal is noisy, or whether it is single-shot or
repetitive. The signal-to-noise ratio (SNR) improvement depends on the form of the noise in the original
signal. The enhanced resolution filtering decreases the bandwidth of the signal, filtering out some of the
noise.

The instrument's constant phase finite impulse response (FIR) filters provide fast computation, excellent
step response in 0.5 bit steps, and minimum bandwidth reduction for resolution improvements of between
0.5 and 3 bits. Each step corresponds to a bandwidth reduction factor of two, allowing easy control of the
bandwidth resolution trade-off.
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Resolution -3 dB Bandwidth (x | Filter Length

increased by Nyquist) (Samples)
0.5 0.5 2
1.0 0.241 5
1.5 0.121 10
2.0 0.058 24
25 0.029 51
3.0 0.016 117

With low-pass filters, the actual SNR increase obtained in any particular situation depends on the power
spectral density of the noise on the signal.

The improvement in SNR corresponds to the improvement in resolution if the noise in the signal is white
(evenly distributed across the frequency spectrum). If the noise power is biased towards high frequencies,
the SNR improvement will be better than the resolution improvement.

The opposite may be true if the noise is mostly at lower frequencies. SNR improvement due to the
removal of coherent noise signals—feed-through of clock signals, for example—is determined by the fall of
the dominant frequency components of the signal in the passband. This is easily ascertained using
spectral analysis. The filters have a precisely constant zero-phase response. This has two benefits. First,
the filters do not distort the relative position of different events in the waveform, even if the events'
frequency content is different. Second, because the waveforms are stored, the delay normally associated
with filtering (between the input and output waveforms) can be exactly compensated during the
computation of the filtered waveform.

The filters have been given exact unity gain at low frequency. ERes should therefore not cause overflow if
the source data is not overflowed. If part of the source trace were to overflow, filtering would be allowed,
but the results in the vicinity of the overflowed data—the filter impulse response length—would be
incorrect. This is because in some circumstances an overflow may be a spike of only one or two samples,
and the energy in this spike may not be enough to significantly affect the results. It would then be
undesirable to disallow the whole trace.

Note: While ERes improves the resolution of a trace, it cannot improve the accuracy or linearity of
the original quantization. The pass-band causes signal attenuation for signals near the cut-off
frequency. The highest frequencies passed may be slightly attenuated. Perform the filtering on
finite record lengths. Data is lost at the start and end of the waveform and the trace ends up
slightly shorter after filtering. The number of samples lost is exactly equal to the length of the
impulse response of the filter used: between 2 and 117 samples. Normally this loss (just 0.2 % of a
50,000 point trace) is not noticed. However, you might filter a record so short that no data is
output. In that case, however, the instrument would not allow you to use the ERes feature.
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Fast Wave Port Function

Fast Wave Port is a function of Teledyne LeCroy X-Stream oscilloscopes that enables you to insert a
custom algorithm written in the C/C++language into the oscilloscope's processing stream. It also
maximizes data throughput from the acquisition system to your custom algorithm for purposes of
debugging. Custom algorithms can be written right on the oscilloscope using the Script Editor.

Thisis possible because two Windows system processes may share a region of memory, enabling high-
speed data transfer between the acquisition system and the custom algorithm, which runs in a separate
process from the oscilloscope application. A major benefit of Fast Wave Port is that your algorithm may be
implemented and, more importantly, debugged independently of the main application.

It isimportant to note that transferring the results of your algorithm back into the X-Stream processing
stream is optional. If performance is the primary goal, and further processing of the results within the X-
Stream software is not required, this step may be skipped.

Fast Wave Port was designed for use with the C/C++ programming language. However, it is theoretically
possible for the processing to be implemented in any language supporting Windows named events
(Mutex) that can open a named memory-mapped file. No guarantee can be given, however, as to the
behavior of the function using anything but C/C++.

The size of the memory window is fixed at 80 MB, equating to 40 ms.
See the Fast Wave Port topic in the oscilloscope Help for an example C++ application.

To use Fast Wave Port, follow the usual steps to set up a math function, selecting Fast Wave Port as the
Operator, then make the appropriate settings on the Fast Wave Port subdialog.

The Port Name is critical, indicating the base name of the memory window and the global objects within
the Windows O/S. Only change the default value if using multiple Fast Wave Port functions in parallel.

Note: The base name must match the base name used in the client application.

The full names of the default global objects are as follows:

Object Full Name

Memory Mapped File FastWavePort1File

Data Available Event FastWavePort1MutexDataAvailable

Processing Complete Event | FastWavePort1MutexProcessingComplete

The Timeout control specifies the amount of time the DSO waits for the custom processing function to
complete. This prevents the DSO from waiting indefinitely for a custom processing function which may
never arrive. Be careful to set this control to a reasonable value, meaning a time longer by a reasonable
margin than the custom processing is ever expected to take.
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FFT Function

For a large class of signals, you can gain greater insight by looking at spectral representation rather than
time description. Signals encountered in the frequency response of amplifiers, oscillator phase noise and
those in mechanical vibration analysis, for example, are easier to observe in the frequency domain.

If sampling is done at a rate fast enough to faithfully approximate the original waveform (usually five times
the highest frequency component in the signal), the resulting discrete data series will uniquely describe
the analog signal. Thisis of particular value when dealing with transient signals, which conventional swept
spectrum analyzers cannot handle.

While FFT has become a popular analysis tool, some care must be taken with it. In most instances,
incorrect positioning of the signal within the display grid will significantly alter the spectrum, producing
effects such as leakage and aliasing that distort the spectrum.

An effective way to reduce these effects is to maximize the acquisition record length. Record length
directly conditions the effective sampling rate and therefore determines the frequency resolution and
span at which spectral analysis can be carried out.

Setting Up FFT

1. Follow the usual steps to set up a math function, selecting FFT from the Frequency Analysis
submenu.

2. Openthe FFT subdialog.
3. Choose an Output type.

4. If your Output Type is Power Density or Power Spectrum, also enter Line Impedence. By default,
the FFT function assumes a termination of 50 Ohms. If an external terminator is being used, this
setting can be changed to properly calculate the FFT based on the new termination value.

If your Output type is Phase, enter a Group Delay Shift value.
5. Optionally, choose a weighting Window (see below).

6. Checkthe Suppress DC box to make the DC bin go to zero. Otherwise, leave it unchecked.

Choosing a Window

The choice of a spectral window is dictated by the signal's characteristics. Weighting functions control the
filter response shape, and affect noise bandwidth as well as side lobe levels. Ideally, the main lobe should
be as narrow and flat as possible to effectively discriminate all spectral components, while all side lobes
should be infinitely attenuated. The window type defines the bandwidth and shape of the equivalent filter
to be used in the FFT processing.

Rectangular windows provide the highest frequency resolution and are useful for estimating the type of
harmonics present in the signal. Because the rectangular window decays as a (sinx)/x function in the
spectral domain, slight attenuation will be induced. Functions with less attenuation (Flat Top and
Blackman-Harris) provide maximum amplitude at the expense of frequency resolution, whereas Hamming
and Von Hann are good for general purpose use with continuous waveforms.
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Window Type Applications and Limitations

Rectangular

Normally used when the signal is transient (completely contained in the time-domain window)
or known to have a fundamental frequency component that is an integer multiple of the fun-
damental frequency of the window. Signals other than these types will show varying amounts of
spectral leakage and scallop loss, which can be corrected by selecting another type of window.

Hanning (Von Hann)

Reduces leakage and improves amplitude accuracy. However, frequency resolution is also
reduced.

Hamming Reduces leakage and improves amplitude accuracy. However, frequency resolution is also
reduced.
Flat Top Provides excellent amplitude accuracy with moderate reduction of leakage, but with reduced

frequency resolution.

Blackman-Harris

Reduces leakage to a minimum, but with reduced frequency resolution.

FFT Window Filter Parameters

Window Type

Highest Side Lobe
(C12)

Scallop Loss (dB) m Coherent Gain (dB)

Rectangular -13 3.92 1.0 0.0

Von Hann -32 142 15 -6.02
Hamming -43 1.78 1.37 -5.35
Flat Top -44 0.01 3.43 -11.05
Blackman-Harris -67 1.13 1.71 -7.53
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Interpolate Function

Linear interpolation, which inserts a straight line between sample points, is best used to reconstruct
straight-edged signals such as square waves. This is the default interpolation method used by the
oscilloscope.

(Sinx)/x interpolation, on the other hand, is suitable for reconstructing curved or irregular waveshapes,
especially when the sampling rate is 3 to 5 times the system bandwidth.

Cubic interpolation can be used to create a smooth, continuous function by applying a third-degree
polynomial.

For each method, you can select an upsample factor of 2 to 50 points to insert between samples.

1. Follow the usual steps to set up a math function, selecting Interpolate from the Filter submenu.

2. Touch Algorithm and select an interpolation type.
3. Enter the Upsample factor by which to increase sampling.

You can use the Up and Down buttons to set this value. To make fine increment changes, deselect
the "only by 2, 5..." checkbox.

4. InHalf Width enter the width in taps of the filter.

5. Touse a weighting function rather than an upsample factor, select it from Weighting. See FFT for
more information about the functions. If using the Kaiser function, also enter the Beta value.

Sparse Function

The Sparse math function allows you to thin out an incoming waveform by skipping points at regular
intervals, and by starting acquisition at a particular offset (point). The Sparsing factor specifies the
number of sample points to reduce the input waveform by. A sparsing factor of 4, for example, says to
retain only one out of every 4 samples. A Sparsing offset of 3, on the other hand, says to begin on the third
sample, then skip the number of samples specified by the sparsing factor (4). In this way, the sample rate
is effectively reduced.

For the sparsing factor (interval), you can set a value from 1to 1,000,000 points. For the sparsing offset
you can set a value from 0 to 999,999.

1. Follow the usual stepsto set up a math function, selecting Sparse from the Misc submenu.

2. Touch the Sparsing factor control and provide a Bandwidth Limit value.

3. Touch the Sparsing offset control and provide a value.
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Rescale Function and Assigning Units

The Rescale function allows you to apply a multiplication factor (a) and additive constant (b) to any source
waveform. You can do it in the unit of your choice, depending on the type of application.

Tip: Analog channel traces may be rescaled directly using the Cx dialogs. They do not require a
separate Math function.

Setting Up Rescaling

1. Follow the usual steps to set up a math function, selecting Rescale from the Functions submenu.

2. Touchthe Rescale subdialog tab.
3. Toapply a multiplication factor:
« Checkthe First multiply by: box and enter a value for a, the multiplication factor.
« Touch then add: and enter a value for b, the additive constant.
4. Tochange the output unit of measure from that of the source waveform:
« CheckOverride units.
« InOutput enter the abbreviation for the new unit of measure.
You can combine units following these rules:
« Forthe quotient of two units, use the character ":/"

« Forthe product of two units, use the character".

« Forexponents, append the digit to the unit without a space (e.qg., "S2" for seconds squared)

Note: Some units are converted to simple units (e.g., V.A becomes W).
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Abbreviated Units of Measure

Abbreviation Measure Abbreviation Measure
(blank) No units N Newton

A Ampere OHM Ohm

Cc Coulomb PAL Pascal

CYCLE Cycles PCT Percent

DB Decibel POISE Poise

DBC Decibel referred to carrier PPM Parts per million
DBM Decibel Milliwatt RAD Radian

DBV Decibel Volts DEG Degree (of arc)
DBUZ Decibel Microamp MNT Minute (of arc)
DEC Decade SAMPLE Sample

DIV Divisions SWEEP Sweeps

Event Events SEC Second (of arc)
F Farad S Second

G Gram SIE Siemens

H Henry T Tesla

HZ Hertz ul Unitinterval

J Joule \Y Volt

K Degree Kelvin VA Voltamps

CEL Degree Celsius w Watt

FAR Degree Fahrenheit WB Weber

L Liter MIN Min

M Meter HOUR Hour

FT Foot DAY Day

IN Inch WEEK Week

YARD Yard

MILE Mile
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Phistogram Function

The Phistogram function creates a histogram of the samples within a vertical or horizontal "slice” of a
persistence map to reveal the features that are only visible when several acquisitions have been
superimposed on one another. Vertically, each bin contains a class of similar amplitude levels; horizontally,
each bin contains a class of similar time values.

The source trace must have Persistence "on" to generate the persistence map. Eye diagrams, which are a
type of persistence map, are a an especially useful class of traces to which you can apply the Phistogram
function.

For a histogram of... Use...

A crossover pointin time or amplitude on an eye diagram * | Vertical and horizontal slice persistence histogram

Cumulative jitter on an eye diagram * Horizontal slice persistence histogram

Signal-to-noise ratio on an eye diagram * Vertical slice persistence histogram

* Requires optional software package capable of creating eye diagrams, such as SDA Il orSerial Decoder TDME software.

1. Follow the usual steps to set up a math function, choosing a Single operator function using the
Phistogram operator.

2. Onthe Phistogram subdialog, choose the slice of the persistence map to histogram:

« Slice Direction of determines whether the slice transverses the entire height of the map
centered around a time (vertical), or transverses a period of time in the map centered around
a level (horizontal).

« Slice Centerrepresents the center time or level of the slice.

« Slice Width represents the total time or amplitude of the slice, half each side of the center.

Note: This operation does not affect, and is not affected by, Center and Width settings
made on any existing histograms.

3. Choose Center Cursor to place a measurement cursor at the center of the slice.
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Ptrace Functions

The Ptrace Mean, Ptrace Range, and Ptrace Sigma math functions (found in the Jitter Functions sub-
menu of the Math Operator selector) compute a vector trace based on a persistence map of underlying
signal acquisitions without destroying the underlying data, allowing the display of analytical results from
raw data. Further measurements or Pass/Fail testing can be performed on the resulting function traces.

The function source trace must have Persistence "on" to generate the persistence map.

Function

Ptrace Mean

Options

Methodology

For each vertical time slice on the
persistence map, Ptrace Mean cal-
culates and plots a trace cor-
responding to the map’s mean
value. Single-shot signals
sampled at or above 2 GS/s and
accumulated in the persistence
map can be traced at a resolution
of 10 ps (100 GS/s equivalent
sampling). The persistence trace
average can be further analyzed
using the instrument’s standard
parameters, such as rise time.

Uses

See edge detail in a fast signal
or eliminate noise on a per-
sistence map.

Ptrace Range

% population range. A
percentage of the population of
the persistence map can be
chosen from which the envelope
will be formed, enabling
exclusion of infrequent events
(artifacts).

For each vertical time slice on the
persistence map, Ptrace Range
calculates and plots an envelope
corresponding to the map’s
range. The range can then be
used in further processing: for
example, as a source for
Pass/Fail masks.

Assess typical noise on a per-
sistence map.

Ptrace Sigma

Scale to standard deviations.
This allows you to selecta
sigma from 0.5 to 10.0, which
expands those parts of the
sigma envelope representing
waveform regions. This is useful
for making a tolerance mask.

For each vertical time slice on the
persistence map, Ptrace Sigma
calculates and plots an envelope
corresponding to the map’s stand-
ard deviation. Multiples of sigma
can also be done using sigma.
The sigma can be used in further
processing; for example, as a
source for Pass/Fail masks.

Assess worst case noise on a
persistence map and use itto
create a tolerance mask for
Pass/Fail testing.
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List of Standard Operators
The math operators included standard with your oscilloscope are listed below alphabetically.

Note: There may be additional operators available depending on the software options installed on
the oscilloscope.

Operator Definition

Absolute For every point in the waveform the distance away from zero is calculated. For values greater
than zero this is the same as the value. For values less than zero, the magnitude of this value
without regard to its sign is used.

Average Calculates either a summed or continuous average of a selected number of sweeps. See Aver-
aging Waveforms. The maximum number of sweeps is determined by the oscilloscope model
and memory.

Copy Copies waveform in its unprocessed state to the first available memory location.

Correlation Calculates a measure of similarity of two waveforms, or a waveform against itself, as a function
of a time-lag applied to one of them.

Derivative Calculates the derivative of adjacent samples using the formula:

(next sample value — current sample value) / (horizontal sample interval)

Deskew Shifts trace in time the amount of the deskew factor.

Difference For every point in the waveform, the value of Source2 is subtracted from the value of Source1.
Source1 and Source2 must have the same horizontal units and scale and the same vertical
units.

Envelope Calculates highest and lowest vertical values of a waveform at each horizontal value for a spe-
cified number of sweeps.

ERes Applies a noise reduction and smoothing filter by adding a specified number of bits. See
Enhanced Resolution.

Exp Calculates the antilog to the base e of the source; that is, e raised to the power equal to the
source.

Exp10 Same as Exp, using base 10.

FFT Computes a frequency spectrum with optional Rectangular, Von Hann, Flat Topp, Hamming,
Blackman-Harris, and Hanning windows. Calculates up to 128 Mpts. Also allows FFT Aver-
aging through use of a second math operator. See FFT.

Floor Calculates the lowest vertical values of a waveform at each horizontal value for a specified num-
ber of sweeps.

Histogram Plots the number of data points that fall into statistically significant intervals or bins. Bar height
relates to the frequency at which data points fall into each interval/bin.

Integral Calculates the linearly rescaled integral (with multiplier and adder) of a waveform input starting
from the left edge of the screen using the formula:

(current sample value + next sample value) * (horizontal sample interval)
Each calculated area is summed with the previous sum of areas. The multiplier and adder are
applied before the integration function.

Interpolate Inserts points between sampled points (upsamples) according to one of three algorithms: Lin-
ear (straight line), Sinx/x (curved), and Cubic (spine). Interpolation factor of 2 to 50 determines
number of points in the upsample.

Invert For every pointin the waveform, the inverse of that pointis calculated.
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Operator Definition

Ln

Peforms a natural log of a waveform. Values less than or equal to zero are set to underflow.

Log10

Performs a log base 10 of a waveform. Values less than or equal to zero are set to underflow.

MatLab math

Produces a waveform using a custom MatLab function.

Phistogram Creates a histogram based on the displayed pixels of a persistence map falling within a user-
defined vertical and/or horizontal box (slice). The source trace must have Persistence turned
"On.“

Product For every point in the waveform, the value of Source1 is multiplied by the value of Source 2.

Source1 and Source2 must have the same horizontal units and scale.

Ptrace mean

Plots the mean value of each sample pointin a persistence map. The source trace must have
Persistence turned "on."

Ptrace range

Generates a waveform with a width derived from the population range of a persistence map.
The source trace must have Persistence turned "on."

Ptrace sigma

Generates a waveform with a width derived from the sigma (sum) of a persistence map. The
source trace must have Persistence turned "on."

Ratio For every pointin the waveform, the value of Source1 is divided by the value of Source2.
Source1 and Source2 must have the same horizontal units and scale.

Reciprocal For every point in the waveform the inverse is calculated using the formula:
1/ (sample value)

Rescale For every pointin the waveform the sample value is multiplied by the specified multiplier and
then add to with the specified adder. See Rescaling and Assigning Units,

Roof Calculates the highest vertical values of a waveform at each horizontal value for a specified
number of sweeps.

Segment Selects one segment from a source waveform to place in a sequence waveform. Used in
Sequence sampling mode.

Sinx/x Performs 10-to-1 interpolation using a Sin(x)/x filter.

Sparse “Thins,” or decimates, an incoming acquisition by dropping sample points at regular intervals.
Sparsing factor specifies the number of points to drop between retained samples (e.g., factor of
4 retains 1 then drops 4). Sparsing offset specifies the point at which to begin applying the
sparsing factor (e.g., offset of 3 begins count on the third sample (3), then drops the number of
samples specified by the sparsing factor (4).

Square For every point in the waveform, the square of the sample value is calculated.

Square Root

For every point in the waveform, the square root of the sample value is calculated.

Sum

For every point in the waveform, the value of Source1 is added to the value of Source 2.
Source1 and Source2 must have the same horizontal units and scale and the same vertical
units.

Track

Generates a waveform composed of parameter measurements that is time synchronous with
the source waveform. The vertical units are those of the source parameter value and the hori-
zontal units are seconds. Parameter values are posted at the sampling rate.

Trend

Produces a waveform composed of a series of parameter measurements in the order the meas-
urements were taken. The vertical units are those of the source parameter, the horizontal unitis
measurement number. The trend contains a single value for each measurement.

Zoom

Produces a magnified trace of a selected portion of the input waveform. See Zooming Traces.
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Memory

The instrument is equipped with four internal memory slots (Mx) to which you can copy any waveform
that is active on the grid. Thisis a convenient way to store an acquisition for later viewing and analysis.

Memories can be used as source inputs for most oscilloscope math and measurements, allowing you to
compare historical data to a live acquisition or perform "what if" modeling on saved acquisitions.

Saving Memories

Store memories on the Memory dialogs (Mx). Memories are created at the same scale as the source
trace, but they can be adjusted independently by using the zoom factor controls that appear next to the
Mx dialogs.

Save Waveform to Memory

Tip: Try to choose an empty slot, as anything currently stored in that location will be overwritten.
Allmemories will state if they are empty or an acquisition is stored there.

Touch the Add New box and choose Memory until you see an empty memory slot. Drag the descriptor box
of the trace you wish to store onto the Mx descriptor box.

Or

—_

Press the front panel Mem button or choose Math > Memory Setup to open the Memories dialog.

2. Touch the Mx tab corresponding to the memory slot you wish to use.

e

Next Grid

3. InCopy from Waveform, choose the source trace to copy to memory.
4. Touch Copy Now.

5. Optionally, check Trace On to immediately display the memory. Use the Zoom controls to adjust
the scale of the memory trace.

Save (External) Waveform Files to Memory

Trace (.trc) files saved on other Teledyne LeCroy instruments can also be saved to internal memory. Use
the Recall Waveform function to save external files to memory. Then, you can use the Memories dialog to
restore them to the touch screen.
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Restoring Memories
The Memories dialog is a convenient panel for restoring saved memories to the display.

Access the Memories dialog by pressing the front panel Mem button or choosing Math > Memory Setup.

Check On next to the memory trace you wish to display. A description of the memory showing the source
channel and creation time appears next to each Mx on the dialog.

Touch Clear All Memories to empty the memory banks.

A Caution; Memories cannot be restored once they have been erased.

m Memories

Clear All
Memories
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Analysis Tools

The Analysis menu tools complement the standard math and measurements to help you understand the
behavior of waveforms.

WaveScan searches single or multiple acquisitions for events that meet specific criteria.

Pass/Fail Testing shows whether waveforms or measurements meet a set of defined criteria.

Optional software packages may be purchased for specialized uses, such as power analysis. In most
cases, these options are added to the Analysis menu. Documentation for software options can be found at
teledynelecroy.com/support/techlib under Manuals > Software Options. In addition, documentation for
many options available on your platform can be found in the online Help under the Support menu.

WaveScan

The WaveScan® Search and Find tool enables you to search for unusual events in a single capture, or to
scan for a particular event in many acquisitions over a long period of time. Each Scan Mode is optimized to
find a different type of event. Results are time stamped, tabulated, and can be viewed individually.

Bl File | 3 Vertical ++ Timebase | I Trigger | & Display | # Cu El Measure & Math |2 Analysis X Utilities = @ Support

Runt Ampl.

146 mV/

800mv
400 mv

0 IT'IE';‘

-400mv

-800mY
-103.625 ms -102 s -101.625 ms

71 zoom(C2) [N | Timebase 0 msf Trigger I8 LY
200 mV/div 200 mV/div | 50.0 ms/div Stop 0.0 mV
0.0 mV ofst 500 psidiv | | 125 MS 25 MS/s Edge Positive

WaveScan Runt Setup O cLose

Mode cef Find
. Runt 4

Both 4

Action on

. 1 None

WaveScan window with different scan "views" turned on.

You customize the presentation by choosing different WaveScan displays, called Scan Views. Optionally,
set actions, such as stopping or beeping, to occur automatically when unusual events are found.
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Note: The instrument reverts to Real-time sampling mode when WaveScan is enabled.

Setting Up WaveScan

Set up your source channel and triggers before setting up the scan.

Runt Setup

Mode
Runt

1. Pressthe front panel Stop button to stop acquisition.
Choose Analysis > WaveScan.
Check Enable.

Choose the Source waveform.

o A~ WM

Choose the Scan Mode and enter values for any additional settings that appear at the right of the
dialog based on your selection.

6. Select each Scan View in which you wish to display results by checking the box at the bottom of the
dialog. Each view selected is displayed simultaneously.

7. If you're using Scan Overlay view, on the Scan Overlay dialog Clear Sweeps. If desired, set up the
Persistence display.

8. Optionally, choose an Action to trigger when an event that meets your scan criteria is found.

9. Restart acquisition.

Scan Modes

The Scan Mode determines the type of search to be performed. Select the Mode along with the Source
trace to be searched on the main WaveScan dialog. For each mode, different controls appear on the
WaveScan dialog, providing additional inputs to the search criteria. Make the appropriate entries in these
fields before starting the search.

Edge Mode

Edge Mode is used for detecting the occurrence of edges. Events that meet the threshold level are
captured and tabulated. When the acquisition is stopped, scan filters can be applied to the edges to find
specific characteristics. Edge Mode settings are:

« Slope. Choose Pos, Neg, or Both.
« Levelis (setin...). Choose Percent or Absolute.

« Percent/Absolute Level. Enter a threshold value as a percentage of Top to Base or voltage level.
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Non-monotonic Mode

Non-monotonic Mode looks for edges that cross a threshold more than once between high and low levels.
Allevents that meet the criteria of slope, hysteresis, and level are presented in a table and highlighted in
the source trace. The value displayed in the table is the difference of the max. and min. of the non-
monotonicity. This can be confirmed with cursors. The hysteresis value is used to eliminate noise. A non-
monotonicity is detected only when its amplitude is greater than the hysteresis. Therefore, when setting a
hysteresis level, set a value that is greater than the amplitude of the noise. Settings are:

« Slope. Choose Pos, Neg, or Both.
« Hysteresis is (setin...). Choose Division, Percent, Absolute.

Division/Percent/Absolute. Enter hysteresis level in the selected unit.

Levels are (setin...). Choose Percent, Absolute, or Pk-Pk%.

High/Low Level. Enter top and bottom thresholds in the selected unit.

Runt Mode

Runt Mode looks for pulses that fail to cross a specified threshhold. You can search for positive-going or
negative-going runts, or both. An adjustable hysteresis band is provided to eliminate noise.

In the case of negative-going runt pulses, the value displayed in the table is the difference (delta) of the
high level of the signal and the runt amplitude (i.e., where the runt bottoms out). This can be confirmed by
placing cursors on the runt pulse and reading the delta Y value in the trace labels. In the case of positive-
going runt pulses, the value displayed in the table is the absolute value of the amplitude of the runt pulse.
Runt Mode settings are:

« Runt Type. Choose Both, Pos, or Neg.
« Hysteresis. Enter the hysteresis level as a percentage or voltage.
« Low/High Threshold. Enter the levels as a percentage or voltage.

« Absolute Levels. Check this box to enter levels as absolute voltage instead of percentage.

Measurement Mode

Measurement Mode is used for applying filters to measurements to find those that meet your defined
criteria, helping to isolate particular events within many samples. Markers appear over the source trace to
indicate the location of measurement, while the table displays values for the selected parameter that
meet the criteria. Measurement Mode settings are:

« Measurement. Choose the measurement parameter you wish to search.

« Filter Method. Choose the operator that indicates the desired relationship to the Filter Limit. Only
measurements that meet this criteria are returned.

« Filter Limit. Enter the value that completes the filter criteria.

Alternatively, you can use the Filter Wizard to create the filter criteria.
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Serial Pattern Mode

Serial Pattern Mode is used for finding 2- to 64-bit patterns in digital sequences; ideal for bursted patterns
where a PLL cannot lock. Serial Pattern Mode settings are:

« Viewing. Choose to enter the pattern as Binary or Hex(adecimal).
« Binary/Hex. Enter the pattern.

« Num. Patterns to detect. Enter a whole number.

Bus Pattern Mode

Bus Pattern Mode (-MS models only) is used for finding 2- to 16-bit patterns across the digital lines. Bus
Pattern Mode settings are:

« Viewing. Choose to enter the pattern as Binary or Hex(adecimal).
« Binary/Hex. Enter the pattern.

« Num. Patterns to detect. Enter a whole number.

Scan Views

Scan Views are different ways to view your WaveScan results. Just check the boxes at the bottom of the
WaveScan dialog for those views you wish to display simultaneously.

Note: The number of grids varies depending on which views are enabled. WaveScan handles this
function automatically, and you cannot move traces among grids as in normal operation.

Additional controls for Scan Overlay and Zoom views are on their respective dialogs. If you turn on these
traces from those dialogs, you must turn them off from there, too.

Source Trace

By default, the source trace is displayed in the top grid, with markers indicating points that meet the
search criteria.

Table

Table view displays a table of measurements relevant to your chosen Search Mode next to the source
trace. Times view adds columns to the table showing Start and Stop Times for each event.

Scan Overlay
Scan Overlay view uses colored overlays to show the location of events meeting the criteria.

oom

Zoom view works exactly as it does elsewhere in the X-Stream software, creating a new trace that is a
magnified section of the source trace. A Zx tab appears by default when you launch WaveScan; see zoom
factor controls for an explanation of the remainder of the controls found on this dialog.
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Scan Overlay
To apply monochromatic persistence to a Scan Overlay:

1.
2.
3.

4,

Select Scan Overlay when setting up the wave scan, then open the Scan Overlay dialog.
Check Persistence On.

Enter a Saturation level as a percentage. All samples above the saturation level are assigned the
highest color intensity.

Choose a Persistence Time. The higher the time, the more static the persistence display.

To adjust the scan overlay to "zoom" in or out: touch the In/Out buttons, or touch Scale and enter new
values. Check Var. to adjust scale in finer steps than the default 1, 2, 5.

Scan Histogram

Scan Histogram is an additional WaveScan "view" that generates a histogram to give you a statistical view
of edges that meet your search criteria. Set it up as you would any histogram:

—_

Enter the total #Values in the histogram buffer.
Enter the #Bins (bars) in the histogram.

Enter the Center value and Width of each bin from center, or check Enable Auto Find and let the
sofware Find Center and Width.

Choose a Vertical Scale method:

« Linear allows the histogram to build vertically as data accumulates. When the histogram
reaches the top of the display it rescales the vertical axis to keep it on screen.

« LinConstMax keeps the histogram at near full scale and rescales the vertical axis as data is
accumulated.

20.0

Find Center
and Width
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WaveScan Search

Search is used to find events in traces—usually zoom (Zx) traces—that match user-defined criteria. To
search within WaveScan:

1. Select the Zoom view.
2. After stopping the acquisition, open the Zx dialog that appears behind the WaveScan dialog.

3. Use the Prev and Next buttons to move back or forward within the trace to the events that
matched your Scan Modes criteria.

Or
If you know the WaveScan table index (row) number of the event you wish to find, enter it in Idx.
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Pass/Fail Testing

Pass/Fail testing allows you to define a set of qualifying conditions that an acquisition may "pass” or "fail'
when tested against, then take actions depending on whether the result is a pass or a fail.

« Mask testing compares sampled values to a pre-defined area of the grid (the "mask”) to see if they
fall within or without.

« Parameter comparison compares a measurement result to a pre-defined value (Param compare) or
to another measurement (Dual param compare).

You can preconfigure eight qualifiers (Qx) using either method, which are then enabled by selecting them
on the Pass/Fail dialog and defining what results constitute a "Pass" on the Actions dialog.

Mask Test Qualifiers

A mask defines an area of the grid against which a source Channel, Zoom, or Math trace is compared.
Test conditions are associated with the mask, defining how the waveform is to be compared to the
masked area (e.g., some/all values fall within, some/all values fall outside), and a pass or fail result is
returned indicating the condition was found to be true or false.

Mask testing can be done using a pre-defined mask or a mask created from a waveform with user-defined
vertical and horizontal tolerances. Some industry standard masks used for compliance testing are
included with the oscilloscope software. The mask test can be confined to just a portion of the trace by
the use of a measure gate.

Access Mask Test Dialogs
1. Choose Analysis > Pass/Fail to display the Pass/Fail dialog.
2. Touch the Qx button where you want to set up the qualifier.

3. Select Mask test.

The Qx dialog opens with the Mask test condition selected and the Test, Load Mask, Make Mask, and
Gate subdialogs displayed. On these dialogs, you manage, make, and apply gates to your mask.

135



WaveRunner 8000 Oscilloscopes Instruction Manual

Make Mask

Use this procedure to create a new mask based on a live waveform. The mask covers the area of the
waveform plus the boundaries you enter.

1. Open the Make Mask subdialog.

2. If desired, enter a new Destination File Name and path, or touch Browse and select a previous file
to overwrite. The file name should end with the .msk extension.

3. Touch the Ver Delta and Hor Delta fields and enter boundary values using the pop-up Virtual
Keypad or the front panel Adjust knob.

4. Touch Make from Trace.

Load Mask
Use this procedure in lieu of Make Mask if you have a pre-defined mask file.

1. Open the Load Mask subdialog.

2. Touse asaved.msk file, touch File and select the mask.
To use an industry standard mask, touch Standard and select the mask from the pop-up.

3. Check View Mask to display the mask over the trace.

Remove a Mask from the Display

Touch the Delete All Masks button on the Load Mask subdialog. Alternatively, open the Qx dialog where a
particular mask is set, and on the Load Mask subdialog, touch Delete.

Set Gates
Set gates to limit the portion of the waveform that is compared to the mask.

1. Open the Gate subdialog.

2. Enterthe Start and Stop horizontal divisions that mark the segment of the waveform to be tested
with this mask. This can be a whole division or a fraction of a division. Divisions are numbered 1-n
left to right.

A quick way to position the gate is to drag the gate posts initially placed at the extreme left and right
ends of the grid to the desired points.

Define "True"
1. Open the Test subdialog.
2. Select one of the conditions that, when true (yes), results in a pass.

3. Optionally, turn On markers to show where on the waveform mask violations have occurred.
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Param(eter) Compare Qualifiers

Pass/Fail qualifiers (Qx) can be configured to compare different parameter measurements (Px) to each
other or to a user-defined limit (or statistical range). The Summary field shows the logic represented by
the qualifier. Check it to ensure your selections are producing the test you want.

Comparing a Measurement to a Limit
This method compares the result of a selected parameter to a user-defined limit or statistical range.
1. Choose Analysis > Pass/Fail to display the Pass/Fail dialog.
2. Touch the Qx button where you want to set up a qualifier.
3. From the pop-up menu, choose Param compare.
4

. Onthe Qx dialog, touch Source1 and choose the parameter.

All P2 2 0.147782

Current pt § 15
Mean Sigma gme Sigma

5. Onthe ParamCompare subdialog, touch Compare Values and select All (every value must be
within limit to be "true") or Any (any value can be within limit to be "true").

6. Touch Condition and select a math operator, then touch Limit and enter the value that completes
the condition. The value entered acquires properties corresponding to the parameters being
tested. For example, if you are testing a time parameter, the unit is seconds.

7. If you chose to set a Delta limit, also enter the Absolute or % Delta value. You may choose instead
to set Limit and Delta using one of the buttons at the bottom of the dialog.

Comparing Parameter Measurements
This method compares one parameter to another, rather than a limit.

1. Choose Analysis > Pass/Fail to display the Pass/Fail dialog.

2. Touch the Qx button where you want to set up a qualifier.

3. From the Pass/Fail Condition menu, choose Dual Param Compare.

4. Onthe left-hand Qx dialog, select the parameters to compare in Source1 and Source?2.
5

. Onthe ParamCompare subdialog, choose to Compare All (every value must meet condition to be
"true") or Any (any value can meet condition to be "true").

6. Touch Condition and select the operator that expresses the relationship between parameters (e.q.,
AllP1 values must be less than P2).
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Define Pass/Fail Tests

The Qualifiers define the conditions that would result in "true" but don't in themselves determine the test
result. You must separately define what constitutes a "pass” or a "fail" on the Actions dialog. A Pass or Fail
result can be made to produce various additional actions, such as sending a pulse to another device.

1. After setting up the Pass/Fail test qualifiers, open the Actions tab.

Pass/Fail

Force Actions
Once

Clear All

2. Optionally, check Summary View to see a running summary of results over the total number of

sweeps.

3. Select the test Pass criteria in Pass If.

4. Toapply additional actions to the test result:

o Check Enable Actions to turn on actions.

« Under If, choose to apply actions if the result is a Pass or a Fail.

« Under Then, choose all the actions to apply:

Save a waveform file
Stop the test
Sound an Alarm

Emit a Pulse from the AUX OUT connector. When taking this action, also go to Utilities >
Utilities Setup > Aux Output and choose to Use Auxilliary Output For Pass/Fail.

Capture the screen and process it according to your Hardcopy (Print) selection
Create a LabNotebook Entry

Use the Clear All button to clear all the action checkboxes, or Force Actions Once to take action
once regardless of the test results.

Delay Test

You can delay the start of a test by entering the number of sweeps to wait in Start Testing After.

Touch Clear Sweeps at any time to reset the test counter.

Stop Test

To stop the test following a specified number of sweeps, rather than a Pass or Fail result, check the Stop
Test box, then enter the desired number of sweeps in After.

Stop After

1000 sweeps
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Saving Data (File Functions)

This topics in this sections explain the instrument's File menu functions.

Save/Recall features allow you to save and restore setups, waveform data, table data, screen captures,
LabNotebooks, and reports. You can use Print or E-mail to share these files.

LabNotebook is Teledyne LeCroy's proprietary tool for capturing a composite file containing waveform
data, oscilloscope setups and display, which can be output to a preformatted report. An important feature
of LabNotebook is Flashback, which enables you to restore an acquisition (and the setups used to create
it) to the oscilloscope screen simply by recalling a LabNotebook entry.

Save

Oscilloscope setups (configurations), waveform data, tabular data, and the display can all be saved in
multiple formats.

To save them all as a composite LabNotebook file, see Save LabNotebook.

Save Waveform

The Save Waveform function saves trace data either to internal memory (M1-Mx) or to a file in text or
binary format. The source waveform can be any type of trace; a channel, math function, zoom, or even
another memory. Waveform files can be recalled into an internal memory, from where they can be
restored to the display.

Note: Only files saved in Teledyne LeCroy binary format (. TRC) can be recalled to the display.

Save Waveform To Memory
1. From the menu bar, choose File > Save Waveform.

2. Choose to Save To Memory.

File Sharing Print Auto Save Email & Report Settings

=
Setup

=

e
Screen Image

3. Choose the Source trace you are saving.

4. Optionally, select Show On Save to display the memory trace along with its source as soon as it is
saved.

5. Touch the Save button directly to the left of the selected Destination memory slot. The date/time
stamp of the saved memory will appear at that location.
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Save Waveform To File

1. From the menu bar, choose File > Save Waveform.

2. Choose to Save To File.

File Sharing Print A Email & Report Settings € cLose

Save Now

E:- Meﬁw-:wry
Setup

=

L.2d
Screen Image

File

3. Choose the Source waveform. To quickly save all displayed waveforms separate trace files, touch
the All Displayed button.

4. Select afile Format:

Binary, Teledyne LeCroy's binary file format (.trc). Binary results in the smallest possible file
size, and is necessary for recalling waveforms to Teledyne LeCroy instruments. Binary files
can be converted to ASCII using Teledye LeCroy utilities such as WaveStudio.

ASClI text file (.txt). Also touch Delimiter and select a character from the pop-up menu.
MATLAB text file (.dat).

Excel text file (.csv).

MathCad text file (.prn).

Audio .wav file.

WaveML, Teledyne LeCroy's proprietary .xml format used to save persistence maps, eye
diagrams, histograms, and digital traces. This option is only active if the source is compatible.

5. Depending on your format selection, you may also need to specify a SubFormat:

Word (Binary) represents samples in the output file with 16 bits. Always use this options unless
Byte mode is "pre."

Byte (Binary) represents samples in the output file with 8 bits. This option can result in a loss of
output file resolution.

Auto (Binary) looks at the data and automatically selects either Word or Byte subformat.
Amplitude only (Text) includes amplitude data for each sample, but not time data.
Time and Amplitude (Text) includes both types of data for each sample.

With Header (Text) includes a file header with scaling information.

6. The system will auto name the file "Trace" prefixed by the source and followed by a counter
number. To change the file name or Selected Folder, enter the full path and name in File, or touch
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7.
8.

Browse and use the File Browser. By default, trace files are saved to the D:\Waveforms folder on
the instrument hard drive.

If you do not want to use the Source prefix or Counter number, deselect them.

Touch Save Now.

Save Setup

You can quickly save oscilloscope configurations to one of the internal setup panels or to a LeCroy System
Setup (.LSS) file, a text-based Automation program. Setups can be easily recalled to restore the
oscilloscope to the saved state.

Save Setup to Memory

1.

From the menu bar, choose File > Save Setup.

2. Choose to Save To Memory.

Report Ge o File Sharing Print Auto Save Ema

JuL

Waveform

i Memory

-
Setup Table
L

Lahi ]
File

L.od
Screen Image

If desired, touch one of the Setup slots and enter a name for the memory. The default name will be
Paneln. Try to select an empty slot, as anything currently in it will be overwritten.

Touch the Save button directly to the left of the selected Setup slot. The save date/time is
displayed above the Setup field.

Save Setup to File

1.

From the menu bar, choose File > Save Setup.

2. Choose to Save To File.

File Sharing Print Auto Save Email & Report Settings

JuL
LabM Waveform

\Se Save No
E:' - Memaory el e L ave Now

Setup Table
L]
File MySavedSetup-00000.Iss

=

L.2d
Screen Image

The system will auto name the file "DSOSetup" followed by a counter number. To change the file
name or Selected Folder, enter the full path and name in File, or touch Browse and use the File
Browser. By default, setup files are saved to the D:\Setups folder on the instrument hard drive.

If you do not want to use the Counter number, deselect it.

Touch Save Now.
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Save Table
The Save Table function saves tabular measurement data displayed on screen to an Excel or ASCII file.

1. From the menu bar, choose File > Save, then choose Table.

Report Generator File Sharing Print Aut Email & Report Settings

i
LabM Waveform

B =
Setup Table

=

Save Now

WySavedTable—00000.txt

Lold
Screen Image All Displayed

2. Tosave only one of the tables displayed, touch Source and navigate to the selection.

By default, data from all visible tables are saved to separate files. To quickly restore this selection,
touch the All Displayed button.

3. Choose a format of ASCII (.txt) or Excel (.csv). If you selected ASCII format, also touch Delimiter
and choose a character.

4. The system will auto name the file "Table" prefixed by the source and followed by a counter
number. To change the file name or Selected Folder, enter the full path and name in File, or touch
Browse and use the File Browser. By default, table files are saved to the D:\Tables folder on the
instrument hard drive.

5. If you do not want to use the Source or Counter number, deselect them.

6. Touch Save Now.
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Save Screen Image

The full touch screen display or selected portions of it can be captured, saved to an image file, and marked
with custom annotations.

1. From the menu bar, choose File > Save, then choose Screen Image.

Generator File Sharing Print Auto Save Email & Report Settings

Fi
JPEG - JFIF

e / Lod
E- e | \ Save Now
-

Setup
[
: nage--00000.

e Print colors use a white background < b
Screen Image

2. Choose a File Format of .JPEG, .PNG, .TIF, or .BMP.

3. Tomark up the screen image using the drawing tools, select Annotate Screen Image Before
Saving.

4. Select the Screen Area captured:

« Grid Area Only includes any visible waveform grids, tables, and descriptor boxes.

« DSO Window includes the above plus any open dialogs, menu bar, and message bar.

« Full Screen s the full Windows display, including other visible applications and desktop.
5. Choose the Colors used in the capture:

« Standard uses the screen colors on a black background as it appears on the instrument.

« Print (default) uses your print color palette (set in Preferences) on a white background to save
ink.

« Black & White captures the image in grayscale.

6. The system will auto name the file "LeCroy" followed by a counter number. To change the file name
or Selected Folder, enter the full path and name in File, or touch Browse and use the File Browser.
By default, image files are saved to the D:\Hardcopy folder on the instrument hard drive.

7. Touch Save Now.

8. If you've turned on annotations, use the Drawing toolbar to mark up the screen image. Click Done
when finished.
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Auto Save

Data that appears on the oscilloscope display, such as waveforms, measurement readouts and decoder
data, can be very dynamic and difficult to read from the oscilloscope unless you stop the acquisition.

Auto Save enables you to automatically store waveform and table data to file with each new trigger. The
file can later be recalled to the oscilloscope or saved permanently to external storage.

1.

Choose File > Save and open the Auto Save dialog.

File Sharing Print Auto Save Email & Report Settings

es\C1--00000_trc

ble--00000 txt
bles--00000.txt

Select to save Waveforms and/or Tables.
Select the Source from which to save.

By default, waveform files are stored in D:\Waveforms, and tables are stored in D:\Tables on the
instrument hard drive. Optionally:

« Enteradifferent pathin File, or Browse to and select the path.

« Enteramore descriptive root file name than "Trace" or "Table." Auto Saved files will always be
named using the Source prefix and a Counter number suffix around the root.

Choose one of the Auto Save options: Wrap (old files overwritten when buffer filled) or Fill (no files
overwritten, excess is truncated).

If you have frequent triggers, it is possible you will eventually run out of storage space. Choose Wrap
only if you're not concerned about files persisting on the instrument. If you choose Fill, plan to
periodically delete or move files off the instrument, or you will lose new data.

To enable these selections, choose Configure Auto Save from the pop-up dialog that appears.

As soon as there is a trigger, files will begin to be saved. Choose Disable Auto Save to stop saving
files while the acquisition is in process.

You can also choose Off on the Auto Save dialog to disable this feature in between acquisitions.
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Recall

Setups saved to internal memory or to .LSS file can be recalled to restore the oscilloscope to the saved
state.

Waveform data stored to . TRC files can be recalled into a memory and from there restored to the screen.

Torecall and modify saved LabNotebook files, see Recall LabNotebook.

Recall Waveform
Note: Only files saved in binary format (.trc) can be recalled to the touch screen.

1. Choose File > Recall Waveform from the menu bar.

File Sharing Print Auto Save Email & Repol

2. Touch Browse and navigate to the file.

If the file is in the Selected Folder, you can use the Up /Down Arrows to cycle through the available
files until the desired file is selected.

Optionally, touch Show only files to apply a search filter (channels, math functions, or memory) to
the list of available files.

3. Select a Destination memory slot into which to recall the file.
4. Mark Show on Recall to display the trace on the grid.

5. Touch Recall Now.
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Recall Setup

Choose File > Recall Setup... from the menu bar.

Recall Setup from Memory

1. Choose to Recall From Memory.

r File Sharing Print

Se 6 5
LabNotebook " s Recall

JuL Memaory 2 3:3 5 - Y Recall Now
Recall
Waveform

ia File
Recall al3 Recall
Setup Panel3

2. Touch one of the six Recall buttons under Recall From Internal Setup....

Note: If a setup has been stored to a location, it is labeled with the save date/time. Otherwise, the
slot is labeled Empty.

Recall Setup from File

1. Choose to Recall From File.

r File Sharing Print Auto Save Email & Report Settings

i tup-00000.Iss
LabNotebook

S \Setups\
JuL Memory Recall Now Recall Now

Waveform

= File

Setup

2. Enterthe pathto the File, or touch Browse and navigate to the desired file.

If the file is in the Selected Folder, you can use the Up /Down Arrows to cycle through the available
files until the desired file is selected.

3. Under Recall File, touch Recall Now.

Recall Default Setup
Restore the factory default settings by pressing the front panel Default Setup button. Confirm the action.

You can also restore default settings via the touch screen:
1. Choose File > Recall Setup from the menu bar.
2. Choose to Recall From File.

3. Under Recall Default touch Recall Now.
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LabNotebook

The LabNotebook feature allows you to create and save composite files containing a screen capture of all
displayed waveforms, as well as all waveform and setup data at the time of capture.

LabNotebooks can be output to a preformatted .PDF, .RTF, or HTML report. You can also upload your
own report layout if you prefer not to use the default.

The Flashback feature instantly recalls the setups and waveforms stored with LabNotebook Entries,
enabling you to restore the exact state of the instrument at a later date to perform additional analysis.

Save LabNotebook

All LabNotebook files (.LNB) are composed of a screen image (.PNG), a setup file (LSS), and a waveform
file (TRC) for each waveform displayed. When creating LabNotebooks, you choose how to handle the
screen image component, which is the basis for the Report Generator output, and to which you canadd a
description and other hand-drawn annotations.

1. Choose File > Save LabNotebook from the menu bar.

Waveform CAN Std Deco

- 2 y 0g
- Notebookl Save Now

Table

2. Optionally, enter a Description. This text appears whenever the file is recalled and on reports.

3. Tomark up the screen image using the drawing tools, select Annotate Screen Image Before
Saving.

To skip this step, deselect the checkbox. You can recall the LabNotebook later to add a description
and annotations.

4. Tochange the area of the screen captured and the colors used, touch Area/Color Preferences and
make your selections on the pop-up:

« Use Print Colors (default) uses your print color palette (set in Preferences) on a white
background to save ink. Deselect this to capture the display using the screen colors on a black
background as it appears on the instrument.

« Grid Area Only includes any visible waveform grids, tables, and descriptor boxes.

« DSO Window includes the above plus any open dialogs, menu bar, and message bar.

« Full Screenisthe full Windows display, including other visible applications and wallpaper.
Touch Close to save your changes.

5. The system will auto name the file "MylLabNotebook" followed by a counter number. To change this
to something more descriptive, or to change the file path, enter it in LabNotebook Entry, or touch
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Browse and use the File Browser to make a selection. By default, LabNotebook files are saved to
the D:\LabNotebook folder on the instrument hard drive.

Note: Changing the file path, name, or format will cause the counter to reset to the next
number in that sequence.

6. If you do not want to use autonumbering to identify files, deselect Counter.
7. Touch Save Now.

8. If you've left on annotations, use the Drawing toolbar to mark up the screen image. Click Done when
finished.

LabNotebook Drawing Toolbar

The basic LabNotebook is a screen capture of the display as it was at the time of entry, along with the
setup and waveform data. If you have selected to Annotate Screen Image Before Saving, the capture is
immediately displayed in the Drawing window. You can later add Annotations by recalling the
LabNotebook into the Preview window and choosing to Annotate Screen Image.

Markup tools are available from the toolbar along the top of the window.

[ Oll”~

El File | ¥ Vertical | +* Timebase | I Trigger | & Display = # Cursors | E| Measure @ Math | == Analysis | X Utilities | @ Support Processing: |Il| P> Default- ”."-j;

" B
| Enter label text - Drag the dotted
box to move the
callout.

To use any tool, touch the icon, then touch on the image where you wish to draw or add text. From left to
right, the tools are:

Tool Function

Pencil Draw in freehand. Maintain contact with the screen to make a continuous mark. Once you release, you
can touch-and-drag the object to any point on the image.

Circle Draw a circle around a waveform feature that you want to emphasize. Touch-and-drag across the dia-
meter of the circle. When you release, the circle is placed. You can drag the circle to any location on the
image.

Arrow Draw lines with arrowheads for placing callouts. You can rotate these lines through 360 degrees or drag

them to any location on the image.

Text Open a textbox for placing labels/annotations on the image. Touch the point on the image to place the
label, then enter the text in the pop-up dialog. Once placed, you can resize the textbox or drag it to any
location on the image.

RGB Selectors | Quickly change the line color. Just touch the color icon, then choose the next drawing tool.
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Tool Function

More Activates a Custom line color field. The default color is Yellow. To choose another, touch the color
swatch, then select from the Color dialog. You can enter RGB values, or choose from the spectrum. After
saving, the new color appears in the Custom field. This remains the markup color until you choose
another.

Erase Selected | Remove selected drawing objects. Erase All will also undo any Custom color selection.
/

Erase All

Undo Cancel the last action. Use it to restore any objects you inadvertently erased.

Move Undock the drawing toolbar so you can move it anywhere on the display. This helps to keep tools handy
when working on a particular area of a waveform. Touch the button again to restore the toolbar to the top
of the Drawing window.

Done Save the annotations with the image and close the Drawing window.

Recall LabNotebook

Once a LabNotebook Entry is saved, Recall it to view and modify descriptive information or manage
attachments and component files. Flashback to restore the oscilloscope to the state saved in the
LabNotebook file.

Choose File > Recall LabNotebook from the menu bar.
Recall Report Generator File Sharing Print

iif
LabNotebook

T ktop\CAN-FD_Eye\

Waveform

=
Setup

Flashback

Flashback restores the waveforms and setups saved with the LabNotebook Entry, so you can later analyze
the inputs that resulted in that capture. Some result data not included in Flashback are:

« Persistence data, although it is saved with the .LNB file and appears on reports.

« Histogram data over 16-bits. Histograms internally have a 32-bit resolution, but when stored into a
trace file and recalled during Flashback, they are clipped to 16-bits.

« Floating point waveforms resulting from certain math operations that have much higher resolution
than 16-bits. This extra resolution is not preserved when traces are recalled using Flashback.

« Cumulative Measurements in process when Flashback is entered. When Flashback is used, they
lose their history and show instead only the results from the stored waveforms, not including any data
taken from interim acquisitions.

1. In LabNotebook Entry, enter the path to the LabNotebook, or touch Browse and navigate to the file.
2. Touch the Flashback button.

3. Toexit Flashback, touch the Undo button at the far right of the menu bar.
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Recall and Preview
1. Enter the path to the file in LabNotebook Entry, or touch Browse and navigate to the file.
2. Touch View On/Off to open it in the Preview window.

3. While the file is in preview, you may Edit Description, Annotate Screen Image, or Manage
Attachments.

4. Optionally, choose to Save, Print, or Email the LabNotebook in the output report format shown in
the preview. Select Close to close the Preview window.

Edit Description

You can modify the description and annotations saved with the LabNotebook Entry. Setups and waveform
data originally saved with the LabNotebook cannot be changed.

1. Browse to and select the LabNotebook Entry. If the file is in the Selected Folder, just use the
Up/Down Arrow keys to select it.

. Select View On/Off to preview the file.

2

3. From the top of the preview window, choose Edit Description.

4. Touch the pop-up description to open the virtual keyboard and edit the text.
5

. Touch OK twice to save changes.

Annotate Screen Image

1. Browse to and select the LabNotebook Entry. If the file is in the Selected Folder, just use the
Up/Down Arrow keys to select it.

2. Select View On/Off to preview the file.
3. From the top of the preview window, choose Annotate Screen Image and use the drawing tools.

4. Click Done when finished to close the Drawing window and return to the preview.
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Manage Attachments

To append external files to the LabNotebook composite (such asimages of the DUT, mask files, test
scripts, or anything relevant to the entry):

1. Browse to and select the LabNotebook Entry. If the file is in the Selected Folder, just use the
Up/Down Arrow keys to select it.

2. Select View On/Off to preview the file.

3. From the top of the preview window, choose Manage Attachments and select the files to attach.
The file list will build in the lower part of the File Attachments browser.

4. Click Update Attachments to finish.

To later remove appended files, Manage Attachments and deselect the files from the list. Update
Attachments again to refresh the list.

Convert File Format
Individual entries in legacy .ZIP format Notebooks can be converted to the new LabNotebook file format.
1. In LabNotebook Entry, Browse to and select the legacy .zip file from the left side navigation pane of

the File Browser.

Note: Be sure to select the .zip file from the left pane so that its sub-entries appear in the
right pane and the Save buttons appear on the browser. The file should appear in Current
Path on the file browser.

2. Tobatch convert all entries into separate LabNotebook files, at the top of the file browser choose
Save All As LNB Files.
To convert a single entry, select it from the Name list (right side), then choose Save As LNB File.
New LabNotebooks of the same name as the original entries are created in the D:\XPort folder. These can
be selected the same as any other .LNB files for Flashback, editing, reports, or extraction.

Extract Files

The component files that make up the LabNotebook composite (.PNG, .LSS, and . TRC) and any appended
files can be extracted into separate files.

1. Enter the path to the LabNotebook Entry, or Browse to the file.
2. Toextract all files, under Content Management, choose Extract Files.
To extract only the attachments, choose Extract Attachments.
3. Navigate to the folder where you want the files extracted, and choose Extract Now.

A folder of the same name as the original LabNotebook containing the separate files will be created
at that location.
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Report Generator

The Report Generator feature allows you to output a preformatted report consisting of an annotated
screen image and a summary of the setups in place when it was captured. The report can be sourced
from an existing LabNotebook, or it can be newly generated from the current state of the oscilloscope.

The logo and output template used to create the report can be changed on the Email & Report Settings
dialog.

From LabNotebook

This procedure outputs an existing source asis. If you want to further annotate or change the description
of a LabNotebook file, first recall the LabNotebook.

1. Choose File > Report Generator from the menu bar.

Save Recall Report Generator ile Print Auto Save Email & ngs € cLose

Save Now
LabNotebook

Current State Last Saved Report File ~nare
On/ Off .

Email

2. Browse to and select the LabNotebook Entry. If it is in the Selected Folder, just use the Up/Down
Arrow keys to select it.

3. Optionally, use View On/Off to preview the selected file.
4. Choose a Save Format of HTML, .RTF, or .PDF.

Note: Only HTML reports can later be saved to .RTF or .PDF format. The .RTF and .PDF
reports can only be combined into another report of the same format.

5. By default, the system will auto name the file "Report” followed by a counter number. To change the
file name or the Selected Folder, enter the full path and name in Save Report File, or touch Browse
and use the File Browser. By default, report files are saved to the D:\Xport folder on the instrument
hard drive.

Note: Changing the file path, name, or format will cause the counter to reset to the next
number in that sequence.

6. If you do not want to use autonumbering, deselect Counter.

7. Tosave the report, choose Save Now.
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From Current State

If you are creating a report from the current state of the instrument, the procedure is much like that above,
except that you will also be able to enter a new Description, Annotate Screen Image, and select your
capture Area/Color Preferences as you would normally do when first creating a LabNotebook. See Save
LLabNotebook for an explanation of these steps.

However, when using the Report Generator from Current State, you will not have saved a composite .LNB
file that can later be recalled or extracted into its component files. You will only have the preformatted
report file.

Share

Use the File Sharing dialog to email files from the instrument. Configure the oscilloscope for email on the
Email & Report Settings dialog.

Report Generator File Sharing Print Auto Save Email & Report Settings

Select Files ma Share

MyReport—00000 htm Browse 0): o domain_com

Share Now

yReport—00000_htm M
These are the results from the latest

1. Choose File > File Sharing from the menu bar.

2. Use the File Browser to select all the files to be emailed.

Use CTRL + Click to select multiple files.
3. Optionally, change the email Recipient(s). This field defaults to whatever is in your Email Settings.

4. Enter a Subject line and Message Body, then Share Now.
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Print

Print dialog settings control how the front panel Print button behaves. Print captures an image of the
touch screen display, but there are several options as to what it does next with the image:

o Sendittoa Printer
« Copy it to the Windows Clipboard

« Save it toanimage File using your current Screen Image Preferences

Email an image file using your current Screen Image Preferences and Email Preferences

« Create a new LabNotebook file using your current LabNotebook Preferences

The Print Now button at the far right of the Print dialog can also be used to execute your Print selection.

nerator File Sharing Print Auto Save Email & Re e € cLose

= ml & ! o - Screen Area
Printer Clipboard Wny-print64\nymktgptr1 C Only =

Print N
= Orientation rint Mow
¢ s rienatic

Standard Print Buttor

File Email Action

LabNotebook

Printer Settings
If sending to a printer:

1. Touch Select Destination and choose a connected printer. Touch Properties to change any of the
printer properties using the standard Windows Print dialog.

2. Choose a paper orientation of Portrait or Landscape.

3. Select Annotate Before Saving to mark up captures before they print. Each time you press Print,
the capture will open in the Drawing Tools window. When you are Done drawing, the image prints.

Capture Settings
1. Select aScreen Area:
« Grid Area Only includes any visible waveform grids, tables, and descriptor boxes.
« DSO Window includes the above plus any open dialogs, menu bar, and message bar.
« Full Screenis the full Windows display, including other visible applications and wallpaper.
2. Choose the Colors used in the capture:
« Standard uses the screen colors on a black background as it appears on the instrument.

« Print uses your print color palette (set in Utilities > Preference Setup) on a white background

« Black & White captures the image in grayscale.
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Email & Report Settings

This dialog contains additional settings used by the File Sharing and Report Generator functions.

Report Generator i ing Print Auto Save Email & Report Settings

MAPI SMTP

mp Browse [l

es the def

Browse [

Email Settings
1. Select to use MAPI or SMTP.
2. If you chose SMTP, touch SMTP Server and enter the network address of your mail server.
3. Touch Originator Address (From:) and enter the instrument's e-mail address.
4. Touch Default Recipient Address (To:) and enter the recipient's e-mail address.
5

. Optionally, select to always Attach Setup & Waveforms associated with image files selected for
email.

6. Use Send Test Mail to send a confirmation message to ensure proper e-mail configuration.

Report Settings

The default report template uses our logo as a placeholder. You can replace this with your logo. Logo files
should be in bitmap (.bmp) format and not exceed 100 pixels high by 180 pixels wide. Place the file in the
D:\Xport folder.

You can also use your own report template. Templates must be saved as .xsl or .xslt files and placed in the
D:\Xport folder.

Deselect Use Defualt next to each item you want changed, then Browse to and select the new files.
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Using the File Browser

Selecting Browse on any of the File menu dialogs opens a File Browser that enables you to perform basic
disk utility functions, as well as making file path/name and format selections. The additional file actions
available depend on the actions available on the underlying dialog (Save file, Email report, etc.).

Recall Waveform Bro

=1 " Bl
New Folder | | Delete Folder| | Delete File Delete Al Files S Exploter Here

= [1 desktop Name Type Size Modified

| |Ethernet10GBRFrame1 trc TRC File
B n Masks

B Ethemet10GBRFrame2 trc TRC File 39
n Test LabNotebooks B Ethemet10GBRFrameSeqOrderSet tre TRC File 390 KB

= n Wave Files

DigRFV4
DisplayPort

Curent Path  C

File name : Ethernet10GBRFr: c Waveform files ("trc:” XMLdig:™ XMLy ~ Recall

Now

Show On Recall Close

Disk Utilities
New Folder, Delete Folder, Delete File, and Delete All Files can be used to change your file system prior
to saving new files. Be sure to first select the folder from the navigator or file from the file list.

File Path and Name

The Current Path is shown immediately below the navigator pane. To change it, use the navigator to
select a different folder.

To select an existing file, use the file list to the right of the navigator. The buttons immediately above the
file list let you change how items appear: icons only, details, etc. If you do not see the file you seek, try
using the drop-down next to File name to change the file type to "All files (*.*)".

Most file types have a default root file name (e.qg., "MyLabNotebook"), to which an autogenerated prefix
and/or suffix is added. To change this, enter the new File name. If you are autogenerating, the root file
name for a given file type persists until changed.
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Auto Naming Selections

The checkboxes to turn on/off the Source prefix and the Counter number suffix used to autogenerate file
names will appear on the File Browser. These selections are linked to those on the underlying dialog, and
changing the value in either place causes it to change everywhere.

Note: If you change any part of the file path/name or format on the File Browser or the dialog, the
Counter number will reset to the last number in the sequence associated with that value.

Example: Changing "Decode1-Table-0002" to "Decode 1-CANFDTable-..." will reset the counter to
"Decode1-CANFDTable-0000" if there is no prior file named "Decode1-CANFDTable-..." .

Actions

The Close button accepts the selections you made on the File Browser and closes the browser window. If
you do not need to make further entries on the dialog to complete your task, you can choose to Save,
Recall, Flashback, Email, etc. right from the File Browser.
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Utilities

Utilities settings primarily control the instrument's interaction with other devices/systems.

Preferences settings, on the other hand, tend to control the appearance and performance of the
oscilloscope application. Use these settings to personalize the behavior of the instrument.

Disk Utilities enable you to perform commonplace Windows file functions.

Utilities Dialog
To access the Utilities dialogs, choose Utilities > Utilities Setup... from the menu bar.

Utilities Status Remaote Aux Output Date/Time Options

HardCopy Setup

Date/Time Setup

System Status

Hardcopy Setup (Print), Date/Time Setup and System Status buttons open their corresponding dialogs.

There are also tabs linking to Remote Control, Aux Output, and Options settings.

Show Windows Desktop minimizes the X-Stream application window. Maximize the application by
touching the display icon located at the lower-right of the desktop.

Touch-Screen Calibration launches a sequence of display calibration screens. You will be prompted
through a series of actions to improve the precision and accuracy of the touch screen.

The Service button to the far right of the dialog launches a section of the application reserved for qualified
Teledyne LeCroy service personnel. An access code is required to enter this section.

Status

The Utilities Status dialog displays information about your instrument including model number, serial
number, firmware version, and installed hardware and software options.

Choose Utilities > Utilities Setup from the menu bar, then touch the Status tab.

Or

Choose Support > About from the menu bar.
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Remote Control

The Remote dialog contains settings to configure remote control of the instrument and also network
access. Supported remote control protocols are:

« TCPIP (Ethernet). If you choose this option, also install Teledyne LeCroy's VICP drivers on the
controller. These are included in the VICP Passport plug-in, available free from
teledynelecroy.com/support/softwaredownload under Oscilloscope Downloads > Software Utilities.
The instrument uses Dynamic Host Configuration Protocol (DHCP) as its default addressing protocol.
You can assign a static IP address using the standard Windows network setup menus.

« LXI (Ethernet)

« USBTMC (USB 3.1 Gen1). Connect a cable to the USBTMC port on the side of the oscilloscope.

« GPIB. This selection is only active if the instrument has the GPIB hardware option installed. Connect
the controller to the GPIB port.

Note: Full remote control setup requires installation and configuration of software on the
controller, as well. See the MAUI Oscilloscopes Remote Control and Automation Manual for full
instructions on making the remote connection and sending remote commands. The steps shown
here are only those performed on the oscilloscope to enable the connection.

Utilities Status Remote Aux Output Date/Time

KPIERRO-MBWT

30.7.125, 0.0.0.0, 10.30.7.124, ..

Set Up Remote Control

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.
2. Onthe Remote dialog, make a Control From selection.

3. Ifusing TCPIP and wish to restrict control to specific network clients, choose Yes under Security.
Enter the IP addresses or DNS names of the authorized controllers in a comma-delimited list.
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Utilities

Configure the Remote Control Assistant Event Log

The Remote Control Assistant monitors communication between the controller and instrument. You can
log all events or errors only. The log can be output to an ASCII file and is invaluable when you are creating
and debugging remote control programs.

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.
2. Under Remote Control Assistant, touch Log Mode and choose Off, Errors Only, or Full Dialog.

3. Toalwaysclear the log at startup, check Reset to Errors Only and clear at startup.

Export Contents of the Event Log

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.
2. Touch the Show Remote Control Log button. The Event Logs pop-up is shown.

3. Enteralog file name in DestFilename, or touch Browse and navigate to an existing file.
Note: New contents will overwrite the existing content; it is not appended.

4. Touch Export to Text File.
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Auxiliary Output

Use the Aux Output dialog to configure the output of the Aux Out port and Cal Out port.

Utilities Status emote Aux Cutput Date/Time Options

iz, 1V
Square Wave

100.000 ms

Auxiliary Output

Trigger Enabled sends a pulse when the trigger is ready (Ready indicator lit), but not necessarily triggered.
It can be used as a gating function to trigger another instrument. Enter the desired pulse Amplitude.

Trigger Out sends a pulse upon a trigger (TRIG'D Indicator lit). Enter the desired pulse Amplitude.

Pass/Fail generates a pulse when Pass/Fail testing is active and conditions are met. Enter the desired
Pulse Duration.

Fast Edge provides a fast edge signal that can be used to deskew multiple channels.

Off disables auxiliary input/output.

Calibration Output
Choose the signal to be output from the Cal Out hook on the front of the instrument:

« Square wave signal. Enter the wave Frequency and Amplitude into 1 MQ, or choose to Set to 1 kHz,
1V Square Wave.

« Reference DC Level. Enter an Amplitude into 1 MQ.

Off disables calibration output.
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Date/Time

Date/Time settings control the instrument's timestamp. These numbers appear in the message bar and
on tables/records internal to the oscilloscope application, such as History Mode and WaveScan.

To access the Date/Time dialog, choose Utilities > Utilities Setup from the menu bar, then touch the
Date/Time tab.

Utilities Status Remote Aux Output Dat Options

Set from Internet

VEILE
Changes

Manual Method
Enter the Hour, Minute, Second, Day, Month, and Year, then touch the Validate Changes button.

Internet Method

This method uses the Simple Network Time Protocol (SNTP) to read the time from time-a.nist.gov. The
instrument must be connected to an internet access device through a LAN (Ethernet) port.

If your connection is active, touch the Set from Internet button.

Windows Method

To set date and time using the internal Windows system clock, touch the Windows Date/Time button.
This displays the standard Windows Date and Time Properties pop-up dialog, where you can further
configure these settings. If you are satisfied with the setup, just touch OK.
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Options

Many optional software packages are available to extend the Analysis functions of the instrument. When
you purchase an option, you will receive a key code by email that activates the new functionality. Use the
Options dialog to activate software options by installing the key code. This dialog also displays the
ScopelD and Serial #.

Toinstall a key:

1. From the menu bar, choose Utillities > Utilities Setup, then touch the Options tab.

Utilities | Status ote | AuxOutput | DatefTime | Options

PWR_ANALYSIS

2. Touch Add Key. The Virtual Keyboard appears onscreen.

3. Use the Virtual Keyboard to type the Key Code in the Enter Option Key field, then touch OK to enter
the information.

The Key Code is added to the list of Installed Option Keys. You can use the Up/Down buttons to
scrollthe list. The software option that each key activates is displayed below the list.

4. Restart the X-Stream application: choose File > Shutdown, then double-click the Start DSQO icon on
the desktop.
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Disk Utilities
Use the Disk Utilities dialog to manage files and folders on your instrument's hard drive. Disk Space
information is shown at the far right of the dialog for convenience.

Note: These tasks can also be accomplished using the standard Microsoft Windows file
management tools. Choose File > Minimize to access the Windows desktop and task bar.

Access the Disk Utilities dialog by selecting Utilities > Disk Utilities from the menu bar.

Disk Utilities

Delete a Single File
1. Touch the Delete button.

2. Browse to the current folder containing the file.

3. Browse to the file to be deleted, or use the Up and Down arrow buttons to scroll through the files in
the folder.

4. With the desired file selected, touch Delete File.

Delete All Files in a Folder
1. Touch the Delete button.

2. Browse to the current folder containing the file.

3. With the desired folder selected, touch Empty Folder.

Create a New Folder

1. Touch Create.
2. Touch Current folder and provide the full path to the new folder, including the folder name.

3. Touch Create Folder.
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Preferences Settings

Preference settings have mostly to do with the appearance and performance of the instrument itself,
rather than its interaction with other devices/systems. These setting are also called "non-volatile,"
because they are not lost and do not change when the oscilloscope is restarted or a setup panelis
recalled.

Access the Preferences dialogs by choosing Utilities > Preference Setup... from the menu bar.

Audible Feedback controls the instrument's audio output. Select this box to hear a beep each time you
touch a screen or front panel control.

Language sets the language used on the touch screen display.
Font Size changes the size of the text that appears on the touch screen display.

Performance settings let you optimize performance for either Analysis (speed of acquisition and
calculation) or Display (speed of update/refresh). For example, if you are concerned with persistence or
averaging, you might optimize for Analysis, giving higher priority to waveform acquisition at the expense of
display update rate. Choices are presented as a spectrum.

There are also tabs linking to Calibration, Acquisition, Color, and Miscellaneous settings.
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Calibration

Calibration ensures that the output from the analog-to-digital converters (ADCs) accurately represents the
input. The instrument is calibrated at the factory prior to shipment. So that it maintains specified
performance, it is factory set to perform an automatic calibration routine upon start-up and whenever
conditions warrant it, based on your automatic calibration selection.

To maintain good performance, we recommend that you manually invoke a full calibration every six
months.

Warm up the oscilloscope for at least 20 minutes prior to use to give the instrument time to complete the
automatic calibration procedure. You will see a warning message on the Calibration dialog when the
oscilloscope is still in the warm-up phase.

Calibration Acquisition E-Mail Color Miscellaneous

Calibrate
Current State

A System is warming up.

Automatic Calibration

You have the option of selecting the automatic calibration routine used. Go to Utilities > Preference
Setup > Calibration.

Stored Calibration (the default selection) uses cached calibration files to recalibrate the instrument at
start-up. As long as the oscilloscope is used at or near sea level within a temperature range of 19-30 °C,
this calibration routine should be sufficient to maintain specified performance. The instrument will
dynamically recalibrate if the temperature goes outside of the stored calibration range. If you know you
will be operating outside this temperature range, do a Calibrate All to minimize recalibration.

The Dynamic Calibration routine recalibrates the oscilloscope at start-up and every time there is a
change in any of the acquisition settings that directly affect the performance of the ADCs, in particular
Vertical Scale, Coupling, Bandwidth, Attenuation, and Horizontal Scale. This can cause interruptions during
operation, but ensures absolute accuracy within the current operating environment at every setting. When
one setup is calibrated at a particular ambient temperature, the calibration is entered in a calibration table
and reused for the duration of the session, so that over time the frequency of recalibration decreases.
These calibration entries persist only for a single session; Dynamic Calibration restarts when the
instrument is restarted or you change the principal acquisition settings.

Manual Calibration

Two manual calibration routines can be used to recalibrate immediately before sensitive measurements
or when there is a significant change of environmental characteristics that could affect the performance
of the ADCs.

Go to Utilities > Preference Setup > Calibration to manually invoke calibration.

A Caution: Remove all inputs from the oscilloscope prior to manual calibration.
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Calibrate Current State calibrates at the current vertical and horizontal settings. This calibration takes 5
seconds but is valid for only this setup at the current temperature +2.5 °C.

Calibrate All calibrates all possible combinations of vertical and horizontal settings. This calibration is valid
for the current temperature and takes about four to five hours. Perform it when the ambient temperature
is stable from the time of calibration to the time of operation.

We recommend that you run Calibrate All when:

« Theinstrument is operating outside the 19-30 °C range and the operating temperature changes
while outside that range. Calibrate Allis only valid for + 2.5 °C of the last calibration temperature when
operating outside of the 19-30 °C range.

« Theinstrumentis moved to a new operating environment.

« It hasbeen six months since the previous manual calibration.
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Acquisition

The Acquisition preference settings determine how traces behave as Vertical Offset or Horizontal Delay
changes. To access them, choose Utilities > Preference Setup and open the Acquisition dialog.

Offset Setting constant in:
« Volts movesthe Vertical Offset level indicator with the actual voltage level.

« Div(isions) keeps the Vertical Offset level indicator stationary. The waveform remains on the grid as
you increase the gain; whereas, if Volts is selected, the waveform could move off the grid.

Delay Setting constant in:
« Time moves the Horizontal Delay indicator relative to the O point at the center of the grid.
« Div(isions) keeps the Horizontal Delay indicator stationary. The trigger point remains on the grid as

you increase the timebase; whereas, if Time is selected, the trigger point could move off the grid.

Note: The Offset value is always in the vertical unit, and the Delay is always in time. However,
whenever Div is selected, these values are scaled proportional to the change in gain or timebase,
thereby keeping the division of the grid constant.

Reset trigger counter before starting a new acquisition is selected by default. It clears the trigger
counter each time a new acquisition command is sent. It is only made active for deselection when trigger
Holdoff is set.
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Color

Color dialog settings assign the colors used for channel, math, and memory traces. All dialogs, tables, and
trace descriptor boxes will match the color of the trace assigned here. You can choose different colors to
be used on the instrument and in print.

For convenience, you can Preview print colors to see how the settings will appear in print output.

Note: Print colors are used only when the Colors control is set to Print on any of the File menu
dialogs (Save Screen Image, Print, etc.). Otherwise, the Screen colors are used for print output as
well as on screen.

To make any setting, just touch the color swatch for either Screen or Print next to the trace number, and
make a selection from the Color pop-up menu.

Touch Factory default colors to recall the original color settings for your instrument.
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Miscellaneous

These other Preference settings are located on the Miscellaneous dialog.

To add the Teledyne LeCroy logo to print output, check Print Teledyne LeCroy Logo When Printing Grid
Area Only. This identifies the instrument as the source of the image.

Dimming darkens/shades those areas of the source waveform that are not part of the Zoom trace.

Control Sensitivity adjusts the sensitivity of the front panel knobs. Optimized applies an acceleration
algorithm to the knobs. Legacy detects rotation of the front panel knobs in a manner similar to our legacy
oscilloscopes.

Serial Decode Annotation Position: If you have Serial Trigger or Decode options installed on your
instrument, this control determines the placement of annotation labels relative to the trace line. It does
not appear if there are no installed options.

« On Trace places the label close to the line.

« On Noisy Trace sets the label further from the line to accommodate potential noise spikes in the
trace.

Check Enable HTTP Screen Capture to enable remote capture of the touch screen display over a
netowrk. This setting is required to use the instrument with the WaveStudio software.
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Maintenance

Maintenance

Topics in this section describe procedures for keeping the instrument in optimal working condition.

Touch Screen Calibration

Periodically calibrate the touch screen to maintain its accuracy and responsiveness. We recommend that
you use a stylus rather than your finger for this procedure.

1. From the menu bar, choose Utilities > Utilities Setup.
2. Onthe Utilities main dialog, touch Touch-Screen Calibration.

3. Following the prompts, touch as close as possible to the center of each cross that appears on the
screen until the calibration sequence is complete.

Restart/Reboot Instrument

To restart the oscilloscope application, choose File > Exit from the menu bar, then touch the Start DSO
desktop shortcut.

Note: You will generally need to exit and restart the application after adding new options keys.

Toreboot the instrument, which includes restarting the OS:

1. From within the oscilloscope application, choose File > Shutdown from the menu bar. From the
Windows desktop, use the Windows Start Menu Shutdown command.

2. Wait 10 seconds, then press the Power button on the front of the instrument.
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Firmware Update

Teledyne LeCroy frequently releases free oscilloscope firmware updates containing new product features
and bug fixes. The installer updates multiple components including the base application, required DLLs,
drivers, and low-level microcode for integrated circuits.

The firmware update procedure does not modify or delete any saved panel setups, waveforms, screen
captures, calibration constants, or other data stored on the D: drive.

Caution: The installation may take several minutes, depending on the length of time since your last
update. Do not power down at any point during the installation process.

Exit the X-Stream application by choosing File > Exit.

Visit our download page at teledynelecroy.com/support/softwaredownload and click the link to
Oscilloscope Downloads > Firmware Upgrades.

Select your series and model number.

Enter your registration login information, or create a new account.

5. Click the download link, and choose to Save the installer to the instrument Desktop or a folder on

the D: drive. If downloading from a remote PC, save the installer to a USB storage device to transfer
it to the instrument.

Browse to the location of the installer (xstreamdsoinstaller_x.x.x.x.exe) and double-click it to launch
the X-Stream Setup wizard.

7. Onthe wizard, click Next, then read the EULA and click | Agree.

10.

Leave the default installation (recommended), or select individual components:
« Driversfor GPIBT - required for internal PCI-GPIB card.
o MATLABMCR -required for sampling scopes, QPHY-USB and QPHY-Broad-R-Reach.
o X-Stream DSO, DSO Device drivers, Upgrade DSO Microcode - required for a version upgrade.

« Touch Screen Driver - required to use the display as a touch screen (you can opt to use a
mouse).

« SPARQ Package - required to drive a connected SPARQ from the instrument.
Click Install when done.

If you receive Windows security warnings, trust and Install the file. If you see the Hardware
Programmers screen, accept all code installations, then click Close after you see that
programming has completed to return to the X-Stream Setup wizard.

When installation is complete, choose Reboot now and click Finish.
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Technical Support

Live Support

Registered users can contact their local Teledyne LeCroy service center at the number listed on our
website.

You can also submit Technical Support requests via the website at:

teledynelecroy.com/support/techhelp

Resources

Teledyne LeCroy publishes a free Technical Library on its website. Manuals, tutorials, application notes,
white papers, and videos are available to help you get the most out of your Teledyne LeCroy products.
Visit:

teledynelecroy.com/support/techlib

The Datasheet published on the product page contains the detailed product specifications.

Service Centers
For a complete list of offices by country, including our sales & distribution partners, visit:

teledynelecroy.com/support/contact

Teledyne LeCroy

700 Chestnut Ridge Road
Chestnut Ridge, NY, 10977, USA
teledynelecroy.com

Sales and Service:

Ph: 800-553-2769 / 845-425-2000
FAX: 845-578-5985
contact.corp@teledynelecroy.com

Support:
Ph: 800-553-2769
customersupport@teledynelecroy.com
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Returning a Product for Service

Contact your local Teledyne LeCroy service center for calibration or other service. If the product cannot be
serviced on location, the service center will give you a Return Material Authorization (RMA) code and
instruct you where to ship the product. All products returned to the factory must have an RMA.

Return shipments must be prepaid. Teledyne LeCroy cannot accept COD or Collect shipments. We
recommend air-freighting. Insure the item you're returning for at least the replacement cost.

1.
2.
3.

Remove all accessories from the device. Do not include the manual.
Pack the product in its case, surrounded by the original packing material (or equivalent).

Label the case with a tag containing:
o The RMA
« Name and address of the owner
« Product model and serial number
« Description of failure or requisite service

Pack the product case in a cardboard shipping box with adequate padding to avoid damage in
transit.

Mark the outside of the box with the shipping address given to you by Teledyne LeCroy; be sure to
add the following:

« ATTN: <RMA code assigned by Teledyne LeCroy>
. FRAGILE

If returning a product to a different country:
« Mark the shipment as a "Return of US manufactured goods for warranty repair/recalibration.”

« Ifthereisa cost for the service, list the cost in the Value column and the original purchase
price "For insurance purposes only."

« Be very specific about the reason for shipment. Duties may have to be paid on the value of the
service.

Extended warranty, calibration, and upgrade plans are available for purchase. Contact your Teledyne
LeCroy sales representative to purchase a service plan.
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Certifications

Teledyne LeCroy certifies compliance to the following standards as of the time of publication. See the EC
Declaration of Conformity document shipped with your product for the current certifications.

EMC Compliance

EC Declaration of Conformity- EMC

The instrument meets the intent of EC Directive 2014/30/EU for Electromagnetic Compatibility.
Compliance was demonstrated to the following specifications listed in the Official Journal of the European
Communities:

EN 61326-1:2013, EN 61326-2-1:2013 EMC requirements for electrical equipment for measurement,
control, and laboratory use. !

Electromagnetic Emissions:
EN 55011:2010, Radiated and Conducted Emissions Group 1, Class A 23

EN 61000-3-2/A2:2009 Harmonic Current Emissions, Class A
EN 61000-3-3:2008 Voltage Fluctuations and Flickers, Pst =1

Electromagnetic Immunity:

EN 61000-4-2:2009 Electrostatic Discharge, 4 kV contact, 8 kV air, 4 kV vertical/horizontal coupling planes
4

EN 61000-4-3/A2:2010 RF Radiated Electromagnetic Field, 3VV/m, 80-1000 MHz; 3V/m, 1400 MHz - 2
GHz 1V/m,2GHz-2.7 GHz

EN 61000-4-4/A1:2010 Electrical Fast Transient/Burst, 1 kV on power supply lines, 0.5 kV on I/0 signal
data and control lines 4

EN 61000-4-5:2006 Power Line Surge, 1 kV AC Mains, L-N, L-PE, N-PE 4

EN 61000-4-6:2009 RF Conducted Electromagnetic Field, 3Vrms, 0.15 MHz - 80 MHz
EN 61000-4-11:2004 Mains Dips and Interruptions, 0%/1 cycle, 70%/25 cycles, 0%/250 cycles 4°

1. To ensure compliance with all applicable EMC standards, use high quality shielded interface cables.
2. Emissions which exceed the levels required by this standard may occur when the instrument is connected to a test object.

3. This product is intended for use in nonresidential areas only. Use in residential areas may cause electromagnetic
interference.

4. Meets Performance Criteria “B" limits of the respective standard: during the disturbance, product undergoes a temporary
degradation or loss of function or performance which is self-recoverable.

5. Performance Criteria “C" applied for 70%/25 cycle voltage dips and 0%/250 cycle voltage interruption test levels per
EN61000-4-11.

European Contact:*
Teledyne LeCroy Europe GmbH
Im Breitspiel 11¢

D-69126 Heidelberg

Germany

Tel: +49 622182700
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Australia & New Zealand Declaration of Conformity— EMC

The instrument complies with the EMC provision of the Radio Communications Act per the following
standards, in accordance with requirements imposed by Australian Communication and Media Authority:

AS/NZS CISPR 11:2011 Radiated and Conducted Emissions, Group 1, Class A.

AUSTRALIA / NEW ZEALAND CONTACTS:*

RS Components Pty Ltd. RS Components Ltd.
Suite 326 The Parade West Unit 30 & 31 Warehouse World
Kent Town, South Australia 5067 761 Great South Road

Penrose, Auckland, New Zealand

*Visit teledynelecroy.com/support/contact for the latest contact information.

Safety Compliance

EC Declaration of Conformity— Low Voltage

The instrument meets intent of EC Directive 2014/35/EU for Product Safety. Compliance was
demonstrated to the following specifications as listed in the Official Journal of the European Communities:

EN 61010-1:2010 Safety requirements for electrical equipment for measurement, control, and laboratory
use — Part 1: General requirements

EN 61010-2:030:2010 Safety requirements for electrical equipment for measurement, control, and
laboratory use — Part 2-030: Particular requirements for testing and measuring circuits

The design has been verified to conform to the following limits put forth by these standards:

« Mains Power Supply Circuits: Overvoltage Category Il, instrument intended to be supplied from the
building wiring at utilization points (socket outlets and similar).

« Measuring Circuit Terminals: No rated measurement category. Terminals not intended to be directly
connected to the mains supply.

« Unit: Pollution Degree 2, operating environment where normally only dry, non-conductive pollution
occurs. Temporary conductivity caused by condensation should be expected.

U.S. Nationally Recognized Agency Certification

The instrument has been certified by Underwriters Laboratories (UL) to conform to the following safety
standard and bears UL Listing Mark:

UL 61010-1 Third Edition — Safety standard for electrical measuring and test equipment.
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Canadian Certification

The instrument has been certified by Underwriters Laboratories (UL) to conform to the following safety
standard and bears cUL Listing Mark:

CAN/CSA-C22.2 No. 61010-1-12. Safety requirements for electrical equipment for measurement, control
and laboratory use.

Environmental Compliance
End-of-Life Handling

The instrument is marked with this symbol to indicate that it complies with the applicable
European Union requirements to Directives 2012/19/EU and 2013/56/EU on Waste
Electrical and Electronic Equipment (WEEE) and Batteries.

The product is subject to disposal and recycling regulations that vary by country and region.
Many countries prohibit the disposal of waste electronic equipment in standard waste
receptacles. For more information about proper disposal and recycling of your Teledyne
LeCroy product, please visit teledynelecroy.com/recycle.

Restriction of Hazardous Substances (RoHS)
This instrument and its accessories conform to the 2011/65/EU RoHS?2 Directive.

ISO Certification

Manufactured under an ISO 9000 Registered Quality Management System.
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Warranty

THE WARRANTY BELOW REPLACES ALL OTHER WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING
BUT NOT LIMITED TO ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS, OR ADEQUACY FOR
ANY PARTICULAR PURPOSE OR USE. TELEDYNE LECROY SHALL NOT BE LIABLE FOR ANY SPECIAL,
INCIDENTAL, OR CONSEQUENTIAL DAMAGES, WHETHER IN CONTRACT OR OTHERWISE. THE
CUSTOMER IS RESPONSIBLE FOR THE TRANSPORTATION AND INSURANCE CHARGES FOR THE
RETURN OF PRODUCTS TO THE SERVICE FACILITY. TELEDYNE LECROY WILL RETURN ALL PRODUCTS
UNDER WARRANTY WITH TRANSPORT PREPAID.

The product is warranted for normal use and operation, within specifications, for a period of three years
from shipment. Teledyne LeCroy will either repair or, at our option, replace any product returned to one of
our authorized service centers within this period. However, in order to do this we must first examine the
product and find that it is defective due to workmanship or materials and not due to misuse, neglect,
accident, or abnormal conditions or operation.

The instrument's firmware has been thoroughly tested and is presumed to be functional. Nevertheless, it
is supplied without warranty of any kind covering detailed performance.

Teledyne LeCroy shall not be responsible for any defect, damage, or failure caused by any of the following:
a) attempted repairs or installations by personnel other than Teledyne LeCroy representatives or b)
improper connection to incompatible equipment, or c) for any damage or malfunction caused by the use
of non-Teledyne LeCroy supplies. Furthermore, Teledyne LeCroy shall not be obligated to service a
product that has been modified or integrated where the modification or integration increases the task
duration or difficulty of servicing the instrument. Spare and replacement parts, and repairs, all have a 90-
day warranty.

Products not made by Teledyne LeCroy are covered solely by the warranty of the original equipment
manufacturer.

Intellectual Property

All patents pertaining to the WaveRunner 8000 can be found on our website at:

teledynelecroy.com/patents/

Windows License Agreement

The oscilloscope application software runs on a Windows® operating system. Teledyne LeCroy's
agreement with Microsoft® prohibits users from installing third-party software that is not relevant to
measuring, analyzing, or documenting waveforms.
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Index

A
acquisition

optimiztion 166
pre-processing 20, 44
sampling mode 51
settings 169
action toolbar 22, 97
activating traces 31
altitude 2
analoginputs 11
attenuation 11
autonaming 157
autosave 144
auto zero 45

AUX connectors 15, 162

averaging 20,44,112,114

B
bandwidth limiting 20, 43

C
cable de-embedding 44

calibration 13,162, 167,176

Cascaded 68

channel 42
descriptor box 20
frequency 11
setup 43

cleaning 2

clock

external 56

reference 56
sample 56
color 170
compliance 177
cooling 2
copy function 113
coupling 11, 20, 43
cursor 83-84
controls 85
readout 21, 83
custom measurements 89

D
date and time 163

de-embedding 11, 44
default setup 146
degauss 45
delay 51, 169
post-trigger 51
pre-trigger 51
descriptor box 17, 20, 31
deskew 20, 44
dialogs 22
differential time measurements 108
display 14,75
controls 77,171
extended 14, 78
grid 18,79
optimization 166

persistence 81
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DisplayPort 14

E
EC compliance 177

email 153-154

EMC 177

enhanced resolution 44,114
enhanced sample rate 44
extended display 14
external monitor 14
external trigger 11

F
FET 117

file browser 156
file structure 156, 165
filtering
bandwidth 43
LabNotebook entries 156
measurements 90
noise 44,114
firmware 13
update 174
version 159
Flashback Recall 147,149
foreground trace 31
frequency 114
response 11,117
front panel 171

G
gain 43,169

gating measurements 90

GPIB 160
graphing measurements 97
grid 18,59, 76

autogrid 75

intensity 79

style 75,79

H
hard drive 165

histograms 88, 97, 122
WaveScan 133
holdoff 69
horizontal
controls 51
humidity 2

I
import

trc files 145

setup panels 146
inputs

analog 11
intensity

grid 79
interfaces 11
interleaving 52-563
interpolation 44,119
inversion 20, 44
IP address 14, 160

L
labelling traces 34, 148
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LabNotebook 17, 147-148
recall 149
save 147,154

language selection 16

logs
remote control event 161

M
markers 88

mask testing 135
math 109, 111
descriptor box 21
function setup 109
graphing 110
on parameters 92
operators 109
measurements 86, 106-108
cursors 83
custom 89
filtering 90
gating 90
graphing 97,100-101
histicons 88
list of 102
markers 88
pass/failtesting 135,137
processing web 94
readouts 86
statistics 87

measurements; status 86

memory 126-127,139, 141
descriptor box 21
memory length 52
multi-grid display 75
multi-stage triggers 67
multi-zoom 35

0
offset 169

operating environment 2
optimization 166
options 13, 164

P
parameter compare 135, 137

parameter math 92
pass/fail testing 135, 137-138
persistence 81

histogram 122

WaveScan 133
position

trace 35
post-trigger delay 51
power

standby 13
pre-processing 20
pre-trigger delay 51
preferences 166
printing 14,39, 154,171
probes 11

settings 45

tip selection 45
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processing web editor 94

Q
Q-Scape display 76-77

qualified measurements 90
qualified trigger 67

R
real-time sampling mode 52

recall

LabNotebooks 149
reference clock 15, 56
remote control 14,160, 171
reports 147,152
rescaling 120
restart/reboot 173
restore

waveforms 127
returns 176
RH 2
RIS sampling mode 53
rise and fall time 106
RoHS 179
roll sampling mode 53

S
safety 1,178

sample clock 14, 56
sample points 52,119
sample rate 52-53
sampling mode 51
real-time 52

RIS 53

roll 53
sequence 53
save
data 147
setup panels 147
waveforms 126
screen capture 39, 143,154
search 129

sequence sampling mode 53, 80

serial triggers 171
service 175-176
setup panels 141, 146-147
sinx 20, 44
software assisted trigger 72
software options 13, 164
sound 166
sparse function 119
support 175-176
system

hibernate 13

on/off 13

status 159

timestamp 163

-
tables 142

auto save 144
technical support 175-176
temperature 2

time parameters 107

184



Index

timebase 51, 169
clock 56
controls 51
descriptor box 21
top and base 106
touch screen 14,17
calibration 173
language 16
traces
3D 82
activating 32
color 170
copy 113,126
descriptor boxes 20
label 34,88, 147-148
line style 80
persistence 81
recall 145, 147
save 139, 147
turn on/off 32
track 97,100
TRCfiles 126
trend 97,100-101
trigger 59
automating 73
controls 59, 67, 69
counter 69, 169
delay 51

descriptor box 21

holdoff 69

software assisted 72

time 52,69
TriggerScan 73

U
UL compliance 178

undo 17
units 120
utilities 159

V
vertical 42

controls 43
offset 43
resolution 114
sensitivity 42-43

W
waveform files 126, 140

autosave 144
recall 145
WaveScan 129
WaveStudio 171
WEEE 179
Windows
dialogs 16
networking 14
power settings 13

X
XWEB 94

XY plots 80
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4
zoom 29, 32,35

controls 35, 171
descriptor box 21
multi-zoom 35

undo 17
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